1Password on Mastodon

Chromebook generates incorrect TOTP after sleep.

robert1probert1p
Community Member

After logging into my Chromebook, the TOTPs generated by 1Password are fine. However, after the Chromebook screen times out (i.e. goes to sleep), the TOTPs are no longer correct. The only way I've found to fix the issue, is to log out of my Chromebook and log back in.

Unsuccessful attempts: Confirmed the Chromebook's time zone and clock settings are correct; also tried changing and restoring them. Exited and restarted the 1Password app. Upgraded from 7.9.4 to 8.9.3; (i.e. both versions have have the issue). On the same Chromebook, two different Google users (each with their own 1pw account) experience the same issue.


1Password Version: 8.9.3
Extension Version: Not Provided
OS Version: Chromebook 107.0.5304.110
Browser:_ Not Provided
Referrer: forum-search:topt

Comments

  • Hi @robert1p, thanks for writing in with this issue.

    I'd like to ask what indication you've seen that the TOTPs are incorrect? Are you comparing them by viewing the same items in another 1Password app or do they fail to allow you to sign in? If you're comparing them to TOTPs on another device, do they ever match or cycle through the same TOTP?

    On the same Chromebook, if you sign in on 1Password.com or sign in to the 1Password extension do the TOTPs match what you see in 1Password for Android on that Chromebook or are they correct?

    Thanks again!

  • robert1probert1p
    Community Member
    edited December 2022

    When attempting to log in with the TOTP it fails. So then we compare to the phone app, and see that they differ; both the Chromebook and phone app change values at the same time, but the values differ. If we use the TOTP from the phone app, we can login from the Chromebook. When we log out/in on the Chromebook, we see that the Chromebook generated TOTPs are now in sync with the phone app; i.e. they change with the correct value at the same time as the phone app.

  • Hi @robert1p, thanks for those additional details.

    I'd like to ask you to send us a message at [email protected] so we can look in to this issue more closely. With your message, please include a description of the issue. You'll get an auto-reply from BitBot which gives you a support number, that looks like [#ABC-12345-123], and if you post that here, I'll make sure your message gets to the right place. Thanks again!

  • robert1probert1p
    Community Member

    [#ZFH-53865-393]

  • robert1probert1p
    Community Member

    Update: This issue occurred when visiting family in the state next door (same time zone). It was easily reproducible by both my brother and myself the 7 days we were there; i.e. both our 1pw accts showed the same issue. It only occurred on the Chromebook; my laptop and our phones were fine. Now that I've returned home, the Chromebook no longer has the issue. [It will be a 4-8 weeks before my next visit, where I'll confirm that it still occurs there.]

  • Hello @robert1p, thanks for the update. That is certainly a peculiar issue and I would definitely be curious to know if it pops up again when you next visit your family. If there's anything else I can help with at this time, just let me know!

  • robert1probert1p
    Community Member
    edited January 24

    Ok, I'm visiting family again and I am able to reproduce the issue. I first tried hitting the lock screen button and immediately logging back in; however, after 3 tries, it did not reproduce the issue. I then shut the cover and let it sit a couple minutes. Upon opening it back up, it did reproduce the issue. (Makes me wonder if the app is reading a fresh time when it wakes up.)

    Just for grins, I hit the lock screen and instead of logging back in immediately, I left it there for 2 minutes. Upon login, the values were still in sync. Thus, it does seem to point to wake-from-sleep being the issue.

    I just put the chromebook to sleep and then immediately woke it back up and found the values still in sync; HOWEVER, the OTP countdown has drifted between the two. I repeated this and they drifted further. It's almost like the app is either not reading the current time or it is using a timer that is based on passing seconds instead of referencing the clock (i.e. no seconds pass for the app when the device is asleep).

  • robert1probert1p
    Community Member

    After further testing, I found the Web Extension on the Chromebook stays in sync with my phone and laptop. It is only the App installed on the Chromebook that has the issue. When I first start, the App & WebExt are both in sync. After I put the Chromebook to sleep, I wake it back up to find the App countdown timer is now ahead of the of the WebExt, phone, & laptop by about 18 seconds.

    I repeat the sleep test waiting 30 seconds before wakeup, and now find the App is generating TOTP values in the future; i.e. the value the App currently shows will eventually be generated by the WebExt, phone, and laptop in another 50 seconds.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file