Unable to upgrade or fresh install

Community Member

I had 1P8 installed and for over 2 months it kept failing to update so I uninstalled it, deleted the %LOCALAPPDATA%\1Password folder and restarted my computer.

Then I downloaded the latest version from https://my.1password.com/apps and tried installing it. Same error:

I am on my work PC with McAfee installed and no access to control it. However it's up-to-date, never had this issue before and I have access to McAfee logs and I cannot find anything that would indicate McAfee blocking the installation.

No matter how many times I try I get the same logs (with completely new %LOCALAPPDATA%\1Password folder recreated on each attempt):

[2022-12-08 16:41:55.146153 +02:00] INFO [op_windows_starter::installer] op-windows-starter\src\installer.rs:602: Setup logs path set to : C:\Users\redacted\AppData\Local\1Password\logs\setup
[2022-12-08 16:41:55.148793 +02:00] INFO [op_log::private] foundation\op-log\src\private.rs:70: system locale detected as 'en-US'
[2022-12-08 16:41:55.148851 +02:00] INFO [op_log::private] foundation\op-log\src\private.rs:70: selected translations for EN_US based on detected locale en-US
[2022-12-08 16:42:34.367519 +02:00] INFO [op_windows_starter::installer] op-windows-starter\src\installer.rs:516: Starting fresh install to 80910043
[2022-12-08 16:42:34.551483 +02:00] INFO [op_windows_starter::installer] op-windows-starter\src\installer.rs:288: Copying files to C:\Users\redacted\AppData\Local\1Password\update
[2022-12-08 16:42:34.552597 +02:00] INFO [op_windows_starter::transaction] op-windows-starter\src\transaction.rs:70: copying files to: C:\Users\redacted\AppData\Local\1Password\update\8
[2022-12-08 16:42:36.640174 +02:00] INFO [op_windows_starter::installer] op-windows-starter\src\installer.rs:292: Renaming C:\Users\redacted\AppData\Local\1Password\app to C:\Users\redacted\AppData\Local\1Password\previous
[2022-12-08 16:42:36.640208 +02:00] INFO [op_windows_starter::transaction] op-windows-starter\src\transaction.rs:128: renaming C:\Users\redacted\AppData\Local\1Password\app to C:\Users\redacted\AppData\Local\1Password\previous
[2022-12-08 16:42:36.804384 +02:00] INFO [op_windows_starter::transaction] op-windows-starter\src\transaction.rs:170: renaming C:\Users\redacted\AppData\Local\1Password\app to C:\Users\redacted\AppData\Local\1Password\previous
[2022-12-08 16:42:36.804726 +02:00] INFO [op_windows_starter::installer] op-windows-starter\src\installer.rs:300: Renaming C:\Users\redacted\AppData\Local\1Password\update to C:\Users\redacted\AppData\Local\1Password\app
[2022-12-08 16:42:36.804759 +02:00] INFO [op_windows_starter::transaction] op-windows-starter\src\transaction.rs:170: renaming C:\Users\redacted\AppData\Local\1Password\update to C:\Users\redacted\AppData\Local\1Password\app
[2022-12-08 16:42:36.806648 +02:00] ERROR [op_windows_starter::transaction] op-windows-starter\src\transaction.rs:54: failed to rollback rename of C:\Users\redacted\AppData\Local\1Password\app to C:\Users\redacted\AppData\Local\1Password\previous. Error: The system cannot find the file specified. (os error 2)
[2022-12-08 16:42:37.117185 +02:00] ERROR [op_windows_starter::installer] op-windows-starter\src\installer.rs:169: failed to move app files. Error: Io(PermissionDenied)
[2022-12-08 16:42:38.711589 +02:00] INFO [op_windows_starter::installer] op-windows-starter\src\installer.rs:374: starting C:\Users\redacted\AppData\Local\1Password\app\8\1Password.exe 
[2022-12-08 16:42:38.712181 +02:00] ERROR [op_windows_starter::installer] op-windows-starter\src\installer.rs:201: Failed to start previous app. Error: The system cannot find the path specified. (os error 3)

1Password Version: 8.9.10
Extension Version: Not Provided
OS Version: Windows
Browser:_ Not Provided


  • Hello @lazybeaver,

    Thanks for your message and sorry for the troubles you had with the updates and currently, the reinstallation of 1Password 8.

    The message you are seeing in the logs typically relates to the folder being locked down or not available, causing the installation to fail. To help us beeter understand if the antivirus or other antimalware is causing the troubles here, are you able to try restarting Windows in Safe Mode with Networking Enabled to see if the installation completes?

    If this was possible and helped, I'd next suggest turning to your security software. While I understand you are not able to control it, would you be able to reach out to your IT team to excluded the entire 1Password directory and the 1Password.exe in any security software you have running, then try rebooting your device. The 1Password directory can be found here - %localappdata%\1Password and the 1Password.exe is here: %localappdata%\1Password\App\8.

    If you have any additional questions or concerns, please let us know!

This discussion has been closed.