1Password on Mastodon

1Password doesn't work in my Brave web browser

romadromad Member
Community Member

Brave Version 1.46.144 Chromium: 108.0.5359.128 (Official Build) (x86_64)

1Password Extension is installed and enabled.

No 1 Password icon visible.

1 Password doesn't activate when I click in a log in box, so I have to copy-and-paste from the 1Password 7.9.8 application.

What am I missing?


1Password Version: 7.9.8
Extension Version: 2.5.1
OS Version: MacOS 10.13.6
Browser:_ Brave

Comments

  • Joy_1PJoy_1P

    Team Member

    Hey @romad, if the extension is installed and enabled, then you'll want to follow the steps here to pin the extension to your toolbar in Brave: https://support.1password.com/missing-browser-button/#brave

    Does that help? If you are still unable to use 1Password in Brave, please let us know.

  • romadromad Member
    Community Member

    @Joy_1P, All that did was pin the icon to the toolbar; it still shows 1Password as locked (it isn't, I unlocked it directly) and nothing happens when I click on the pinned icon.

  • Joy_1PJoy_1P

    Team Member

    @romad Glad to hear that you were able to pin the 1Password icon to the toolbar. However, it sounds like the extension is having a hard time communicating with the 1Password app in order to unlock. To fix that, please try the following:

    Turn on 'Keep 1Password in the menu bar' in the 1Password app settings
    1. Open the 1Password app.
    2. Click 1Password in the top left corner and select Settings.
    3. Under the General section ensure "Keep 1Password in the menu bar" is checked.

    Reset the connection between the app and extension
    1. Right-click the 1Password icon in your browser toolbar and choose Settings.
    2. Under General, disable "Integrate with 1Password app".
    3. Fully quit 1Password app and browser.
    4. Restart the 1Password app and then open browser.
    5. Right-click the 1Password icon in your browser toolbar and choose Settings.
    6. Under General, re-enable "Integrate with 1Password app".
    7. Test things out with the extension.

    Please let us know how that goes.

  • romadromad Member
    Community Member
    edited December 2022

    @Joy_1P Still doesn't work.

    The 1Password icon in the tool bar shows it as still locked even though I have launched and unlocked 1Password.app first:

    Clicking on the toolbar icon opens this window:

    but nothing happens when I click on the "Open 1Password" button.

    I still tried it out but 1Password never activated in Brave.

    BTW, I'm using the MacOS version of 1Password so the text is slightly different from what you wrote in the "Turn on..." paragraph above.
    In step 2, it is Preferences instead of Settings, and in step 3, instead of the word "Keep" it is "Show".

  • Joy_1PJoy_1P

    Team Member

    @romad sorry about that. Are you able to reproduce the behavior and then send us the following so that we can investigate further?

    Attach the logs and diagnostics to an email message addressed to [email protected]

    With your email please include:

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks!

  • romadromad Member
    Community Member

    @Joy_1P
    Here is the Support ID #: [#EDB-47731-684]

    As a precaution, I shutdown Safari and had only the Brave web browser running when I went through the steps.

  • ag_tommyag_tommy

    Team Member

    @romad

    I found that report. Thanks!

    ref: EDB-47731-684

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file