1Password on Mastodon

Running op under WSL with systemd turned on gives error message

thisdevdanethisdevdane
Community Member
edited December 2022 in CLI

Running op under WSL when having the new systemd support turned on will give the following error message:

❯ op whoami
couldn't start daemon: open /run/user/1000/op-daemon.pid: permission denied
Shorthand:    my
URL:          https://my.1password.com
<info removed>

I have XDG_RUNTIME_DIR=/run/user/1000/ in my environment and the uid of the running user is 1000.

Any idea if this message can be fixed? I tried just as a temp fix setting OP_CACHE=false but that still produces the message

EDIT: Specifically it's Debian 11 under WSL


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Browser:_ Not Provided

Comments

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file