ssh-agent on windows 11 does not work. Is there some trick I'm missing or something?

Community Member

The native ssh client in Windows 11 does not appear to be working with ssh-agent in 1Password. I have to export the key into the .ssh directory in order to get in. What am I missing or doing wrong?
Here is what happens if I don't export the key

Received disconnect from x.y.z.a port 22:2: Too many authentication failures
Disconnected from x.y.z.a port 22


1Password Version: 8.9.10
Extension Version: 2.5.1
OS Version: Windows 11
Browser:_ Firefox
Referrer: forum-search:ssh-agent


  • Hi @siggib:

    Just to confirm, have you disabled the Windows OpenSSH Authentication Agent from services.msc?

    Let me know.


  • siggib
    Community Member

    Yep, Just checked to confirm and the service is disabled. Also once I export the key and put it in .ssh as id_ed25519 then I get a windows security popup that says that 1password is asking to allow windows terminal to use one of my keys, and names my key by the name I've got it stored in 1password. But if I delete id_ed25519 from .ssh then I get an immediate auth failure.

  • Hi @siggib:

    In that case, I'd like to ask you to create a diagnostics report from your Windows PC:

    Sending Diagnostics Reports (Windows)

    Attach the diagnostics to an email message addressed to

    With your email please include:

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks very much!

  • siggib
    Community Member

    Hello there! 👋

    My human friends have received your follow-up email from your conversation in the forum and they'll be back with you shortly.

    For your reference, this is your support ID:


    Please include the full support ID (including the brackets) in the subject of any follow-up emails so we can keep things organized. Also post the support ID back in the forum discussion if requested.

    Thanks again for reaching out to us about 1Password. We look forward to helping you! 🙂

    BitBot, and the entire 1Password team ❤️🇨🇦

  • Great thank you @siggib! We'll be in touch soon. Keep an eye out!


  • dieter_k
    Community Member

    Did this get resolved? I'm having the same issue.

    • Windows 11 22H2
    • Windows Terminal Version: 1.17.11461.0
    • 1Password for Windows 8.10.7 (81007041)
  • aggieben
    Community Member
    edited September 2023

    I also am having a similar issue; I followed the instructions in the docs, and the Settings dialog shows that the agent is "Running", but the named pipe it should be using (\\.\pipe\openssh-ssh-agent) doesn't exist:

    λ gci \\.\pipe\ -filter *ssh*

    Update: when I looked in the logs, it became apparent that the agent actually failed to start, even though the UI said it was "Running". Two errors in the logs occurred, neither one of which were surfaced in the UI at all.

    ERROR 2023-09-07T15:36:08.306 tokio-runtime-worker(ThreadId(2)) [1P:ssh\op-ssh-agent\src\] Unable to start agent, another process is already listening
    ERROR 2023-09-07T15:36:08.307 tokio-runtime-worker(ThreadId(2)) [1P:C:\builds\dev\core\core\ssh\op-agent-controller\src\] LocationUnavailable
    ERROR 2023-09-07T15:36:08.307 tokio-runtime-worker(ThreadId(2)) [1P:ssh\op-agent-controller\src\] SSH Agent failed to start.
    ERROR 2023-09-07T15:38:46.747 tokio-runtime-worker(ThreadId(7)) [1P:op-ui\src\ssh_key_decryption\] Error processing imported private key: invalid passphrase provided

    The fix was to disable the agent, quit 1Password, start it back up, unlock it, and then enable the agent again, and that seemed to do that trick.

This discussion has been closed.