1Password on Mastodon

1Password browser extension in Safari Technical Preview will not unlock, though it works elsewhere

For some time now (I think since 2.4.1), on my 2019 Intel iMac , I can no longer get 1Password Safari Extension to unlock from within Safari Technology Preview. When I click the 1Password icon within that browser's toolbar (which shows lock symbol as part of the 1Password toolbar icon), the traditional locked panel shows up. When I click on the one and only button on the panel ("Open 1Password") nothing happens. Within MacOS's settings I've set Safari Technology Preview to be my default web browser, and it is up-to-date (as of this writing "Release 161 (Safari 16.4, WebKit 18615.1.17.6)." The 1Password Extension opens without any trouble on Safari and Mozilla Firefox and the helper app in the Mac's menu bar works as expected. I have tried quitting the browser and 1Password. Neither of those steps work. I have tried rebooting the computer. That hasn't helped. I have tried disabling and re-enabling the browser extension within STP's settings. Frustratingly, nothing I have tried so far (short of uninstalling and re-installing 1password itself -- who would want to do that?) has worked.

Any thoughts on how I can get around this problem? As you might imagine, the value of 1Password is significantly reduced if its integration in my primary browser won't work.


1Password Version: 8.9.12 (80912010)
Extension Version: 2.4.1
OS Version: macOS 13.1 (22C65)
Browser:_ Safari Technology Preview
Referrer: forum-search:Safari Technology Preview 2.4.1

Comments

  • SkyweirSkyweir
    Community Member

    Same here with identical software versions. The installation of 25.1 1Password plug-in has not changed the locking problem.

  • cwisniewskicwisniewski
    Community Member

    A day later and still no response, but coincidentally a newer version of 1Password for Safari was released in the last day, so I installed that --- so now running 2.5.1 -- but there is not much different happening. The release notes for this new update refer to now-fixed problems with the extension unexpectedly locking itself. So I was hopeful that updating the extension would fix my issue. The one small difference that I notice is that, now, when I launch the browser, the 1Password iconic the browser's toolbar initially shows itself in unlocked state (no lock symbol on 1Password icon in browser's toolbar). Soon enough, though, and faster than I can click on it, the lock icon is rendered on the toolbar button. Today, even after successfully updating to version 2.5.1, I uninstalled the extension and then reinstalled it. Unfortunately, no change in behavior: it's still un-openable on Safari Technical Preview but works fine on standard Safari.

    I would sure appreciate some thoughts

  • cwisniewskicwisniewski
    Community Member

    Seven days later -- and still no response? Am I mistaken about where to get help with the product? Should I send an inquiry directly to technical support's inbox?

  • steph.gilessteph.giles

    Team Member

    Hey @cwisniewski, @Skyweir,

    I'm so sorry that you had not yet received a response.

    I think it would be useful if we could take a closer look at some logs and what may be going wrong here. I'd like to ask you to send over a console log from your browser as well as a diagnostics report:

    Please attach the reports to an email message addressed to [email protected] with a link to this thread.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks very much!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file