1Password Provisioning Script Issue

nathandigiservice
nathandigiservice
Community Member
edited February 2023 in CLI

I am working on a script to provision new users, and I am having an issue with the 1Password cli. Although I am in the group "Provision Managers" it always gives me the error [ERROR] 2023/02/22 10:42:24 You are not in the Provision Managers group.
And yet, if I run the command directly in the terminal, it works fine. Wondering if this is some env variable or something for which there is a simple fix that I am overlooking. New to 1Password, super intrested in getting some scripting working, any help is greatly appreciated.


1Password Version: 8.10.0
Extension Version: Not Provided
OS Version: Ubuntu 22.04.2 LTS x86_64
Browser:_ Chrome

Comments

  • Hi @nathandigiservice:

    First I'd like to apologize for the delay here. Just as a quick first check, if you run op whoami in both your script, as well as in your terminal, are you using the same user? Let me know.

    Jack

  • nathandigiservice
    nathandigiservice
    Community Member

    Hi @Jack.P_1P,
    Thanks for getting back to me.
    Yes, I tired that as well as checking the group status, everything looks good (same user/correct account) both from script output and from directly running it. Real mystery to me as to why I still get "[ERROR] 2023/03/14 09:35:24 You are not in the Provision Managers group." (Also tested 'op group ls' in script and directly, output macthed up fine)

  • Hi @nathandigiservice:

    In that case, we'll likely need to take a closer look at your specific setup. Can you please email in to [email protected] mentioning you need some help with 1Password CLI, and we'll continue our conversation there.

    Jack

This discussion has been closed.