1Password on Mastodon

SSH Agent without Windows Hello is causing "ssh authorization prompt timed out" error

Community Member
edited March 16 in SSH

I am attempting to use the SSH Agent without Windows Hello (I am using the nightly build since this functionality is not yet in the production release). When I try a git clone command the 1Password prompt appears as expected but when I enter my password and click Authorize the green check appears in the password field and the authorize button turns into a loading icon. It stays this way until it times out. When that happens I get the message,

sign_and_send_pubkey: signing failed for RSA "GitLab" from agent: communication with agent failed

and the 1Password log has the entries,

INFO  2023-03-16T18:04:13.720 op_executor:invocation_loop(ThreadId(16)) [1P:op-app\src\app\backend\auth_prompt.rs:47] invoked auth prompt unlock
INFO  2023-03-16T18:05:06.936 tokio-runtime-worker(ThreadId(2)) [1P:ssh\op-ssh-agent\src\lib.rs:355] ssh authorization prompt timed out

Git version is git version 2.27.0.windows.1, I also tried git version 2.40.0.windows.1.
I have tried a variety of Windows SSH ports including,

OpenSSH_for_Windows_8.1p1, LibreSSL 3.0.2
OpenSSH_for_Windows_8.6p1, LibreSSL 3.3.3
OpenSSH_for_Windows_8.9p1, LibreSSL 3.4.3
OpenSSH_for_Windows_9.2p1, LibreSSL 3.6.1

I made sure to disable the OpenSSH Authentication Agent Windows service and added sshCommand = C:/Windows/System32/OpenSSH/ssh.exe to my .gitconfig file.

I'm not sure if this is a defect or if I have made a mistake in my setup. Any help would be appreciated.

1Password Version: 1Password for Windows 8.10.3 (81003015)
Extension Version: Not Provided
OS Version: Windows 10 Pro version 22H2
Browser:_ Not Provided
Referrer: forum-search:ssh authorization prompt timed out


  • floris_1Pfloris_1P

    Team Member

    We haven't heard that before. Does this happen consistently? Could you record a video of it?

  • maxlefevremaxlefevre
    Community Member
    edited March 16

    Yes, every time. Sometimes the first try doesn't trigger the prompt, not sure why. You can also see this in the video. I have converted it to gif due to file type restrictions and attached it here.

  • akschuakschu
    Community Member

    I also want to use ssh-agent without Windows Hello because my hardware doesn't support it and even if it did I wouldn't trust poor biometrics to my 1password account access. I installed the latest beta of 1password but the windows hello as well as the ssh agent options are greyed out. What are my options to getting ssh agent access working without trusting biometrics. This works on my mac just fine.

  • maxlefevremaxlefevre
    Community Member

    You need to switch to the nightly build to get access to it without Windows Hello. I was able to get the agent running but I am still facing the above issue. It may work better for you though.

  • MartonS1PMartonS1P

    Team Member

    Thanks for reporting this issue, @maxlefevre. We have not been able to replicate this bug yet and we will probably need more info from you. Could you join the 1Password Developers Slack workspace and DM me @1Password Marton ?


    I will ask you for a couple more details and work together with you to reproduce and resolve the issue. Afterwards I will update this thread with the solution we found.

  • akschuakschu
    Community Member

    My 1password does exactly the same thing. ssh-agent -l shows my keys and when I ssh I see the same 1password access requested window, type password and click authorize and I see green check and spinning wheel.

  • MartonS1PMartonS1P

    Team Member

    We have fixed this issue in the latest nightly: 1Password for Mac 8.10.4 (81004010)

    Please update to the latest nightly and let us know if you run into any other issues.

  • maxlefevremaxlefevre
    Community Member

    This is fixed now as of 8.10.4 (81004010). Thank you for all your help @MartonS1P

  • Jack.P_1PJack.P_1P

    Team Member

    On behalf of Marton, and everyone else involved, you're very welcome!


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file