Password filling twice

rogerl50
rogerl50
Community Member

When I use the browser extension with the fingerprint activation to unlock, and if there is only one entry for the site in question, the password field fills twice. As far as I can tell, this happens on every site. I don't know if it happens if/when I'm forced to activate the extension by typing my password. Works fine on mobile I think.


1Password Version: 1Password for Mac 8.10.3 (81003012)
Extension Version: Not Provided
OS Version: macOS 11.7.4
Browser:_ Firefox 110.0.1
Referrer: forum-search:password enters twice

Comments

  • Joy_1P
    Joy_1P
    1Password Alumni

    Hey @rogerl50, it looks like you emailed us about this. We've sent you a response. Let's keep the conversation in the email so that there's no back and forth. Thanks and let us know if you need more help.

    ref: LZC-49383-717

  • talbet
    talbet
    Community Member

    I have the same problem, is there a solution that can be shared?

  • Hi @talbet, thanks for reaching out!

    Can you confirm if your browser is Firefox and if you're using Universal Autofill to autofill your login details?

    Looking forward to hearing from you!

  • talbet
    talbet
    Community Member

    Hi @david.m_1P, yes I am using Firefox and Universal Autofill.

  • Thanks for confirming, @talbet!

    Are you using the latest version of Firefox (Version 113.0) when this occurs? If not, can you update Firefox using the following steps:

    1. Open Firefox.
    2. Click Firefox in the Mac menu bar.
    3. Select "About Firefox".
    4. Let Firefox finish checking for updates, then if available, click to update and relaunch Firefox.

    Once fully up to date, can you let us know if you're still able to re-create this behaviour?

  • talbet
    talbet
    Community Member

    I can confirm that this is still happening on the latest Firefox (v113). When 1password is unlocked, and I use a hotkey to fill a password, everything works fine.

    However, when 1password is locked:

    • I use a hotkey to fill a password,
    • the unlock screen comes up
    • when I unlock 1password the password field is filled twice.

    The username and password is filled instantly on unlock, however around a second after the unlock, the password is filled and appended again resulting in a double password.

  • Thanks for trying that out, @talbet!

    I can confirm that this behaviour is due to a known issue that our development team is aware of and investigating. It appears to only occur when using the keyboard shortcut for Universal Autofill to fill a page opened in Firefox while 1Password is locked. I've added you to the list of affected users and apologize for any inconvenience.

    Aside from ensuring that 1Password is unlocked before using the keyboard shortcut for Universal Autofill, you can try the following steps as a workaround when 1Password is locked as well:

    1. Navigate to the website you'd like to fill on.
    2. Press Command + Shift + Space to access the Quick Access menu.
    3. Unlock 1Password once prompted, then the Quick Access menu will appear.
    4. Ensure that the correct item is highlighted and press the Return key to autofill the item on the webpage.

    Let us know if you have any questions!

    ref: dev/core/core#19106

  • npb
    npb
    Community Member

    Hello, I have this issue daily. Please add me to the list.

    Universal autofill is on. MacOS 13.5.1, 1Password 8.10.13 (81013005), Extension 2.14.1, Firefox 117.0.

  • Hey @npb,

    I have added your report, I'm sorry for the disruption.

    I hope the workaround above helps in the meantime.

    ref: dev/core/core#19106

  • rcork
    rcork
    Community Member

    Add me to the list of impacted users. Looking forward to a fix but the workaround works for now.

  • Thanks for letting us know this is impacting you as well, @rcork! I've added you to the list of affected users.

    ref: dev/core/core#19106

  • ticuliced
    ticuliced
    Community Member

    I'm not sure if I understand the issue here correctly, but I am experiencing 1password pasting the password into the password input twice "back-to-back" in some cases. Is this what is described here? If so, what is the timeline of a fix for this?

  • Hey @ticuliced,

    Can you let me know the steps you are taking to fill so I can check to see if you are running into the issue mentioned above? Are you using a keyboard shortcut?

  • ticuliced
    ticuliced
    Community Member
    edited December 2023

    Hey @steph.giles apologies for the delayed response. I am not sure when it occurs because it does so seemingly at random. It just did happen, however, when trying to log in to 1password.com, but has happened with various sites before. I am using the keyboard shortcut (⌘+\), yes.

  • Hey @ticuliced,

    Thank you for getting back to me.

    In the issue listed above, 1Password is filling the password twice in Firefox if you used the shortcut when 1Password is locked.

    Does the workaround listed here help at all: https://1password.community/discussion/comment/685928/#Comment_685928

    Apologies for the disruption.

  • ticuliced
    ticuliced
    Community Member

    Hi @steph.giles, yes, know that you say it, that is indeed the case. I must have overlooked the previous answer – it sounds like it might be that. Though I just tried to disable 'Universal Autofill' and it is still happening – so I am actually unsure?

    In any case, as this is a known issue: Is there any timeline for a fix, given that it was reported back in March, already?

  • Dave_1P
    edited December 2023

    @ticuliced

    Thanks for the reply. How did you turn off Universal Autofill? If you removed the system permission then you might need to fully close 1Password from the menu bar and then reopen it before those changes take effect.

    Just to confirm: does the workaround in the previous post help?

    Is there any timeline for a fix

    I don't have an ETA to share at the moment, the issue is still in our developer's backlog to be further investigated and fixed in the future. Thank you for your continued patience.

    -Dave

  • ticuliced
    ticuliced
    Community Member

    @Dave_1P I turned it off in the 1Password settings (Settings > General >Autofill > "Submit automatically with Universal Autofill") – does that not actually turn it off? Yes, the problem only occurs when 1Password is locked, so unlocking it first does seem to be a viable workaround.

  • @ticuliced

    Thanks for the reply. Turning off that option just means that the login won't be automatically submitted by having 1Password click on any "Login" or "Next" buttons in the login form after filling your password. Universal Autofill will still fill your credentials but will leave clicking the login button to you.

    I'm happy that the workaround provides some help. I'm sorry again for the inconvenience.

    -Dave