1Passs Chrome Ubuntu not working

Options
zan2
zan2
Community Member

Hello everyone,

I've been a long-time user of 1Password and absolutely love the platform. It has greatly helped me centralize all my passwords. However, I recently encountered an issue where the 1Password extension stops functioning in Chrome. It doesn't open in any of the usual form fields, nor does it respond when I click on the extension icon.

I have already attempted to reinstall the extension, but it didn't solve the problem. The only temporary workaround I found is to forcefully close Chrome using 'xkill' and then reopen it. Interestingly, I noticed that prior to experiencing this issue, the console gets flooded with messages, as shown below:

I'm using Ubuntu 22.04.2 LTS, Chrome Version 113.0.5672.92 (Official Build) (64-bit), and the latest version of 1Password.

Has anyone else encountered a similar problem with the 1Password extension in Chrome? I would greatly appreciate any insights or suggestions on how to resolve this issue. It's quite inconvenient to rely on the workaround mentioned above, and I rely on 1Password for my password management needs.

Thank you in advance for your assistance!


1Password Version: 8.10.6
Extension Version: 2.10.0
OS Version: Ubuntu 22.04.2 LTS
Browser:_ Chrome
Referrer: forum-search:chrome

Comments

  • ltptnt
    ltptnt
    Community Member
    Options

    I was also running into a similar issue with Brave Browser Beta (Version 1.52.100 Chromium: 113.0.5672.92 (Official Build) beta (64-bit)) on Fedora 38 and fixed this issue by copying the file using the following commands:

    cp ~/.config/chromium/NativeMessagingHosts/com.1password.1password.json ~/.config/BraveSoftware/Brave-Browser-Beta/NativeMessagingHosts
    and
    cp ~/.config/chromium/NativeMessagingHosts/com.1password.1password.json ~/.config/BraveSoftware/Brave-Browser/NativeMessagingHosts

    No idea if this is what solved the issue as I was unfortunately doing a number of troubleshooting steps simultaneously.

    You could try and make a file in ~/.config/google-chrome/NativeMessagingHosts/com.1password.1password.json with the following text

    {
      "name": "com.1password.1password",
      "description": "1Password BrowserSupport",
      "path": "/opt/1Password/1Password-BrowserSupport",
      "type": "stdio",
      "allowed_origins": [
        "chrome-extension://hjlinigoblmkhjejkmbegnoaljkphmgo/",
        "chrome-extension://khgocmkkpikpnmmkgmdnfckapcdkgfaf/",
        "chrome-extension://aeblfdkhhhdcdjpifhhbdiojplfjncoa/",
        "chrome-extension://dppgmdbiimibapkepcbdbmkaabgiofem/"
      ]
    }
    
  • zan2
    zan2
    Community Member
    Options

    @ltptnt
    Thank you for your suggestion. I have tried to follow the steps you've outlined, but unfortunately, the issue persists. One thing I've noticed is that there are multiple "com.1password.1password.json" files, and I've checked that they all have identical content.

    Could the existence of these multiple files be contributing to the problem? Or perhaps there is another troubleshooting step I should take? I'd appreciate any further guidance you can provide.

    Thanks again

  • AliH1P
    Options

    Hey @zan2, I apologize for our delayed response here.

    To investigate this issue further, I'd like to ask you to send us the full extension console logs:

    Sending Extension Console Logs

    Attach the logs to an email message addressed to support+linux@1password.com.

    With your email please include:

    We'll look forward to hearing from you.

This discussion has been closed.