AutoSubmit not working anymore on one website

Gilles9
Gilles9
Community Member
edited June 6 in 1Password in the Browser

It used to work, that Financial Institution made changes to their web page, now it will not autosubmit

https://client.bnc.ca/cdbn/login

all other sites work and autosubmit whwn I use 1Password shortcut


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Browser:_ Not Provided

Comments

  • Gilles9
    Gilles9
    Community Member

    The problem with autosubmit, only occurs if the site has "remember me" active, which remembers the login user
    when th user ID is remembered it does not autosubmit
    if there is no User ID then it will autosubmit

  • Joy_1P
    Joy_1P
    1Password Alumni

    Hey @Gilles9, I took a look at the website https://client.bnc.ca/cdbn/login. I can confirm that autosubmit does work if "remember me" is not checked. I'm curious, when you fill your login, does that option automatically get checked? That behavior has happened on other websites. If it is happening there, please let us know and we can take a closer look at it with you.

  • Gilles9
    Gilles9
    Community Member

    I need to have "Remember me" selected, otherwise I get a Two factor authentification request every time I log in

    If I could at least just press "Enter" after the password has filled with 1P, not even I have to click the "connect" button

    Why wouldn't 1P just fill in the password and autofill ?

  • Joy_1P
    Joy_1P
    1Password Alumni

    @Gilles9 Hmm it is odd, but after testing things out again with the "Remember me" option selected, I am see that autosubmit is working: https://share.cleanshot.com/jX5NTvsm

    The error in the video above only comes up because my username and password are not valid. Could you test this again from your end and let me know what you're seeing? What browser are you using and what version of the extension are you running?

  • Gilles9
    Gilles9
    Community Member

    Yes it works because you had no name in the userID field
    you did check "Remember me" with no name already in the UserID

    Once the UserID is "remembered" and that field is filled already, this is when autosubmit is not working
    it fills the password field and stop there, no autosubmit, if I press "enter" no effect, I have to click the "connection" button

  • Gilles9
    Gilles9
    Community Member

    @Joy_1P

    do you think there is anything you can do to re introduce autosubmit for this site ?

  • Joy_1P
    Joy_1P
    1Password Alumni

    Hey @Gilles9 even with the username field filled beforehand, autosubmit still works on my end: https://share.cleanshot.com/9h29npQ8. Could you share a screen recording of the behavior from your end so that we can take a closer look at what is going on?

    Please attach the recording to an email addressed to [email protected]. With your email please include:

    As a note, for security reasons, we are unable to click on third party links inside emails. If your recording is too big to attach to the email, please let us know in your email message to us, and we'll send you a secure upload link for it.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks!

  • Gilles9
    Gilles9
    Community Member

    @Joy_1P

    Support ID = #BIW-49269-183

  • Thank you @Gilles9.

    I have located your ticket, the team will be in touch soon.

    ref: BIW-49269-183