Firefox on Mac doesn't communicate with native app

Community Member
edited July 19 in 1Password in the Browser

I am using firefox. For some reason, Firefox 1Password extension is only one that doesn't integrate with my 1Password app. I have to unlock the firefox extension with password all the time and cannot use touch id.

It does work well in Edge and Safari. I tried to follow complete uninstallation guides for mac, restarting everything many times, reinstalling many times. For some reason even when I follow after reinstallation it still remember my email (that means that some step in that manual is missing). I tried to delete all data in browser extension.

1Password for Mac 8.10.8 (81008045)
1Password Beta – Password Manager 2.13.1

Extension log looks somehow like this (when I click the extension, red errors appear):

1Password Version: 8.10.8
Extension Version: 2.13.1
OS Version: 13.4.1
Browser: Firefox


  • @svobol13

    You most likely have iCloud keychain turned on. 1Password for Mac is finding a reference it stores to your account there. This is normal and expected behavior. I see a browser verification failed message. Is the browser up-to-date? If not, please update it. Is the browser located in your /Applications folder?

  • svobol13
    Community Member

    @ag_tommy thanks. Yes I have iCloud keychain turned on. My Firefox app is on my external drive folder (not in the system /Application folder).

    After I turned iCloud keychain off, it was still not working.

    After I started Firefox from system /Application folder it started to work. Thanks!

    Btw would it be possible to allow running browser from any location? I usually save money for built-in SSD on my macs so I am used to offload anything possible to external, cheaper drive.

  • @svobol13

    I can pass along your feedback to the team regarding using other locations. Thank you for sharing. I am not aware of a way to allow running a browser from a location other than the /Applications folder.