Cannot copy from Win11 and paste into virtualbox

Community Member

I've experienced this problem a few years ago but gave up on looking for a resolution. But now I decided to give it a try and see how long it will take to find a definite solution.

So community,
Let me ask if there's someone else who's experiencing the same.
I'm on a Win11 host and working on a VBox-Kali.
The task is simple: I need to copy a user/password from Win11 and paste it on VBox.

What I did so far:

  • VBox Guest installed;
  • Tested OK copying + pasting random pieces of texts back and forth.
  • Deselected config setting for "remove info after 90 sec" option.


  • Sometimes, and at random, it will succeed copying from win11 and pasting into Vbox.
  • The same random key/pwd that succeeded once, doesn't next time.

1Password Version: 8.10.16
Extension Version: Not Provided
OS Version: win11
Browser: Not Provided


  • Hey @crispytk, thanks for reaching out to us. This is an issue that I've been able to reproduce and raised internally for further investigation.

    In the meantime, when the issue reoccurs, could you let me know if the following workaround allows you to paste successfully:

    1. Copy any random character or string from your local device.
    2. Copy a password from 1Password
    3. Paste to the VM.

    Looking forward to hearing from you.


    ref: dev/core/core#10982

  • Azareus
    Community Member
    edited November 14

    I'm joining in here because I'm experiencing the same problem with my team using Windows 11, 1Password for Windows 8.10.18 and VirtualBox version 7.0.6 r155176 and I'm very frustrated.

    In the vast majority of cases, copying and pasting a password from 1Password into a (Linux) guest machine of VirtualBox does not work. At the beginning I thought that the passwords were not saved correctly, which could not be the case as they were created with 1Password. It seems as if the shared clipboard is not updated. However, the password is stored correctly in the clipboard on the host and can be pasted into Wordpad, for example. If I then copy this password from Wordpad, I can paste it on the guest machine.

    The suggested work around does not work for me. Under these circumstances, I cannot use 1Password productively. I was very surprised that this problem has been known for a long time, but there is still no solution in sight.

    I would be very happy if this problem could be solved

  • AliH1P
    edited November 17

    Hey @Azareus, I'm sorry to hear you're also encountering this issue and that the workaround doesn't work for you.

    I understand you frustration and I've added your case to the internal tracker and shared your comment with the team.

    Your patience is greatly appreciated.


    ref: dev/core/core#10982