Using 1P with Safari Technology Preview launches Safari.app

Ryan Parman
Ryan Parman
Community Member

I'm a perpetual beta user. I'm running the latest beta of macOS, the 1Password beta channel, the latest Safari extension from TestFlight, and Safari Technology Preview.

Starting a couple of months ago, whenever I would use the "Universal Autofill" feature (I think that's what it's called) in Safari Technology Preview, I started seeing a single Safari.app window open. The Safari extension doesn't work consistently for me (#LHK-37297-729), and I've been a user for over a decade, so Cmd-\ is weaved into my muscle memory at this point.

This seems to happen whenever I use this key command. I'll be using STP, hit the key command to bring up the 1Password quick prompt thing, and a single Safari.app window will open in the background. And no, macOS won't let me delete Safari.app. I've tried. :)

Is anyone else seeing this? Has this already been reported? I tried searching before opening a new discussion, but didn't find anything that seemed to match this behavior.


1Password Version: Mac 8.10.26 (81026011)
Extension Version: 2.20.2 (22000202)
OS Version: 14.4 Beta (23E5180j)
Browser: STP Release 187 (Safari 17.4, WebKit 19619.0.1.2)

Comments

  • Hello @Ryan Parman! 👋

    Thank you for reporting the issue! I'm not running the macOS beta but I'm not able to reproduce the issue using the stable version of macOS. So that I can try to build the same environment that you have can you please tell me the following:

    1. Do you have the 1Password extension installed in both Safari and Safari Technology Preview?
    2. What is your default browser set to?
    3. Is Safari.app already open and is it just focused when you try to fill into Safari Technology Preview? Or is Safari.app completely closed and it opens from scratch?
    4. Do you use Safari.app or Safari Technology Preview in multiple spaces/screens or in fullscreen mode?

    I look forward to hearing from you.

    -Dave

  • Ryan Parman
    Ryan Parman
    Community Member
    1. I've disabled all extensions in Safari.app, and enabled my extensions in STP.
    2. STP
    3. Closed, and opens from scratch.
    4. I use STP exclusively, and use it in full screen mode exclusively.
  • Ryan Parman
    Ryan Parman
    Community Member

    Despite my disabling all extensions in Safari, it seems that there was a Safari update which added this checkbox. :\

    I disabled the checkbox in Safari, and then re-disabled all extensions (that had been enabled without my knowledge).

    It doesn't seem to be happening anymore.

  • @Ryan Parman

    Sounds like you got things figured out, but let us know if you need anything. :)