Unable to install recent One Password Updates on Windows 10 or 11 - Solved

Options
jfmorris
jfmorris
Community Member

I am posting this for others who run into this. I found an older discussion about the issue, but basically, every time I tried to install a One Password update, I would end up with an "Unable to install update, rolling back changes" message. Even if I downloaded the installer and tried it outside One Password 8, this would occur.

I finally disabled active protection briefly in my antivirus solution - Webroot SecureAnywhere - and was able to do the update.

In reading other discussions, the key appears to be that the update tries to delete and recreate folders that are protected by the AV solution. The same issue apparently can happen with Microsoft's Defender AV, and these folders have to be whitelisted.

For me, 1Password apparently lives in my User directory at:

C:\Users\XXX\AppData\Local\1Password

So whitelisting that folder in the AV should allow future updates without shutting off AV protection.

Unfortunately, in many corporate environments, you are not allowed to boot to safe mode, or shut down AV, and may not have control of the AV whitelist either. So I am not sure how you get an update to 1Password installed in those type situations. These are my computers in my home office, under my control, so thankfully I was able to work around the problem.

I feel that 1Password needs to redo their update process in the installer to NOT try to delete these folders and recreate them, or whatever is triggering popular AV solutions to step in and intercept it. I sure have not had this type issue with any other commercial software I have installed in years.


1Password Version: 8
Extension Version: Not Provided
OS Version: Windows 10 22H2 or Windows 11
Browser: Firefox

Comments

  • Kirkman
    Kirkman
    Community Member
    edited February 26
    Options

    I am regularly getting the following error message shortly after I sign in to Windows:
    1Password was unable to complete installation and will roll back any changes.

    I use 1Password on a managed computer. It has a BitLocker protection that prevents me from restarting into safe mode, and I am unable to edit the settings of any security software that is running.

    I have found that if I set the AppData > Local > 1password folder to "Read-only" and then immediately double-click the installer inside the directory, that it will then install successfully.

    But some management system on my computer appears to very quickly undo this change, so that if I wait too long, it won't work.

    Basically, this is untenable. There must be a better way to for 1Password to download and install updates.


    1Password Version: 8.10.24
    Extension Version: 2.20.2
    OS Version: Windows 10 (10.0.19045)
    Browser: Firefox

  • Dave_1P
    edited March 1
    Options

    Hello @Kirkman and @jfmorris! 👋

    I'm sorry that you both ran into trouble when installing 1Password, thank you for sharing your findings. This is indeed an issue that seems to occur when security software blocks or interrupts the installation process. You can find our official instructions on how to configure your security software here:

    If you're using a managed PC (such as in a corporate environment) then I would recommend forwarding the article that I shared above to your organization's IT team so that they can configure your security software to avoid the issue in the future.

    I hope that helps.

    -Dave