Unable to sign into Sony account using a passkey in Chrome

This discussion was created from comments split from: Trouble signing into Sony using a passkey.

Comments

  • pujezdsky
    pujezdsky
    Community Member
    edited February 28

    I have the same issue and I am now completely locked from my Sony account :(

    When I go to login page from https://playstation.com, the 1password "notification" pops up in the top-right corner. When I click on "Sign in" it does absolutely nothing. I have checked Chrome developer console and this is the error it throws

    However I have done some interesting things.
    1. I have created my PassKey in sony account
    2. I tested signing in and out using the PassKey and 1password, successfully
    3. I have opened 1Password app and did not see the "key" anywhere in the sony login item. I found out that I am using some prehistoric version of 1password - something from 2022. I have updated 1password and now I could see the "passkey" information in sony item

    Now moving to my iPhone:
    1. I tried to use PassKey login via 1Password in Chrome on iPhone
    2. I found out that 1Password 7 probably does not support PassKeys - Chrome does not suggest my created PassKey
    3. I have updated to 1Password 8 and removed 1Password 7
    4. Now Chrome suggests my PassKey from 1Password
    5. When I try, it opens 1Password, authenticates via FaceID, closes and.. nothing. The Login via PassKey "modal dialog" is still opened and I can click again on Continue to repeat the process.

    Now I have lost my patience and wanted to go back using the working password. I switched back to Chrome on macbook. However the login using PassKey stopped working - clicking on the "Sign in" also does nothing - see the screenshot above.

    I have tried restarting both iPhone and macbook and I am still having the same issue. I have also tried Safari with the same result. Chrome and both iOS and macOS are on newest versions.

    From the screenshot I suspect that the older versions of 1password somehow mangled the internal data for PassKey, which is now unusable.

    Edit:
    I have managed to recover my account via SMS and set up new password. I have then removed my broken PassKey from 1Password. Then I created new PassKey and now everything works as expected. Phew :)

  • Hello @pujezdsky! 👋

    I'm sorry that you ran into trouble when saving and signing in to your Sony account with a passkey. It sounds like you were able to resolve the issues that you mentioned by saving a new passkey and I'm happy that everything is working now.

    I'll keep an eye out for further reports of this behaviour so that the team can correct any bugs that might be at the root of the issue.

    A quick note: saving and signing in with passkeys does indeed require using 1Password 8 on all of your devices. If you're still using 1Password 7 on some devices then I recommend that you upgrade: Upgrade to 1Password 8

    Let me know if there's anything else that I can help you with. 🙂

    -Dave