Unable to use Yubikey to add security key to Google account.

aquinox77
aquinox77
Community Member
edited March 22 in 1Password in the Browser

I'm having several issues with using Yubikey with Google and 1password. I tried to add the Yubikey to secure my Google account, but 1password seems to be hijacking the prompt, I think (but not sure).

When trying to create a security key (using my Yubikey) on Google, I click "Create a passkey" -> "use another device."

Then, 1password offers to "Save passkey". At first, I tried adding it and 1password seems to have saved a "passkey." This isn't what I wanted to do, of course.

So I went back to try again. This time, I hit the 'x' on 1password when it offered to create a passkey, but then google prompts "We weren’t able to save your changes. Return to your account settings, and try again."

Out of curiosity, I wanted to see how this passkey worked, so I logged out of my Google account and tried to sign in, only to find that 1password's "QR code detection failed." So now I cannot even use that to sign into my Google account.

Freshly formatted PC (1-2 weeks), with only a few extensions installed on my browser. Please help me figure out how to use 1password correctly, because I'm clearly doing something terribly wrong. Thanks.


1Password Version: 8.10.28
Extension Version: 2.21.0
OS Version: Windows 11
Browser: Brave

Comments

  • Dave_1P
    edited March 22

    Hello @aquinox77!

    I'm sorry that you're running into issues when trying to add a security key to your Google account. Both passkeys and security keys use the same underlying webauthn technology which is why you're seeing the prompt from 1Password appear in your browser. Can you click on the security key icon in the prompt to use your security key instead:

    image

    If that doesn't work, and you still see the same error message, then try temporarily turning off 1Password in Brave:

    1. Open Brave.
    2. Type brave://extensions/ into the address bar and press enter on your keyboard.
    3. Turn off "1Password - Password Manger".

    Then try to save your security key again, does that work? This will confirm whether the error message from Google is being caused by 1Password or by something else. Once you've completed the test, remember to turn 1Password back on.

    -Dave

  • aquinox77
    aquinox77
    Community Member

    Hi Dave,

    Thank you for your prompt response. I just started using 1password recently (moved from LastPass), so forgive me for any unfamiliarity with usage.

    I've already tried clicking the security key icon, and it immediately caused Google to fail with the same error.

    I tried turning off the extension too, and now Google just prompts me with "We weren’t able to save your changes. Return to your account settings, and try again." whenever I click on "Create a Passkey."

    So I figured maybe Google is just "broken" and I'll go try to secure my 1password account using this Yubikey -- but even that has been riddled with issues. I tried turning on 2FA on 1password and it gave me the exact same issues as I had with Google. Tried turning off the extension and I only get this error:

  • Hello @aquinox77, thank you for getting back to us. I apologize for the delay in response.

    First, let's check to make sure your browser and the 1Password extension are up to date -> Update your browser and 1Password in the browser.

    If you're still experiencing issues after updating, can you test if the same behaviour occurs on a different browser? If not, are there any other extensions installed in your browser?

    -Evon