Brave Browser and 1Password For Mac Autolock Settings


What settings in 1Passwword for Mac and Brave Browser will prevent the autolock from requiring password entry all the time. I tried changing 1Password setting but it doesn't prevent autolock from requiring frequent restarts.

1Password Version: 8.10.28
Extension Version: 2.22.1
OS Version: MacOS 14.41
Browser: Brave 1.64.116


  • Dave_1P

    Hello @crablice! 👋

    Thank you for reaching out, I'm sorry that 1Password is locking more often than expected. When the 1Password desktop app is installed and app integration is turned on, auto-lock settings are controlled from the app and not from the browser extension. First, I'd like you to confirm that app integration is turned on:

    1. Open and unlock the 1Password for Mac desktop app.
    2. Click on 1Password next to the  in the menu bar.
    3. Click Settings.
    4. Make sure that "Keep 1Password in the menu bar" is turned on.
    5. Click Browser.
    6. Make sure that "Connect with 1Password in the browser" is turned on. Leave the desktop app open.
    7. Open your browser.
    8. Right-click on the 1Password icon in your browser's toolbar and click Settings.
    9. Make sure that "Integrate this extension with the 1Password desktop app" is turned on and you see a green circle. If you see a different coloured circle then let me know.

    Then, go back to the desktop app's settings and click Security. Configure your auto-lock settings here. You can read more about auto-lock here: How to set 1Password to lock automatically

    Does auto-lock work correctly now? I look forward to hearing from you.