Chrome and 1Password (Autofill and Passkeys)

Options
jkane001
jkane001
Community Member

On Android Chrome, in recent days autofill has stopped working completely. And I can no longer set up Passkeys and have it defer to 1Password, it defaults to the Google Manager.

I've checked settings in the browser, 1Password app, and OS, and all like right to me (though I'm open to suggestions).

Anything I can try?


1Password Version: 1Password for Android 8.10.30 (81030042)
Extension Version: Not Provided
OS Version: Android 14; Pixel 7 Pro Build/AP1A.240405.002.B1
Browser: Chrome 124.0.6367.114

Comments

  • jkane001
    jkane001
    Community Member
    Options

    I just updated to beta and that fixed the autofill issue, but not the Passkeys issue.

  • jkane001
    jkane001
    Community Member
    Options

    And then again, maybe the beta still doesn't work. Sometimes the suggestions appear, but I cannot get it to actually fill the password. So still something's wrong.

  • ShoxJeanz
    ShoxJeanz
    Community Member
    Options

    I think the Android Chrome team is still implementing the Credential Manager API. Sometimes too with their flags get wonky where they turn it on or off on whim. Hopefully the browser will better support passkeys from both Google password manager and 3rd party password managers. You can find the flag under Chrome://flags, I forget what it is, but search credential management.

  • 7elou
    7elou
    Community Member
    Options

    I think the problem may be that you have a flag enabled in chrome://flags that disables 1password from autofilling. I forgot the flag, nut I had the same problem, and returning it to its default state resolved it.

  • BrendanR1P
    edited May 24
    Options

    Hi @twere @ShoxJeanz & @jkane001,

    From checking this in the latest version of Chrome it appears that Credential Manager is still not enabled by default in Chrome to allow 1Password passkey suggestions to appear with a flag still needing to be enabled to allow this to occur.

    Since the release of Chrome version 125, the flag that previously needed to be enabled for third party password manager passkey prompts to appear (Android Credential Management for passkeys) no longer appears in the list of flags by default. Another flag now needs to be enabled before this flag will appear in the list of flags. I've included details regarding this below:

    Enabling the Temporarily unexpire M124 flags flag

    1 Open Chrome, then type chrome://flags into the address bar
    2. In the flags page which opens, tap the search box, then search for M124
    3. Tap Default under Temporarily unexpire M124 flags then tap Enabled

    Once this flag has been enabled, the Android Credential Management for passkeys flag should now appear in the list of flags again. Setting this to Enable for Google Password Manager and 3rd party passkeys by following the steps below should allow 1Password passkey suggestions to be shown when trying to sign into a website in Chrome using passkeys.

    1. Open Chrome, then type in chrome://flags into the address bar
    2. In the flags page which opens, tap the search box, then search for passkeys
    3. Tap Default under the Android Credential Management for passkeys flag, then tap Enable for Google Password Manager and 3rd party passkeys
    4. Tap the Relaunch button that appears at the bottom of your browser

    If the steps above don't work, please repeat the steps again but in Step 3, please change Enable for Google Password Manager and 3rd party passkeys to Enable for 3rd party passkeys.

    Hopefully Google will enable this by default in Chrome in an update soon which will prevent the flag needing to be enabled.

    I hope this helps

    -- Brendan

  • ShoxJeanz
    ShoxJeanz
    Community Member
    Options

    Thank you 👍🏼😊

  • Dave_1P
    Options

    I'm happy that Brendan was able to help. 🙂

    -Dave