Why does Migration Assistant keep asking me to update?

Options
Lorraine_
Lorraine_
Community Member

I am already on 8.10.32 (81032044, on BETA channel); why do I keep seeing the Migration Assistant telling me that version 7 is detected and offering to update? And why does it then ask for my Password to update my info? Is it supposed to be doing this?


1Password Version: 8.10.32 (81032044 beta)
Extension Version: 2.23.3
OS Version: MacOS 14.4.1
Browser: Firefox 125.0.3

Comments

  • Dave_1P
    edited May 14
    Options

    Hello @Lorraine_! 👋

    I'm sorry for the confusion. The latest beta versions of 1Password for Mac feature a new tool that offers to help you migrate your items from any old standalone vaults (used in 1Password 7) that it detects on your Mac. If you already see all of your items in 1Password 8 then you likely don't need to migrate anything.

    So that I can fully understand the situation, and offer the best advice, I'd like to ask for a diagnostics report from your end (make sure to use the instructions for 1Password 7, not 1Password 8):

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to support+forum@1password.com.

    With your email please include:

    Please send the entire file.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks very much!

    -Dave

  • Lorraine_
    Lorraine_
    Community Member
    Options

    Hi Dave,

    Thanks for your response. I've emailed the Diagnostics report. Here is the support ticket ID: YXS-98933-159

    The link to the Forum post:

    https://1password.community/discussion/145752/why-does-migration-assistant-keep-asking-me-to-update

    Thanks!

  • ag_tommy
    Options

    Thanks!

    ref: YXS-98933-159

  • MHnyc
    MHnyc
    Community Member
    Options

    I'm running into the same migration prompts to upgrade from 1P7 to 1P8 following the update to 1Password for Mac 8.10.33 (81033001). A diagnostics report was sent to support.

    Support ticket ID is VTM-57236-854.

    Thanks!

  • Dave_1P
    Options

    @MHnyc

    Thanks for posting the Support ID, I see that my colleague has already sent you a response.

    Our development team is aware of an issue where the message to migrate items from 1Password 7 appears even if you've already completed a migration in the past. The team is working to include a fix in a future update as soon as possible.

    For anyone else who runs into this message: If you're unsure as to whether you've migrated all of your items then send an email to support@1Password.com and our dedicated migration team can help further. 🙂

    -Dave

    ref: dev/core/core#29691