No way to bring main screen of 1password to the foreground after unlocking Firefox extension

Options
berkentekin
berkentekin
Community Member
edited May 16 in Linux

Fedora 40 - GNOME 46 - Wayland

Hello everyone,
So I realized that after I unlock the Firefox extension (using the desktop app), there's no way to actually edit any information because the main screen does not come to the foreground. Even when I start the app from the main menu afterwards, no view comes up. Also, the unlock prompt appears behind all other windows, so I need to Alt-tab it to the front. Perhaps this is a related issue.
These problems appear when I enable desktop integration for the extension.

If I disable desktop integration and unlock 1password with the browser extension, this issue doesn't arise, I can start the desktop application any time. Naturally, edits are made through the webpage in this case.

If I disable desktop integration, quit the desktop app, unlock 1password with the browser extension, unlock the desktop app, then re-enable integration; any time I attempt to edit a password through the extension, the desktop application appears normally. However, in this case, if I manually lock the browser extension afterwards, once I unlock it (through desktop) I can't open the desktop app anymore. But I can't replicate this reliably. Sometimes when I try to open the main window of the desktop app, it doesn't even display the unlock prompt. This may not even be a browser extension issue (or a desktop integration issue) at all.

The Quick Access as well as the settings always seem to appear (when I open them through the system tray) and the 1password unlock prompt is always accessible when I try to open these, though the Quick Access also has the alt-tab issue that I've mentioned.

This is just a small hiccup though, I'm kind of asking for it by using GNOME instead of KDE.

Thank you for your help

EDIT:

This is a case where I attempt to launch 1password through the terminal but the password prompt doesn't appear, integration was disabled in this case but the browser extension was unlocked:
https://gist.github.com/berkentekin/715e5a8f45efdeafc71b809deea0ae98

I then locked the browser extension and tried again, this time everything was fine:
https://gist.github.com/berkentekin/56c80e541892f64ade67793ffa25debe

It appears that whether integration is enabled or not, if browser extension is unlocked I can't access my desktop application (which contradicts what I've said earlier, so I'll leave this to you).


1Password Version: 8.10.32
Extension Version: 2.23.3
OS Version: Fedora 40
Browser: Firefox