OnePlus 9: Sign in screen appears then disappears

Options
This discussion was created from comments split from: UpsideDownCake Android 14 Beta.

Comments

  • MrDark
    MrDark
    Community Member
    edited May 16
    Options

    I recently switched to 1Password and have the same issue as reported before: the password login screen appears, but after signing in, it disappears suddenly.

    After some testing, the issue only appears when you close the app with the home or items tab active. The previously suggested workaround to directly open WatchTower or Search doesn't work for me. Wiping app data and setting up the app is the only way I can get back into the app.

    My phone is a OnePlus 9 running Android 14 (April 5 security update), 1Password version 8.10.32 (81032050, production channel)

  • Dave_1P
    Options

    Hello @MrDark! 👋

    I'm sorry that 1Password isn't opening correctly on your OnePlus 9 device. Since the issue in a previous thread was resolved in an update a few months ago, it's likely that you're running into a different issue even if the symptoms are similar.

    Just to clarify, can you confirm that these the reproduction steps:

    1. Tap on the 1Password for Android app from the home screen and unlock the app.
    2. Go to the Home or Items tab.
    3. Close 1Password.
    4. Tap on the 1Password for Android app from the home screen and unlock the app.
    5. The app closes.

    Let me know if I misunderstood. If I have that right then can you tell me how you're unlocking 1Password? Are you using biometrics? Does the same issue occur if you type in your account password instead?

    -Dave

  • MrDark
    MrDark
    Community Member
    Options

    Hi Dave,

    That is correct. It crashes after sign-in if the app was closed while on the Home or Items tab.

    It does not matter whether I try to login using biometrics or account password.

  • Dave_1P
    Options

    @MrDark

    Thank you for the reply. So that the team can look into this further and find a solution, I'd like to ask for a diagnostics report from your end. Follow these steps:

    1. Reproduce the issue one more time.
    2. Open Chrome.
    3. Type in onepassword://diagnostics.
    4. In the menu underneath the address bar, choose the option with the globe icon.
    5. A "Continue to 1Password?" prompt will appear, choose Continue.
    6. Follow the prompt to generate a diagnostics report.

    Send the diagnostics report to support+forum@1password.com.

    With your email please include:

    Please send the entire file.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks very much!

    -Dave

  • MrDark
    MrDark
    Community Member
    Options

    Hi Dave,

    It looks like it was one of these "involved mystery" bugs. Have tried to reproduce it, but the app is starting just fine now, no matter the tab.

  • Dave_1P
    Options

    @MrDark

    I'm happy that everything is working for now. If the issue does return then please collect a diagnostics report using the instructions in my previous post and the team can investigate further. 🙂

    -Dave