Hide Passwords from Teammembers

Options
ChristianTerhorst
ChristianTerhorst
Community Member
edited June 7 in Business and Teams

Hello,

Hello everyone!

I didn't find a solution yet, to hide passwords from teammates who has to access passwords over autofill. Is there a solution?
I tried to do it with a Test account, but if you are disabled "copy password" and switch the access only to show, then the autofill doesn't work.
So is there a Function where Teammates can have access to passwords without seeing them?

Best
Christian Terhorst


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Browser: Not Provided

Comments

  • david.m_1P
    Options

    Hi @ChristianTerhorst, thanks for contacting us!

    In order to provide you with the best advice, can you elaborate a bit on the situation and what you're trying to accomplish? For instance, if you're using a Teams or Business account, do you have items in a shared vault with other team members where you want them to have access to autofill the items but not visibly reveal the credentials in within those items in 1Password?

    I look forward to hearing from you!

    -David

  • ChristianTerhorst
    ChristianTerhorst
    Community Member
    Options

    Hey @david.m_1P

    thanks for your answer! :)

    For instance, if you're using a Teams or Business account, do you have items in a shared vault with other team members where you want them to have access to autofill the items but not visibly reveal the credentials in within those items in 1Password?

    --> Exactly! We want to do that. Goal is that the people can autofill the passwords and usernames but not see or copy them.

    Best
    Christian

  • david.m_1P
    Options

    @ChristianTerhorst

    Thanks for clarifying!

    You can manage permissions to prevent a person or group from revealing passwords in 1Password by disabling the "View and Copy Passwords" option under Client Settings. Here's how to do that:

    1. Visit https://start.1password.com in your browser and sign in to your account.
    2. Click Vaults in the right sidebar, then select the vault that you'd like to manage permissions for.
    3. Click the gear icon next to the person or group to view a list of their permission settings.
    4. Make sure that View and Copy Passwords is deselected under Client Settings.

    This is a client-enforced permission, so there are some limitations in how much it can do to prevent access to passwords outside of the 1Password apps. You can read more about these permissions in the following article:

    With the "View and Copy Passwords" setting disabled, and the "View items" permission remaining enabled, users should still be able to autofill successfully. If that doesn't work, let me know, and we can troubleshoot further.

    -David

  • ChristianTerhorst
    ChristianTerhorst
    Community Member
    Options

    Hello,

    thanks, it worked!!
    But not on every Website, on some, the autofill is not working. What can we do in that case?

    Best
    Christian