Passkey with GitHub failing

Options
mdp553
mdp553
Community Member
edited May 31 in 1Password in the Browser

This is similar to https://1password.community/discussion/142287/cant-use-passkey-on-github-com, however the discussion there did not resolve my issue

I created a passkey from Edge on my work computer (where no extensions are allowed) and stored in my 1password account via my iOS app.

However, I cannot use this to sign in to GitHub:
1. Open Edge
2. Go to github.com
3. Select "Sign in with passkey"
5. passkey QR code appears
6. I scan with my iOS device
7. I get the prompt 1password prompt "Sign in with your passkey?" on my iOS device
8. I select continue
9. GitHub returns a "Unable to sign in with your passkey" error message:

I have verified that the passkey is not saved as two-factor authentication (however, I cannot turn off 2FA for my GH account, but I use the GH mobile app as my 2FA option).

I have also tried on my personal macOS using the 1password extension (checked for updates) on both Brave and Safari - both approaches result in the same error message


1Password Version: 8.10.32
Extension Version: Not Provided
OS Version: iOS 17.4.1
Browser: Edge

Comments

  • david.m_1P
    Options

    Hi @mdp553, thank you for reaching out!

    I'm sorry that you're encountering trouble when trying to sign in to GitHub with a passkey. Can you reproduce the behaviour using the 1Password extension on your personal device and send over a console log, so that we can take a closer look:

    Please attach the console log to an email message addressed to support+forum@1password.com with a link to this thread.

    After sending the email, you’ll receive a reply from BitBot, our friendly robot assistant with a Support ID that looks something like [#ABC-12345-678]. Post that here, and I’ll be able to locate your message and make sure it’s gotten to the right place.

    I look forward to hearing from you!

    -David