1Password on Mastodon

These two (2) sites do not autofill, (used to work with 1P3)

Community Member

https://accesd.desjardins.com (fills in but does not autosubmit)

https://www.disnat.com/indexfr.asp (this one fills in the wrong field ( two fields on page, Quotes and Client login, it fills Quotes instead of Client login)

Both worked correctly with 1P3



  • m_wm_w
    Community Member
    edited October 2013

    Hi Gilles9 - I had a similar problem with a site where it just wouldn't fill in the details. I had only just installed the v4 Safari extension and so I thought restarting might be a good idea. I did and then 1Password filled in the details without issues.


  • MikeTMikeT

    Team Member

    Hi @Gilles9,

    The auto-submit in the MAS version may be a bit inaccurate on some sites. We're working on a separate tool that'll install a special script that'll improve the auto-submit feature. We'll release more details when we finish it.

    As for Disnet, can you try saving a new Login for the site, see if it'll work better.

  • Gilles9Gilles9
    Community Member

    Thanks MikeT
    Happy to hear you are working on something to fix this
    also surprised to hear it is only the MAS version

    I'll be waiting

  • Gilles9Gilles9
    Community Member

    this "https://accesd.desjardins.com (fills in but does not autosubmit)" site
    has suddenly strted to autosubmit, out of the blue
    with the MAS version 4

    So one problem solved


  • MikeTMikeT

    Team Member

    Hi Giles9,

    The script has to be installed in a separate location and since the MAS version is sandboxed, OS X won't let it install the script automatically. Thus, it has to be a separate tool to let you install it.

    Did you try re-saving the the Login on the second site?

This discussion has been closed.