Dropbox Sync Not Working



  • roustemroustem AgileBits Founder

    Team Member

    Hi @annoyedashell,

    Please try to disable Dropbox sync on iPhone, wait for a few seconds and then enable it again. That should reset all Dropbox data cached on iPhone and hopefully will resolve the data mismatch issue.

  • I am new to the Board. I too was having DropBox sync troubles after upgrading to 1Password 4, but appear to have fixed the problem, so I'll share my experience. BTW, Password4 is an upgrade from Ver 3 that I purchased from Agile Webstore and is installed in a MacBookPro. I run 4.3 on iPhone. (1) I then turned off DropBox sync in 1Password preferences. I then removed the keychain file from MBP DropBox folder, renamed it "old," and saved it on my desktop. (2) I removed the keychain file from my DropBox folder on my iPhone. (3) I removed the 1Password app from the iPhone. (4) I went into iCloud settings on iPhone and deleted the 1Password data and toggled "off" back up switch for 1Password (I don't see a need for it so long as I am using DropBox. (5) Restarted MPB and iPhone. (6) Created a new 1Password folder in DropBox folder on MBP. (7) Turned on DropBox sync in 1Password preferences and pointed it to new folder. I waited five minutes and confirmed that a new keychain file was added to the new folder in DropBox. (8) went to iTunes on iPhone and reinstalled 1Password app. Started app and pointed it to DropBox folder. I waited for App to sync and saw that data was not accessible on iPhone. (9) created "test" note on iPhone to see if it synced back to MBP and confirmed that it did. Created test not on MBP and confirmed it synced back to iPhone. It did. A lot of gyrations, to be sure, but it worked.

    If I was at home, I would have poured a celebratory beverage, but alas I am at work. I hope this helps those of you that are still struggling. Good luck.

  • sjksjk oversoul 1Password Alumni

    Hi, @bassra. I'm sorry you had to go through all those gyrations to get Dropbox Sync working after the 1P4 upgrade but am sure glad it is now!

    Was @roustem's suggestion (post #62) helpful for you, @annoyedashell?

    Sometimes when 1P4 on iOS has trouble with Dropbox Sync I'm able to get it working again simply by force closing and relaunching the app. General force closing steps:

    1. Double Click iPhone Home Button
    2. Locate the App you wish to force close or shut down.
    3. Swipe up on the app card to Force Close the running application
    4. That is it. Press the home button to return to your home screen.

    That's probably the easiest thing to try first.

  • Hi, @sjk. Post #62 didn't work for me. Everything has been working smooth since I completed the process that I described. Thanks.

  • Nothing works for me. I just can't get my devices (all Apple) to sync. Desktop OS 10.8.5, iPhone 5 7.0.2, iPad 7.0.2.

  • I had the same problem of syncing not working too. Took the basic steps @baasra laid out in post #63 and following the restart tips in: http://learn.agilebits.com/1Password4/Mac/en/KB/start-over.html. After an hour of deleting, reinstalling, syncing, my three Macs and 2 iOS devices are all syncing again. The key appears to be moving the keychain back to /Dropbox/1Password.

  • I fixed the syncing issue by doing a complete reset of my sync setup. I posted the steps here.

    Post Op of problem appears to be centered around where the keychain is being stored. I originally had it in the root folder of Dropbox. I moved the keychain to a 1Password folder on Dropbox and all my syncing issues were fixed.

  • sjksjk oversoul 1Password Alumni

    Hi, @kagy.

    Please check your Messages inbox for followup about your syncing issue.

  • sjksjk oversoul 1Password Alumni

    Hi, @mygeekdaddy.

    Thanks for posting the link to your detailed instructions for how you resolved your problem with 1Password Dropbox syncing. We're reviewing them for information that might be helpful to us for isolating and fixing bugs causing reported issues. Some may be related to storing the keychain in the Dropbox root folder, yet that's where one of mine is and the simple "force close and relaunch" workaround I posted in #64 has always been successful when Dropbox syncing with 1P4 iOS gets troublesome. Moving 1Password.agilekeychain to a 1Password subfolder under the Dropbox root may not be enough to resolve certain sync problems but if it's already there it's normally best to leave it there. Similar symptoms of problems doesn't mean their causes and solutions will be the same.

    We're truly sorry for inconvenience anyone's having from these issues, appreciate you reporting them, and will get them resolved as soon as possible.

  • I followed @mygeekdaddy 's instructions and resolved my issue as well (see here).

    One additional thing to note is that even though I'm using the non-MAS version of 1PW, the root of my problems seemed to originate when my 1Password keychain was not in the standard ~/Dropbox/1Password path.

  • I have spent so long on trying to resolve the 'open and fill' and 'synch' issues with 1PW4 that my dear wife is beginning to think that I am having an online affair. Having unsuccessfully tried iCloud, I am now back with Dropbox. Nothing works and the apps on my IPhone and IPad are in continuous synch. I appreciate that AB is trying to minimise reputational damage; however, in fairness to its long-standing customers who have downloaded versions of 1PW4 from the MAS in good faith, the Company needs to come out with either:

    (a) A step-by-step resolution guide for users to install a known configuration that works - and one which protects existing data. It cannot be right that users are having to read through pages of 'it works for me' and 'I did this' when it is clear that we may not be all at the same starting point.

    (b) Give some more formal reassurance that AB has a grasp of issues with a clear timeline for the release of a robust fix for the MAS versions of 1PW4.

  • Update to #72. If I turn off my IPhone and IPad they will synch when switched back on. If I close 1PW4 and then re-open it, the app goes back into constantly attempt a re-synch. My 2 Macs will just not synch.

  • No offense intended to bassra's highly touted post #63, but it just seemed over-my-head, and terribly complicated. I have, however, incorporated some of what he's suggesting, and checked within the root folder of dropbox. That's where my agilekeychain exists, and that's where I left it. However, within that folder were many (too many, it seemed) files named "1Password(1).html," "1Password(2).html," etc., etc., up to about 5 or 6 of them. I deleted them all except for the one without a number following it. That seemed to have solved the issue, and test files I created were synced to both my iOS devices. However, this morning I now have another file with a (1) after it, and the iPhone sync indicator is spinning indefinitely. This might be because my computer shuts down at night. I'm at a loss.

  • sjksjk oversoul 1Password Alumni
    edited October 2013

    Thanks for the followups, guys.

    Please refer to this Announcement for some additional information about troubles with syncing many of you have reported:

    1Password iOS 4.3 sync issues identified, fix submitted to Apple

    We're hopeful that 4.3.1 will resolve issues that, among others, the "force close and relaunch" workaround has been unsuccessful with. If possible, we suggest waiting until that update comes out to confirm if does fix them or that it's something different. No troubleshooting will resolve what 4.3.1 fixes so we'd prefer saving you the trouble of trying things now only to find out they won't help.

    Of course if you don't think 4.3.1 will be a solution or would rather not wait for it we're always glad to help with any problems you're currently having. Please start a new topic and we'll assist you there since I'm closing this one now. Thank you!

This discussion has been closed.