Putting an image onto the icon field resulting missing alpha channel

The icon's background wouldn't be transparent, but white instead.

«1

Comments

  • Another small bug: Dragging an app icon into the icon box gives it a white background upon saving.

    See: https://dl.dropboxusercontent.com/u/7561159/1P4 white icon background.mov

  • MeganMegan

    Team Member

    Hi @79342427,

    Thanks for bringing this to our attention. What version of 1Password are you currently using? Could you please include a screenshot of what you're seeing? There are instructions on how to take a screenshot here: http://take-a-screenshot.org/. You can save the image to a service like Dropbox and include a link in your reply.

  • sjksjk oversoul 1Password Alumni
    edited February 2014
    Hey @Niklas,

    I've added your post from Minor bugs in 1P4.1.2 into this topic.

    @79342427: Instead of posting a screenshot that @Megan asked for, can you take a look at Niklas' video and let us know if that's the same issue you're having? We'd still like to know which version of 1Password (and OS X) you're running, too. Thanks!
  • JasperJasper

    Team Member
    edited February 2014

    Hey @Megan & @sjk,

    I'm experiencing this issue too. 4.2.BETA-6 on OS X 10.9.1

    It appears that the issue only appears in versions greater than 4.1.1.

    Could it be related to this change in 4.1.2/4.1.3:

    • Improved quality of the custom icons.
  • pawtrackspawtracks Junior Member
    edited February 2014

    Same issue as @Niklas, app store version Version 4.1.2 (412009)
    Looks fine when you add the icon, click save and you get an extra ugly icon :(

    Before is when you drop the icon in
    After is what you see when you click save

  • MeganMegan

    Team Member

    Hi @pawtracks (and @JasperP and @Niklas ),

    Thanks so much the information here. I've filed an issue in our tracker to alert our developers to this issue. :)

  • I’m on 4.4.1 now and this problem still persists. I used to be able to add icons without white background in earlier versions.

  • MeganMegan

    Team Member

    Hi Sebastian,

    Could you please send me a screenshot of what you're seeing? This bug is marked as resolved in our tracker, and I'm currently unable to reproduce using 4.4.1 (Mac App Store).

    ref: OPM-1478

  • Hi Megan, it’s only in the list of software licences. When you mark them, you can see the white background:

    iStats Menus 4 I added a while back, just a few days back version 5 came out and I couldn’t manage to add an image without background. In the app page itself it looks fine though.

    I am however on the Yosemite public beta. I’m aware that this could just be an incompatibility problem. I’d be fine with that knowing I'd be able to change it when the final version comes out.

  • sjksjk oversoul 1Password Alumni

    Hi Sebastian,

    Here's what iStat Menus looks like when added and selected in the items list with 1Password 4.5.BETA-12 on Yosemite Public Beta:

    Post #2 in this topic has more information about running 1Password on Yosemite:

    1Password for Yosemite beta (OS X 10.10) [requires 1Password 4.5 beta; see Mac Beta forum]

    I hope that helps. :)

  • The 4.5 Beta doesn’t work here sadly but when I reinstalled the latest final version again, everything worked, including the images without white background. Strange but nice. :)

  • sjksjk oversoul 1Password Alumni

    Glad you could get that icon issue cleared up with 4.4.1, Sebastian.

    The 4.5 beta should be working with the Yosemite beta, even with known issues for both. The Mac Beta forum is the best place to get help with that, if you'd like. :)

  • edited October 2014

    Hi sjk, I just updated to 5.0 and again, it looks like this when highlighted:

    So the problem is back sadly. I tried deleting the entry completely and creating it anew but it would always come up like this. :neutral_face:

    Really annoying, why does it behave like this?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Sebastian Rasch‌,

    I can't reproduce it with 1Password 5, I don't use iStat and I just downloaded iStat Menus 5 to try to populate the icon, here's what shows up:

    Try this:

    1. Open the main 1Password app, unlock, and go to the 1Password Menu > Preferences > General
    2. Uncheck Show Rich Icons
    3. Wait a few minutes and then check the option

    Now, see if it is working better.

  • No, sadly not. The icon of iStat Menus 4 would disappear when unchecking that box, but that of version 5 stays. I don’t have the problem with any other icon. I tried different file types, .icn, .jpeg, .png, nothing helps.

  • sjksjk oversoul 1Password Alumni
    edited October 2014

    Hi Sebastian,

    Please give this a try:

    • Edit your iStat Menus 5 item.
    • Single-click (select) its icon and press Delete to clear it.
    • Save the modified item.

    Does that make any difference?

  • thightowerthightower T-Dog Agile's Mascot
    edited October 2014

    When I add an icon 512 X 512 this is what I get :

    • This happens when dragging directly from Safari into the edit window.

    Same results with a stop on the desktop first. url for one of the image's I was using https://openclipart.org/image/800px/svg_to_png/192129/ Different image but was my original choice.

    Its intermittent I can reproduce at times and other times it doesn't work. After editing the item several times trying to reproduce this I can no longer do that and it appears correct.

  • Hi sjk,

    strangely, it automatically uses the icon of iStat Menus 4 when I delete the icon of iStats Menu 5. I tried as well to delete the entry completely and write it anew from scratch. Didn’t help either.

  • sjksjk oversoul 1Password Alumni

    Hi Sebastian,

    Sorry that didn't help. If you do the same thing with the iStat Menus 4 item, that might fix the problem but could replace that v4 item's icon with the one from iStat Menus 5.

    Did you create a new iStats Menu 5 item by first removing the old one, then dragging the app icon into 1Password? And do you have versions 4 and 5 of the iStatus Menu application both installed?

  • sjksjk oversoul 1Password Alumni

    Thanks for doing that testing and posting the results, Tommy. I wasn't able to reproduce what you did, possibly because of its intermittent nature that you discovered and mentioned. We'll have to do more thorough testing to get to the bottom of this.

  • Hi sjk,

    even if I delete the entry for iStat Menus 4 completely and remove the icon in iStat Menus 5, it still takes the icon of iStat Menus 4. I don’t know where it gets it from, I don’t have it installed anymore, only the upgraded version 5.
    The same applies for when I just delete the icons. The icon of version 4 would always come back, I can’t delete it. Really weird.

    I tried different other icons, some would show a white background, others wouldn’t. I couldn’t determine what’s special with those that show a white background and those that don’t. It seems random to me but there must be something.

  • sjksjk oversoul 1Password Alumni
    edited October 2014

    That is some peculiar behaviour with the iStat Menus item icons, Sebastian. Sorry I don't have a good explanation for it yet, only a few hunches not worth mentioning at the moment.

    Here's something more thorough you can try if you'd like to, which sort of combines what Mike suggested in post #15 plus mine in post #17:

    • Open the main 1Password app and unlock
    • Select 1Password Menu > Preferences > General and disable the Show Rich Icons option
    • Remove all iStat Menus items
    • Press Control-Command-Q (⌃⌘Q) to quit 1Password and mini
    • Reopen the main 1Password app and unlock
    • Reenable the Show Rich Icons option
    • Drag the iStat Menus 5 app icon into the item list area of the 1Password app to create a new Software License item for it

    If that new item still has the iStat Menus 4 icon, wherever its mysteriously finding it, then:

    • Select the iStat Menus 5 app in Finder and press Command-I (⌘I) to open its Info window
    • If necessary, expand the Preview section of that Info window
    • Edit your iStat Menus 5 item
    • Single-click (select) its icon and press Delete to clear it
    • Drag the icon from the Preview section of the app Info window onto the icon area of the iStat Menus 5 item
    • Save the modified item

    Any difference after the first set of steps and possibly the second?

  • Sadly not. The new item would have the version 5.02, but still take the old icon of version 4. Changing the icon as described from the preview section of the app would create the white background problem again.

  • rickfillionrickfillion Junior Member

    Team Member
    edited October 2014

    @Sebastian Rasch‌ I've been able to reproduce the issue of the white background here locally (it's quite possibly machine-dependent in behaviour). We had a bug opened for it previously and it got resolved as we thought we had fixed it up. I've reopened it.

    As for the other issue of where that v4 icon is getting picked up from... that one baffles me a little. I'm looking at the code here and if you've toggled Show Rich Icons (which deletes all cached images), then we should just be asking the image for it on the next run to put that in the cache. So it would be the system that's giving us the v4 icon.

    ref: OPM-1478

  • sjksjk oversoul 1Password Alumni

    Hi Sebastian,

    Like Rick mentioned, 1Password is picking up the v4 icon for your iStat Menus item from somewhere on the system. Please try running this command in a Terminal window and see if that helps you locate it:

    mdfind 'iStat Menus' kind:Application

    With a single version installed normally in the system /Applications folder, the output would simply be:

    /Applications/iStat Menus.app

    Let us know what you discover; thanks! :)

  • Doesn’t give me back any information, just goes back to the normal mask.

  • sjksjk oversoul 1Password Alumni

    That's for trying that, Sebastian. Interesting you didn't get any matches.

    Another option is to use a tool like EasyFind (free; from DEVONtechnologies) to do the search without using Spotlight. Here are what results look like when I run it here:

    I'd put a copy of /Application/iStat Menus.app in another folder and renamed it to iStat Menus 5.app to demonstrate how the search found both of them.

  • Nothing that doesn’t belong to iStat Menus 5

  • sjksjk oversoul 1Password Alumni

    That might be progress, Sebastian. :)

    What about these two `app' types from 2012?

    Can you at least temporarily remove those, maybe first compressing them into a zip archive if you'd like to restore them later, and see if that resolves the v4 icon issue? Thanks!

  • edited October 2014

    I deleted it, was the same item twice. It has nothing to do with iStats itself though, that’s just a key generator I used before I bought the program. Didn’t even know I still had it.

    I removed iStats completely now and removed all remaining data with CleanMyMac and try to find anything else with EasyFind. It’s completely removed from my machine now. Still, it would create a iStats 4 icon in a new iStats entry.

This discussion has been closed.