Installing 4.5b37 unlinked Dropbox

When I installed 4.5b37 I got this message Missing the local cache of 1Password.agilekeychain file. Syncing with (null) has been disabled.
Error
Domain=com.agilebits.onepassword.errordomain code=9202 "Missing the local cache of 1Password.agilekeychain file. Syncing with (null) has been disabled." UserInfo=0x16d0b7d0 {NSLocalizedDescription=Missing the local cache of 1Password.agilebitskeychain file. Syncing with (null) has been disabled.}

on my iPhone & iPad. All my info was still there but the app had been unlinked from Dropbox

Comments

  • skylarpskylarp Junior Member
    edited February 2014

    I got this, too. Erasing my data and setting it back up with Dropbox fixed things.

    After setting 1Password up again, I discovered that the default security settings are different on the iPhone and iPad. For instance, the iPad has "never" as the default for clearing the clipboard, which strikes me as a very bad default.

    Also, and very obviously, the icon reverted to the non-beta version (no construction stripes).

  • ethansissonethansisson Junior Member

    Me too.

  • Same here with the initial Dropbox error, and when I tried to remove the existing Dropbox account via the 1Password UI, the big red button wasn't functional and I wasn't able to remove the Dropbox account. I tested this with both an iPad and iPhone with the same result.

  • MrRooniMrRooni

    Team Member

    Thanks everyone, we've had the same issue internally and are looking into it. In the mean time please reconnect your Dropbox sync setup manually via Settings.

    best,
    Michael Fey
    [email protected]
    AgileBits

  • spyderspyder Junior Member

    I just hit this exact error on my first load of b38, except it says UserInfo=0x14662c60.

    As it came up I realised I forgot to report an issue I experienced re-connecting sync when b36 first loaded (after the big sync update). May be related.

    • Activated Dropbox sync
    • Found keychain
    • Searching for encryption keys
    • Briefly flashed a "quick unlock code" entry screen, then back to which sync service do you want
    • Hit cancel, then primary again, shows Dropbox connected but never synced.
    • Nothing I do seemed to make it sync.
    • Force quit and reload fixed it.
  • I got the same message after installing 4.5b38 and had the same issue with it unblinking from Dropbox

  • mrtonermrtoner Senior Member

    Ditto on b38.

  • Sorry to say I have lost confidence in DropBox sync until this issue is resolved. Moreover, I don't understand why betas are being shipped until it is!

  • spyderspyder Junior Member

    Betas are never guaranteed to be stable. We're here to find the bugs, not play with new toys early.

  • Hi @spyder This is not a bug but a fundamental flaw with sync.

  • ethansissonethansisson Junior Member

    @HRD, I don't think anyone is asking us to put confidence in Dropbox sync right now. AgileBits have told us that sync is currently a work-in-progress and that we shouldn't use beta releases without backups of our data.

    It's not ideal for sync to be broken in the beta releases for a few weeks, but it's not really a problem either. It's more of an inconvenience. Sync is a pretty big feature and there's a lot of work involved in rebuilding it. It takes time to make software. In the meantime they absolutely should be sending out more beta releases so that testing on other areas of the app can continue.

    Finally, I'm not sure what constitutes a fundamental flaw or why a fundamental flaw can't be called a bug, but whatever terms you use, sometimes things are broken in beta software. And occasionally things are broken enough that some features don't work for some or all users. If that seems a bit too edgy for you, you might be more comfortable using the public release instead until after the beta has matured a bit more.

  • @ethansisson Noted but one expects betas to make progress in resolving bugs as they progress through their revisions. However, Dropbox sync has not; in fact the issues reported above has stayed static during the last few releases.

    Let us hope for some progress soon.

  • ethansissonethansisson Junior Member

    @HRD I agree. Not sure why some things seem to be stalled. My guess is they have to work within their limits (i.e. developer time), which may mean focusing on other areas of sync for now. Here's to hoping they can get further down the road soon. I would guess they're not content to leave it like this for too long.

  • @HRD another reason why they are shipping the betas with possible sync issues is so that we don't stuck with an expired beta while they work out the issue

  • @jmreekes A good point that I had missed.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    jmreekes is correct. We had to ship whatever we have available in order to ensure you guys still have access to the app itself. The major overhaul of the sync system wasn't ready for a few more weeks but the beta expired unexpectedly, so we had to ship them as is.

    As you can see now in the latest build (b40) why we were waiting, the support of multiple vaults and how the sync will work with it, especially with the ability to connect multiple Dropbox accounts as well.

    Now that it's available, we'll be sending out more beta updates soon to fix many of the reported issues.

This discussion has been closed.