Dropbox sync disabled each time the app starts from new

Not every time I run the app however if I haven't used it in a while and start it up, I get a message saying:

"1Password will no logner sync beacuse it cannot read the sync file. Please update sync preferences to start syncing again"

This also happens consistently every time there's an update to the beta as well.
Check out the screenshot to see the exact message I get.

I couldn't find any other posts around this - anyone else seeing the same thing?


  • MrRooniMrRooni

    Team Member

    Hello @jszotten‌. We are aware of this issue and are working to track it down. Sorry for the trouble that it's causing you!

  • Alright cool, that's all I needed to hear. Started to think I was the only one. It seems to be resetting my quick unlock code as well. Not sure if that helps anything but thought it worth mentioning. I also keep seeing 500 items synced even though when I'm told to merge vaults I can see that I have over 700 items. Is that relevant?

  • MrRooniMrRooni

    Team Member

    @jszotten‌ You're not the only one, though the number is small and it's not an issue we've been able to reproduce here, yet. Your information about the PIN code being reset does help, though. The number shown when you are warned about merging vaults includes tombstones, so that difference is expected.

  • iOS 7.1.1

    1PW 4.5.2RC0

    I don't know if this is the same issue as the OP reported. However:
    There is a problem in this version that I didn't see in the previous beta:

    I get the same message every time:

     Error: 1Password will no loner sync because it cannot read the sync file. Please update sync preferences to start syncing again"

    This appears every time, even after I already synced in THIS version. I understand that it asks for re-sync whenever I have a new version, but only the first time.

    I see that there is a new version 1PW 4.5.2RC1, but I wanted to report this before I install the update.

  • I have the same issue, through the last couple of versions including the current (4.5.2.RC1). I'm happy to share whatever logs that might help you all track this down. The issue recurs at least everyday for me.

    I'm using Dropbox sync. I don't know this for sure, but I think it started happening after I changed my iPhone's password.

  • I haven't changed my iPhone or 1P password between 1P beta releases so I wouldn't think that is related. I'm seeing the same thing though - at least once a day. Do let us know if you need any logs and I'll send them through.

  • I disabled "Background App Refresh" and so far, 1 day, dropbox sync has been ok.

  • See my comment in a previous posting "Passwords not syncing" and perhaps merge it here.

    Now st ver 4.5.2RC1, problem still exists.

  • MikeTMikeT Agile Samurai

    Team Member
    edited June 2014

    Hi guys,

    If you see the error again, please email us your diagnostic report to support + FORUM at agilebits.com with a link to this thread. We want to compare your logs to see if we can find a common pattern.

    Please make sure you're using the latest 4.5.2 RC1 build as it contains better logs.


  • Just repro'd the issue again and sent the logs. Hope it helps. I'm happy to answer any other questions about this too.

  • gc916gc916
    edited June 2014

    I experienced the Dropbox sync problem this morning. The PIN code was also disabled. I have sent the logs, as well. Please let me know if you need more info.

  • I just sent in logs as well as I have noticed this happening. I had commented about this on another thread and included some screenshots there of the messages I was getting. I don't get an error when trying to reactivate sync but instead get a message saying there is a vault mismatch like it is trying to merge with the primary vault instead of the secondary vault that I have selected.

  • LockerLocker
    edited June 2014

    Now st ver 4.5.3RC1, problem still exists. (see above)

    (the PIN code is lost too)

  • MrRooniMrRooni

    Team Member

    We are still working to nail this one down, but haven't been able to reproduce it or discover the cause of it. I'm sorry for the trouble it's caused, but hopefully we can get our hands around it soon.

  • Note: 1PW 'forgets' the Dropbox files not only when a (beta) version changes, but from time to time within the same version.

    Can it be something that has to do with switching internet connection (WiFi -> cel) that might happen at the 'wrong time' when 1PW is in the middle of some request and the net connectivity is lost exactly at that time?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @locker,

    That shouldn't matter, it'd just stop syncing based on the network errors and try again later.

    Have you try turning on the Airport mode on the iPhone/iPad and see if that will bring up the issue?

  • I was getting that error "1Password will no longer sync because it cannot read the sync file" pretty much every day. However, ever since doing a backup and restore last week (through which the 1Password Beta app was apparently lost and had to be reinstalled from scratch), the issue has not recurred.

    That's probably not a big help to you all, but it's a stark difference on my end.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @schellack‌,

    That does help, it suggests the issue is with the sync states in the app, which is cleared when you did your restore.

    Just an FYI, iOS backups do not include the iOS apps and when it is restored, they're downloaded from the App Stores to give you the latest versions. However, since the 1Password beta is not from the App Store, it won't be there when the restore is fully done.

  • LockerLocker
    edited June 2014


    Have you try turning on the Airport mode on the iPhone/iPad and see if that will bring up the issue?

    What do you mean? to cut off the connection this way? The problem happens most of the time, so I don't have the pleasure of trying to break it.

    Also, I'm not talking about just a simple case of no connectivity when 1PW tries to access the network. I'm talking about a breakdown in connectivity MAYBE in the middle of some sensitive stage (maybe handshaking??) when 1PW already transmitting to/from the network.

    Regarding your response to @schellack, I do get the problem even after updating to a new beta.

    @schellack: I envy you :)

    (and please don't move to requiring iOS8 before you clear this problem). TY.

  • MrRooniMrRooni

    Team Member

    @Locker: Is the problem only happening for you in the betas, or does it happen with the version from the App Store as well?

  • Haven't used the release version for quite a while. I'll check.

    Quick test: 4.5.2 did not forget. Considering that I haven't used it in a long time, it had "a good memory" :)

    And the sync seemed to be MUCH faster than the beta.

  • MrRooniMrRooni

    Team Member

    Thanks @Locker. We believe this problem is unique to the betas and that we have since fixed it in the release version. I'd like you to try deleting the beta install from your device and then reinstalling it from HockeyApp. Here's a handy dandy install link: https://rink.hockeyapp.net/apps/17e2ff5fecb9a46956b9aa3026da8e0f

    Hopefully you won't run into this problem again.

  • OK. I'm trying.

    I deleted 1PW on the iOS. Meanwhile I realized again how important 1PW to me! Logging into hockeyapp without 1PW. How anybody can live without it??!! :)>-

    I'll report later once I try the new install.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Locker,

    Yea, that's one thing I like about iCloud. I only need to remember the iCloud password and my 1Password master password. Using Dropbox would require me to remember a third one and I don't think I can. :P

This discussion has been closed.