The big thread on TouchID issues with 1Password 4.6 betas

edited July 2014 in iOS Beta

Hey folks. Super stoked for the new beta. I'm having an issue though. I can't enable TouchID. I tap the slider and it slides to on then slides back to the off position.

Any reason this might be happening?



  • Did you let it finish syncing before trying to enable it? If so, try killing the app, and re-launching.

  • I have the same issue: One second after enabling TouchID, the slider deactivates itself. Restarting 1P didn't help. Syncing was already finished.

  • Same problem- killing app and rebooting doesn't help

  • Same here. Confirmed killing and restarting app as well as ensuring sync was complete

  • WilliamTMWilliamTM Junior Member

    Me too. Syncing finished, tried killing the app, yada yada yada, no luck.

  • I am able to unlock my phone with Touch ID, no issues. I can enable Touch ID in settings, no problem. I start 1Password, upon launch it requests Touch ID, yet it does nothing. End up having to cancel out and enter master pass.

  • I can confirm the same. I'll get my iPhone hooked up to my computer this evening and see what the console says.

  • Only thing in app log that comes close:

    Sun Jun 29 15:43:29 2014| 406001 [LOCKSERVICE:0x178066080:] S loadLocalAuthenticationFramework | Loadng LocalAuthentication.framework
    Sun Jun 29 15:43:29 2014| 406001 [LOCKSERVICE:0x178066080:] S setAppLockMode: | Lock mode changed: 1
    Sun Jun 29 15:43:29 2014| 406001 [LOCKSERVICE:0x178066080:] S setAppLockMode: | Lock mode changed: 3
    Sun Jun 29 15:43:30 2014| 406001 [APP:0x170465bc0:] E createDummyFileInBetaContainer | Failed to create ubiquity container. Please enable iCloud and relaunch 1Password

  • I get the same request for Touch ID, but then it requires me to enter my master password...

  • Not working for me too :(

  • Sorry guys it's working for me. But I'd rather not see the prompt for Touch ID unlock. There should be an option not to display it. And if course if it's fails to unlock a few times then password should be prompted

  • Just installed 4.6.BETA-1 on my iPad Air (MF003LL/A) running iOS 8 beta 2 (12A4297e). First time I enabled Quick Unlock in the settings (with Lock on Exit enabled) it displayed the attached iPad passcode dialog without displaying a keyboard. Tapping anywhere in the entry box or anywhere else in the dialog did not bring up a keyboard. Needless to say, it's a bit hard to enter a passcode without a keyboard.

    Hitting the power/sleep button and then waking the iPad brought up this dialog again, repeating this did the same. Next time I woke it I hit Home to switch away from 1Password and killed it.

    Running 1Password again brought up the master password dialog, after entering this I was able to shut off Quick Unlock.

    Turning Quick Unlock on again, switching away from 1Password and tapping the 1Password icon again brings up the iPad passcode dialog with no keyboard again. Hitting sleep/wake and hitting Home to wake brings up the master password dialog.

    Waiting for 2 minutes of inactivity brings up the iPad passcode dialog again, with behavior identical to that described in the last paragraph.

    So the initial setup of iPad passcode won't allow getting out of the iPad passcode dialog without killing the app. Subsequent runs of 1Password brings up the iPad passcode w/o keyboard, but sleeping the iPad and then waking it brings up the master password dialog.

    Steps to reproduce after initial setup:
    1. Start 1Password
    2. Hit Settings icon
    3. Choose Security
    4. Ensure "Lock on Exit" is enabled, then enable "Quick Unlock"
    5. Exit Settings
    6. Switch away from 1Password with Home button
    7. Tap 1Password icon
    8. iPad passcode dialog with no keyboard appears

  • Just to add I can confirm I can't switch Touch ID on either, when I do it just slides itself off.

  • Same here, can't enable Touch ID in the security settings.

  • I'll throw my voice into the choir. The toggle just slides back off immediately after I touch it to turn on.

  • Same here. When i try to activate TouchID it deactivates itself immediately after i slide it on. Sync was finished and relaunched the app several times.
    Also tried reinstalling the whole application but that also didn't help.
    Thats bad i was very happy when i read that TouchID is included but then it doesn't work :( Please quickly fix that.

  • I downloaded the app on a phone that I restored to the iOS 8 beta and Touch ID in 1password enabled as expected. The phone that I "upgraded" to the iOS beta will not toggle Touch ID on. Maybe a coincidence ... Anyone else "upgrade" the problem phone?

  • HobbsyHobbsy
    edited June 2014

    I upgraded and cannot enable Touch ID on 1Password beta

  • @hiwayfuzz: I also upgraded to iOS 8. A restore of the phone is not possible here because i need all my SMS etc. Or have you done a restore of iOS 8 and then installed an iTunes Data Backup?

  • I'm going to try that on the phone that isn't working correctly and will update

  • I'm having the same problem. Haven't been able to diagnose why.

  • @hiwayfuzz: That's great. If an restore of iOS 8 and install of an iTunes Backup is enough, than it would be great. If a clean install of iOS 8 is needed that that's no possibility. But Agile please fix this issue soon so everyone with an iPhone 5s could use TouchID that would make live a lot more easy :)

  • Seems they are having Dome hudge Problems with TouchID. On many Devices like mine to you can't even activate TouchID the slider slides back off imidietly after switching it on. I think they have a lot of work to do to get TouchID working. Hope they can fix the problem in the next 1-2 days because i have a masterpw with 30 digits and TouchID would make my life a lot more easy :)

  • I am having the same slider "turn off" issue.

  • DragonDragon Junior Member

    I've managed to turn it on, but only once actually been asked for touch id, every other time it's just asking for master password. It also appears to take a very long time to ask for this after leaving app and returning.

  • Ok, I restored to iOS 8 beta 2 then restored my backup and installed 1password beta. I was able to enable Touch ID in 1password after

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    Thanks for the reports. I was able to reproduce this and will file a bug report on this for you guys.

    Stay tuned!

  • Thanks Mike :)

  • MrRooniMrRooni

    Team Member

    Thanks for the great report, @sternklang. I've got it entered into our bug tracker and we'll take a look.

  • Just want to add that when you turn on "Quick Unlock", it doesn't give you the option to set a Passcode. This is also on iOS 8 on both the iPhone 5 and the iPad Mini Retina.

This discussion has been closed.