MrC's Convert to 1Password Utility (mrc-converter-suite)



  • MrCMrC Community Moderator


  • I worked, thank you so much!! Software purchased.


  • MrC hi. I just bought the program and am trying to export the contents of my keychains. As was said above by Mr. Denning, apparently the importer doesn't import the iCloud keychain. There are about 1000 in my login chain and about 1000 in my iCloud chain, and they aren't an exact match. I'm basically at a standstill until I can import this stuff because I have zillions of passwords stored and can't move them over one at a time x2000, but if I imported them ad hoc I would never know when I had all of them. This seems like a pretty crippling problem and I'm surprised there isn't a simple workaround that doesn't require me to know terminal language, or whatever this stuff is :-)

    Also - how do you run the "click allow" script? Do you cut and paste that text into the terminal, and if so, before you run the exporter script?

  • As I work through this discussion board it is clear that as great as 1Password is, I shouldn't have bought it.
    I have too many passwords I guess, and I have no time to try to Jerry-rig OS X to export them. The interface is beautiful but I would not have purchased this for iOS or Mac had I understood - which there is no way I would have - from the marketing materials.
    How/who do I contact to request a refund?

  • MrCMrC Community Moderator
    edited December 2014

    Hi @glennmcgee,

    I sent @Scott Denning‌ a couple of messages offline to avoid cluttering-up this thread with tips I wasn't confident would work. Below are the two that are most likely the relevant ones. I've asked for clarification, and one of us will post which tip was the winner, but for now, here they are:

    Do you have iCloud sync enabled for Keychain? Preferences > iCloud > Keychain?

    I believe your iCloud keychain data should sync locally if you've authorized your Mac to have access.


    Ok, I have some more info for you. It seems you have to copy the iCloud data to a local keychain. Please see:

    The AppleScript posted on the other site (referenced in the README) can be saved as text file. Click the Raw button at the upper right of the posted script, and copy the results. Launch the AppleScript Editor, and paste your copied script, and Save the file as click_allow.scpt. Then see instruction #4 on the same page as the link.

  • Thanks but this is more than I can or want to learn to do. I may buy it again when all of this is automated and I apologize if this was in the sales materials. However I need a refund. Please help.

  • MrCMrC Community Moderator
    edited December 2014

    I don't work for AgileBits, nor do I speak for them, so you'll have to post your request / issues with the process to a separate thread.

    Converting is a challenge, I entirely agree. I've tried to help folks like yourself make this easier, but do appreciate the method requires some elbow grease.

    I don't mean to be pessimistic, yet feel its worth stating my opinion that an automated import process (where possible) supporting the numerous password manager's data formats, their various format versions, and supporting the various OS platforms is not cost-effective or the best use of resources for a company like AgileBits, so they will pick and chose their battles (focusing on oft-used features over the one-shot import). I'm comfortable suggesting that the price of 1Password would have to be increased noticeably to implement and support such conversion functionality (and new users would have no interest is such functionality). My converter code and included modules are over 12,000 lines of code and the additional modules used probably represent more than 20,000 lines of code.

  • I appreciate the work you have done which sounds like quite a bit. I agree it is the company's decision where to spend its time. I just wouldn't have purchased this product if any of this information had been made available. In fact the advertising suggests that this function is a key one, going so far as to suggest that you purchase it from the App Store so that you can get the direct relationship with iCloud for backups. I wouldn't go so far as to say it is deceptive but in a casual search I find more than 20 people asking this question de novo in the way I did, surprised that it isn't more transparent that you have to use an external script to make sure of any of your stored iCloud passwords. I did happen upon one exchange with a guy from Apple who very nicely said that this was something that everyone would like to see fixed, but that was months ago. I hope it is fixed eventually but it sounds like that isn't (and maybe shouldn't be) a high priority. So for me I have to return the software...and I'm waiting for an answer. I apologize for thinking that moderator meant working for AgileBit - sorry...

  • MrCMrC Community Moderator

    That's cool. I saw that you posted your request, so someone from AgileBits is likely to reply soon.

  • Mr C - I have eWallet for Mac using OS X Yosemite, i have folder "onepassword-utilities" & file "pm_export.txt" on my desktop. I have followed your instructions using terminal, but have got an error message. I copied the terminal window below, to show what has happened. What else do I need to do?

    Last login: Sat Dec 6 20:14:49 on ttys000
    Eric-MBAir13-512:~ davidastley$ cd Desktop/onepassword-utilities/convert_to_1p4
    Eric-MBAir13-512:convert_to_1p4 davidastley$ perl5.16 converter -v ../../pm_export.txt
    Invalid converter specified

    clipperz ewallet handysafe keepass2 keepassx keychain lastpass msecure safeincloud
    safewallet splashid

    specify one of the converters above on the command line to see complete options
    Eric-MBAir13-512:convert_to_1p4 davidastley$

  • MrCMrC Community Moderator

    Hi @davast,

    You're so close! In your command line, replace the word “converter” with “ewallet”, as in:

    perl5.16 ewallet -v ../../pm_export.txt


  • Hi Mr C, I am trying to convert my "pm_export.vid" (containing my SplashID 7.2.2 data as exported per your instructions to my Desktop).

    I downloaded your zip file, got a folder called "onepassword-utilities" on my Desktop. This contains a subfolder called "convert_to_1p4" which itself contains, couple of readme files, and four other subfolders including "Converters". The problem is when I run the Terminal window and type : "perl5.16 splashid -v ../../pm_export.txt", I get various errors including "converter_to_1p4 command not found", "specify converter" etc. What am I doing wrong? And can your program take in attachments from Splashid 7.2.2. eg images I have attached to my Type records? Help (for dummies) appreciated. I find you 1 and l in your command lines abit confusing to type!

  • MrCMrC Community Moderator

    Hi @silkroad,

    Can you post the exact error messages (either here, or send me an email - address at the top of the script). Your transcribed error message above doesn't match the command, and unfortunately command line stuff is very finicky. You can select the text and copy / paste, or take a screenshot of the portion of interest.

    The command you post above does look correct, but that error message indicates that the "perl5.16" part was missing.

    Also, which OS and version is this?

    I don't have a way to decode the attachments - sorry about that.

  • Hi MrC, Thanks for your reply. I sent you a message with attachment to avoid cluttering this forum separately but please note I am using OS X 10.10.1 on my iMac (not 10.10.2 written by mistake!). I did copy/paste in Terminal but I feel I am doing something basic, wrong.

  • MrCMrC Community Moderator

    @silkroad, I wrote several replies to you via PM. We can keep working issues there until you have your data converted.

  • MrC, Many thanks for your quick, very specific and helpful comments. Will try !

  • MrCMrC Community Moderator

    I've promoted version 1.01 to be the released version. Instructions for Windows users have been updated to reflect the switch from ActivePerl to Strawberry Perl. The changes from the 1.00 version are:

    Version 1.01:
      - Fix: More precisely construct the path to the Desktop on Windows, for the 1PIF export file, and add some debug output
        to help in any future issues.
      - New: Update SafeWallet converter to support the Windows 3.x XML version, and new categories 'irc' and 'server'.
      - Fix: SplashID converter was mishandling two or more adjacent F records.
      - Info: SplashID export encoding is suspect - added commented out decoding line in code to help users try alternate
        decoding (UTF-8 vs. macroman).
      - Change: Updated documentation to switch from ActivePerl to Strawberry Perl, since ActiveState removed 5.16 from their
        free downloads.
  • Thank you MrC, that worked a treat.

  • Dear Mr C,

    Thanks to your help, I used your Converter painlessly to transfer about 300 [mixed customised formats] records from SplashID 7.2.2 on my iMac OS 10.10.1. While I had once before tried the CSV route in 2013, I was unhappy with ,,,, approaches and so tried with Mr C's solution.

    Once the Terminal command line was used correctly (and it needs careful delineation), the conversion was instant. For the benefit of others, I extract here the bit of help from Mr C which was most useful in my conversion:

    **> The full command would be as specified in the ReadMe, but you have to specify the export file name you created. And on Yosemite, you have to use a specific perl program version perl5.16. You do have perl5.16 because when you tried to run a command using it (from your screenshot above), the system did not say -bash: perl5.16: command not found. If you didn't have perl5.16, that would be the error message you'd see. So, your command is (most likely):

    perl5.16 splashid -v ../../pm_export.vid

    If you get an error about not finding the ../../pm_export.vid file, then that file name or path is incorrect, not reflecting the one you created. No worries. Here’s how to solve the problem easily enough…

    In your command line, enter all of the command:

    perl5.16 splashid -v

    and don’t hit Enter yet. Hit the spacebar to add a tailing space after the -v part.

    Now, with the Finder, go find your export file, and drag that file’s icon onto the Terminal app window. Terminal will auto-enter the full path of the file name for you. Now you can hit Enter.**

    Once I ran this, I did get errors ("use of uninitialised value...") from several of my own customised SplashId formats that did not convert 100% seamlessly; this is no fault of MrC's program (-which even offered: a) friendly instructions on how to deal with it, b) from Mr C himself in detailed help over how to handle this problem via command line tweaking) but due to my own haphazard formatting in the first place. However the conversion automatically placed all this nicely as Secured Notes which was great, from where I will cut and copy manually into the 1password's given templates.

    Other users should be told that the difficulty I had with identifying 1 from l in typing the all important perl commands at my end may be due to their own font depictions in their computers...and the need to be aware and maybe change fonts if they have such a difficulty!

    Thank you Mr C for your tireless, detailed, and ever willing help for nothing. It is truly what other users call "amazing". It is also incredibly rare in internet user support situations generally, even when it is not related to a paid commercial purchase. I wish all user supports for any program could be so attentive and specific, and not superficially given in passing a couple of times and passed over as "your problem" as is the case at best in most instances...


  • MrCMrC Community Moderator
    edited December 2014

    @davast‌, @silkroad‌, and to many others who have written via PM or email,

    Excellent - it's great reading of your successes. And a big You're Welcome. Thanks for the nice feedback.

  • Thank you very much for your work. Successfully migrated.

  • I have a Mac running Yosemite OS X. I've followed the instructions, but am getting stuck. Here's the terminal script. I'm hoping you can help, as I'd really like to import my LastPass data into 1Password. I look forward to hearing back from you.

    Last login: Tue Dec 16 14:42:43 on ttys000
    MBP-2:~ AMN$ cd Desktop/onepassword-utilities/convert_to_1p4
    MBP-2:convert_to_1p4 AMN$ perl5.16 converter -v ../../pm_export.txt
    Invalid converter specified

    clipperz ewallet handysafe keepass2 keepassx keychain lastpass msecure safeincloud
    safewallet splashid

    specify one of the converters above on the command line to see complete options
    MBP-2:convert_to_1p4 AMN$ perl5.16 lastpass -v ../../pm_export.txt

    CSV_PP ERROR: 2034 - EIF - Loose unescaped quote

    Failed to parse CSV column names:

    MBP-2:convert_to_1p4 AMN$

  • MrCMrC Community Moderator

    Hi @aniemand,

    You're close, just like the user in post #102 above. In your command, replace the word converter (which is just a placeholder generic term) with your converter name lastpass.

  • Hi MrC. Just tried it and got this error message:

    Last login: Tue Dec 16 15:37:18 on ttys000
    MBP-2:~ AMN$ cd Desktop/onepassword-utilities/convert_to_1p4
    MBP-2:convert_to_1p4 AMN$ perl5.16 lastpass -v ../../pm_export.txt

    CSV_PP ERROR: 2034 - EIF - Loose unescaped quote

    Failed to parse CSV column names:

    MBP-2:convert_to_1p4 AMN$

  • MrCMrC Community Moderator

    This is the first time I've seen problems like this with LastPass's CSV export. Let's see if we can identify what is causing this issue. Send me an email or PM (my email is at the top of the script). Once we get the issue resolved, we can summarize here.

  • What's the e-mail address that you can be reached at?

  • MrCMrC Community Moderator

    My email is at the top of the script.

  • MrCMrC Community Moderator
    edited December 2014

    Here's a summary of resolution of @aniemand's issue above.

    The problem was caused by an invalid saving of the LastPass CSV data into a file. For some users / browsers, the LastPass export process opens a new browser window instead offering to save the data into a file. So the user has to copy and paste the data into a file. In this case, the data was saved without newlines, so the converter was unable to distinguish rows of data. The workaround to this LastPass / browser issue was described here, and I've updated the README file with instructions for this situation.

  • Hi MrC,
    Thank you for providing this conversion tool. I tried it on MacOS 10.10. with the following result trying to convert a txt file from wallet:

    "Thomass-iMac:convert_to_1p4 tome$ perl5.16 /Users/tome/Downloads/onepassword-utilities-2/convert_to_1p4/Converters/ -v /Users/tome/Downloads/onepassword-utilities-2/convert_to_1p4/Export.txt
    Name "DB::single" used only once: possible typo at
    /Users/tome/Downloads/onepassword-utilities-2/convert_to_1p4/Converters/ line 427 (#1)
    (W once) Typographical errors often show up as unique variable names.
    If you had a good reason for having a unique name, then just mention it
    again somehow to suppress the message. The our declaration is
    provided for this purpose.

    NOTE: This warning detects symbols that have been used only once so $c, @c,
    %c, *c, &c, sub c{}, c(), and c (the filehandle or format) are considered
    the same; if a program uses $c only once but also uses any of the others it
    will not trigger this warning.

    Thomass-iMac:convert_to_1p4 tome$"
    What can I do about it?
    Kind regards,

  • MrCMrC Community Moderator
    edited December 2014

    Hi @drtome,

    It is simplest to use the recipe provided in the README, since command line stuff is finicky. Try the following two commands, one after the other, instead of the command you used above:

    cd /Users/tome/Downloads/onepassword-utilities-2/convert_to_1p4
    perl5.16 ewallet -v Export.txt
This discussion has been closed.