1Password Mini picks wrong browser

Options
rlf
rlf
Community Member

I'm a new user to 1P for OSX (version 4.4.3) and the only issue I have so far is that 1Password Mini doesn't seem to know which browser is calling it. I work mainly in Chrome for Mac but I'll occasionally switch to Firefox. If I have Chrome open and then open Firefox and type in my "Show 1Password mini" keyboard shortcut and enter my password, mini will try to open the website in Chrome instead of Firefox even though I had just opened Firefox. The only way I can get this to work is to actually click on the address box in Firefox to have mini open the site open in Firefox. Is this focusing issue a bug with 1Password mini? Is there any way I can get this process to work correctly? Having to stop and click on the FF address window before activating mini sort of defeats the purpose of opening 1Password mini with a keyboard shortcut.

Thanks.

Comments

  • Megan
    Megan
    1Password Alumni
    Options

    Hi @rlf,

    1Password is set to use your default browser for opening Logins, but if another browser has focus on the screen though, the Mini should fill in this browser as well. I know that 1Password's performance here has improved between version 4 and version 5.

    Now, 1Password 5 is the latest and greatest version we have available. It's a free upgrade for all version 4 owners - is there a reason that you're still using 1Password 4?

  • rlf
    rlf
    Community Member
    Options

    I thought that you have to be on Yosemite to use version 5 and I haven't upgraded to Yosemite because it still seems buggy. Can I use v.5 on Mavericks? If so, I'll upgrade. Thanks.

  • Stephen_C
    Stephen_C
    Community Member
    Options

    No, you can't use 1P5 for Mac unless you're running OS X 10 (Yosemite), so you're correct.

    Stephen

  • rlf
    rlf
    Community Member
    edited November 2014
    Options

    Having worked with this another day, this is actually rather annoying. I suspect many users use multiple browsers. IMHO, it makes more sense for 1P mini to open a window in the currently selected browser, not a user's default browser. After all, why would a user switch from their default browser to another one and try to log into that other browser using 1P mini and expect the page to open the default browser they were previously in? That makes no sense from a usability standpoint. Log me in in the browser I call you from. Just my $.02. Thanks.

  • Megan
    Megan
    1Password Alumni
    Options

    Hi @rlf,

    I sincerely apologize for the trouble here. I can see how it would be a little bit frustrating. Now, I've done some testing here with 1Password 4 in Mavericks, and I'm unable to reproduce the issue: 1Password fills in the browser that has focus on the screen, whether my cursor is active in the menu bar or not.

    Here are the steps I took, please let me know if I'm missing anything:

    • Opened Safari.
    • Used ⌘⌥\ ( Command-Option- \ ) to open 1Password mini and selected a Login.
    • 1Password opened and filled the Login in Safari.
    • Opened Chrome on top of Safari.
    • Used ⌘⌥\ ( Command-Option- \ ) to open 1Password mini and selected a Login.
    • 1Password opened and filled the Login in Chrome.
    • Opened Firefox on top of Chrome.
    • Used ⌘⌥\ ( Command-Option- \ ) to open 1Password mini and selected a Login.
    • 1Password opened and filled the Login in Firefox.

    Let's get a few more details to see if we can figure out what's going on:

    • What are the version numbers of your browsers?
    • What is the version number of the extensions?

    Thanks for your help in tracking this issue down!

  • rlf
    rlf
    Community Member
    Options

    Hi Megan,

    I use Chrome Version 38.0.2125.122 Firefox 33.1. I don't use Safari very often so it isn't an issue for me there.

    Robert

  • Hi @rlf,

    A few more questions for you:

    • When you open 1Password mini to fill a login in Firefox, what app displays as active in the OS X menu bar?

    • How exactly do you open the website from mini?

      • Do you press the enter key, from this screen?

      • Or do you use the "open and fill" button in the detail view?

    Thanks in advance for the additional info!

  • rlf
    rlf
    Community Member
    Options

    This typically only happens the first time I open Firefox after having been doing work in Chrome. I use the "Show extension popup keyboard shortcut" which I have changed from the default value to "option+cmd+j". What I've been doing now to ensure the 1P opens in Firefox is that I'll type in "cmd+l" (lowercase L) to put the focus in Firefox's address window before entering the extension popup keyboard shortcut. This forces the focus on Firefox.

  • Hi @rlf,

    If I'm interpreting this correctly, you're saying that you use the first method that @JasperP posted ("press enter key from this screen") as opposed to using the "open and fill" button? I would expect the former to work as expected. The latter will very likely open it in your default browser. I just checked the code and it looks like that path explicitly asks the system for the default browser.

    Rick

  • rlf
    rlf
    Community Member
    Options

    Yes, I believe I do as @JasperP described. I type in the "Show 1Password mini" keyboard shortcut, type the name of the website I want to log into in the Search box that appears, and then hit the enter key to select the website. Just a few minutes ago, I wanted to log in to a site in Firefox so I opened my FF browser, typed in the keyboard shortcut and website name and hit enter as I just described, and 1P logged me into the site via my (default) Chrome browser instead of Firefox. I guess I'll have to live with this but the workaround -- opening Firefox and then typing in cmd + L to put the focus on Firefox -- is pretty annoying.

  • Hi @rlf,

    I've been doing some tests here with Firefox and so far I've not been able to reproduce what you're seeing. That doesn't mean there isn't a bug though. So I've filed a bug (OPM-2619) so that we can take a bit of time and look into this to see if we can figure out a reason that this could be misbehaving.

    I was doing my tests with Firefox 33.1.1, but I doubt much has changed there between 33.1 and 33.1.1, and the logic that decides where to open/fill should be happening outside of the browser. We'll look into it and see what we can find.

    Thanks for the information.

    Rick

  • rlf
    rlf
    Community Member
    Options

    Thanks Rick. I keep encountering this problem and it really is rather aggravating. It didn't happen in 1P v. 3 which is what I just upgraded from. IMHO, I think the problem may be in the algorithm 1P is using. From a user standpoint, I don't think it makes sense for 1P mini to open in the user's default browser by default. If I switch from my default browser to another browser and open 1P mini to log into a site, the fact that I'm in a different non-default browser should be a sufficient signal to 1P mini that I want to log in via that browser, not my default browser. I think 1P mini should use the browser that's currently active -- not the user's default browser -- to log the user in.

    We don't have to continue this thread further unless you find something out. I would only ask that your team take this comment into consideration. Thanks again.

  • Megan
    Megan
    1Password Alumni
    Options

    Hi @rlf,

    Again, my apologies for the frustration here. I've added your thoughts to the issue in our internal tracker. Our devs are looking into this issue, and we'll update you here when we are able to make some progress.

    ref: OPM-2619

  • rlf
    rlf
    Community Member
    Options

    Is there any way I can roll my version of 1P back to version 3? I have to work in multiple browsers all day long and this is SO aggravating, always trying to log in to a site via Firefox and having 1P go back and log me in on my Chrome (default browser) even though the focus was in FF. This behavior didn't occur with 1P Mini in version 3 of your product. Thanks.

  • Megan
    Megan
    1Password Alumni
    Options

    Hi @rlf,

    Personally, I think you're missing out on a lot of cool stuff if you downgrade to 1Password 3 ... and I can't really recommend this as the best solution to the problem. Please note that if you are using the 'Open and Fill' option (clicking on the URL in 1Password to open and fill your details), 1Password will open this Login in your default browser.

    If you would like to use 1Password 3 instead of 1Password 4, I'll need to know a bit more about your 1Password ecosystem:

    • What are the version numbers of 1Password and your operating system for all computers and devices running 1Password?
    • What are you using to keep things in sync?

    Once I know this, I'll be able to give you instructions on downgrading.

  • Andy Caughey
    Andy Caughey
    Community Member
    Options

    Hi, Im experiencing a similar issue. Running 1Password5 and latest chrome and firefox. I open firefox and when I click on the open and fill button within 1P5 it takes me through to a Chrome tab. I tried changing open new page/tab/current tab without success. I only use the browser icons so it is annoying.
    Any ideas?

  • littlebobbytables
    littlebobbytables
    1Password Alumni
    Options

    Hi @Andy Caughey

    We don't have any more information yet on this oddity. From reading this thread all I can say is rlf reported that the keyboard shortcut ⌘L which forces focus onto the address bar resulted in the Login being opened in the correct browser.

    The one thing in common seems to be the two browsers you're running. I'll highlight this in the bug report. Sorry it isn't better news.

    ref: OPM-2619

This discussion has been closed.