New Install ICloud Sync Error CKErrorDomain error 4.0

First time user and new install trying to test iCloud sync and getting the above error.


  • Drew_AGDrew_AG 1Password Alumni

    Hi @bsvol,

    I'm sorry you're running into a problem trying to set up iCloud sync! The "CKErrorDomain error 4" error message usually means your device is having trouble connecting to iCloud, or to the internet in general. Please make sure that your device is connected to the internet, then try syncing again. Does it make a difference?

  • @Drew_AG I've just had the same "CKErrorDomain error 4" error.

    Yes my device (iPhone) is connected to the internet, able to hit websites on Safari. So that is not the issue here.

    Using 1Password 5.1.2. I noticed syncing hadn't happened as a recent change wasn't reflected in my phone. Tried turning sync off, then on again. (So I am in the equivalent situation as the O.P., as if I was a new user.)

    1Password on my iPad and on my Mac is syncing fine, it's just the iPhone having problems.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @jd007,

    Just to make sure I understand: It sounds like you noticed a change didn't sync to 1Password on your iPhone, so you disabled the sync. When you try to enable the sync again, you get the "CKErrorDomain error 4" error on your iPhone. Is that right?

    If so, it may help to follow these steps:

    • Open the 1Password app on your iPhone.
    • Double-click the Home button and swipe up on 1Password to close it.
    • Restart your iPhone (hold down the power button for a few seconds and "slide to power off", then turn it back on again).
    • After the restart, open 1Password and try setting up sync again.

    Does that help? If you get the same error, please let us know what sync option you're using (iCloud, Dropbox, Wi-Fi), and the version of 1Password you're using on your Mac and iPad. Thanks!

  • jd007jd007
    edited December 2014

    @Drew_AG‌ Thanks for your reply. Yes, your description of my issue is correct.

    I tried the steps you suggested, still get the error.

    Sync is via iCloud.

    My iPad app is also version 5.1.2
    Mac app version is 5.0.2

    I am using 3G to connect. Later today I will go in to work and try WiFi to see if it is the same.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @jd007,

    Thanks for letting us know. Since the error message you're getting is usually related to a problem connecting to the internet, I'm interested to know if there's a difference once you connect your iPhone to Wi-Fi at work. Please let us know how that goes, thanks!

  • It worked fine on WiFi. All synced.

    But still not syncing on 3G at all. I turned off WiFi so phone is on 3G, made a change on my Mac, then waited a while and checked the phone. The changes are not showing up there. In 1Password settings, it says that a sync was done 5 seconds ago etc to iCloud, but that is not actually the case.

    I checked iPad, even on 3G it is syncing the new changes.

    So there remains an intriguing issue with the iPhone app on 3G. What else is possible?

  • JasperJasper

    Team Member
    edited December 2014

    Hi @jd007,

    Could you check under Settings > Cellular and ensure 1Password is enabled to use cellular data:

  • Yes I had checked that (it's called "Mobile" here in Australia not Cellular :-)
    It is enabled.

  • So what else is possible here? Is this a bug in 1Password for iPhone?

  • Drew_AGDrew_AG 1Password Alumni

    Hi @jd007,

    The error message you're getting means CloudKit (a feature of iCloud that 1Password uses for iCloud sync) is reporting that it cannot connect to the iCloud servers. Unfortunately we really don't have much (if any) control over that, as that connection is handled by iOS, the iCloud servers, and your device's data connection.

    Since it works for you when your iPhone has a Wi-Fi connection, it sounds like everything is working correctly in 1Password. But it's definitely strange that the internet connection is working in other apps. When the problem is happening in 1Password, are other iCloud services working on the iPhone, or do they have problems as well? Also, when the problem happens, are you able to open websites in the built-in browser in 1Password?

  • Hi @Drew_AG‌ , Thanks for the info.

    I can open websites in the 1Password built-in browser while on 3G.

    I tried using Readdle Documents app to upload/download documents from iCloud Drive. It works on Wi-Fi but broken on 3G. So it looks like you are right, something broken in iOS, but only on my iPhone not on my iPaD. Onto Apple then to ask them what else is possible!

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @jd007‌ It might not do any harm to initiate a dialog with your mobile provider in tandem. Ask them if there is any reason certain data requests might be blocked.

  • jd007jd007
    edited December 2014

    Hi all, well after much chatting to Apple Support (1 junior and 2 different senior advisors, they are highly ignorant of iCloud, all three of them said, "oh these apps you are talking about must use iCloud for their backups right? Is that what you mean?" ... I had to educate them on iCloud Drive, they had apparently not ever heard that 3rd party apps can use iCloud to actually store data/files in order to have it sync across devices! I ended up sending them links to articles e.g. 1Password's page on CloudKit.)

    Anyway after the usual reset network settings etc advice which didn't help, they finally got me to restore the iPhone and set up as a new device. This worked to resolve my issue with 1Password (and the other apps I found that were also not syncing over 3G, i.e. "Audio Memos" and Readdle "PDF Expert". So yay, it is all working now, but wow what a rigmarole to get here.

    Thanks everybody for your input and suggestions.

  • Drew_AGDrew_AG 1Password Alumni

    @jd007, thank you so much for letting us know how that turned out! It's too bad you needed to go through so much trouble to get the iCloud/3G connection working, but I'm happy to hear that problem is now solved. I think that will be helpful if someone else is in the same situation and finds your message here.

    Thanks again, and let us know if you need anything else! :smiley:

  • just a quick update that this bit me recently on iOS 8.2 after I had changed the password on my AppleId ( to reproduce:

    • change password on iCloud account (I also have 2fa set up, but am not sure if that's required)
    • note that 1pass starts to silently fail to sync via iCloud (super duper bad!!!)
    • disable iCloud Sync
    • note that 1pass is no longer able to use iCloud Sync
    • connect to wifi & reinstall 1pass
    • iCloud Sync works again

    needless to say, this was quite an annoying experience (especially the second step)

    could you please try to reproduce this and file a bug at

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @anfedorov,

    Can I just confirm a couple of points.

    When you changed your iCloud password I assume that was via, did you update your iOS device in Settings > iCloud? That's the iOS settings and not 1Password.

    When you disabled iCloud Sync I assume you mean just in 1Password and you didn't disable iCloud Drive?

    Thank you and we certainly will try to reproduce.

This discussion has been closed.