1Password and signing into Outlook.com - mail

I’ve been using 1Password for years to sign into my various email accounts. Three days ago I went to sign into my Outlook.com email account, clicked on the 1P icon which brought up my sign-in info, on which I clicked but it would not fill in the user name and password. Tried several times and it did not work and has not worked since three days ago. Worked flawlessly for years before three days ago!

So I went and saved a brand new login in 1P and tried again but to no avail. This is the only site that I am having difficulty logging using Safari web browser. Any suggestions as to how I might overcome this problem. Presently I am having to copy and paste the info into the sign in area. Thanks kindly.


  • I don't know what might be going on with Outlook.com, but usually when a login item that has been working stops, it means something has happened on the web site end of things. It those cases, it's usually helpful to Save a Login manually. Give that a try.

  • outtacontextouttacontext Junior Member

    I've noticed in the last week that login to my outlook.com mail account from Firefox v 36.01 is no longer working. I'm using the Firefox plugin. I shows the information and I end up having to paste my password in. Every other site is working just fine.

  • IsaiahIsaiah Junior Member

    Thank you, Hawkmoth, for your suggestion about doing a login manually via 1P. I have tried it a couple times now and have not managed to get 1P to sign into my Microsoft account. I really don’t get it because this is the first time ever that it has just stopped working and only for one web site.

  • @outtacontext - Yours is the second report like it in the past day or two, so I took the liberty of merging your post with the other thread that's been discussing it. I wonder if you wouldn't mind trying Saving a Login manually, as I recommended before and let us know if it works for you. If this is more complicated than that, someone from AgileBits will have to take a look at the site and try to decipher what's happening.

  • hawkmothhawkmoth
    edited March 2015

    @Isaiah and @outtacontext - I just logged in to my Outlook.com account successfully without editing anything. The URL outlook.com does redirect you to another URL, but I would have thought if you save a login manually, that would have been captured. The URL in my Outlook login record is https://login.live.com/login.srf. Perhaps you could check your 1Password items to see if that's the URL you are using.

  • outtacontextouttacontext Junior Member

    I just tried that, Hawkmoth. But that isn't working either, I'm afraid. :-(

  • Me too! Me too! Outlook/Hotmail has stopped responding to 1P. I have successfully logged in with the copy-and-paste method, and I manually re-created the login without any improvement. The URL in 1P is the login.live.com . . .

  • Andrew_AGAndrew_AG

    Team Member
    edited March 2015

    I haven't been able to duplicate this problem in 1Password 5 for Mac or iOS, but it's very possible that different people are using different versions and platforms. We need to ask anybody who is experiencing this issue to let us know a few things regardless:

    1) Version number (extension and 1Password app version, if it's on a Mac and/or Windows PC, otherwise just version of the app for mobile).
    2) Platform (Operating System and version number).
    3) The exact (and full) URL that is being used.

  • As @hawkmoth you need to save it as www.live.com

    I had this problem and realized the URL said live.com and not outlook.com

  • Me, again. I'm using Mac OS X 10.9.5, 1P 4.4.3, and Firefox 36.0.4. The same nothingness happens with Chrome 41.0.2272.104. On the other hand, Safari 7.1.3 (9537.85.12.18) (Mark III*, No. 5bis, Rev. 7a) works as intended. (That's not enough to make me change to Safari, though.)

  • Hi @ASquash,

    You haven't stated the version of the extension you're running in each browser, this could be connected.

    Here are my findings on my test machine.

    1Password 4.4.3 for Mac with 1Password browser extension 4.3. In Safari this combination doesn't work.

    If I uninstall the 4.3 browser extension, disable automatic updating of extensions, quit Safari and after launching it again download the 4.2.5 extension available here it then works with the exact same Login items.

    I get the same findings with Firefox. My best guess is one of your extensions is still set to 4.2.5 and the other is set to 4.3.

    1Password Browser Extension v4.2.5 links

  • outtacontextouttacontext Junior Member

    So, littlebobbytables, what you're telling us is to downgrade to 4.25 1password extension (both Firefox and Safari aren't working and they're both using extentsion 4.3)? How about find out what exactly is going wrong and correcting it? Perhaps you're looking into it, but it would be nice to know that what you are suggesting is a temporary solution.

  • dtearedteare Agile Founder

    Team Member

    @outtacontext: I think @littlebobbytables was simply suggesting this as a temporary change to test if it worked for you or not so we could pinpoint the issue.

    I think @prime gave us the key to understanding the issue: is your login saved with a live.com or a outlook.com URL? Perhaps there is another issue as well but I know I am unable to fill if my saved URL is outlook.com. We're pretty sure we know why and will have an update soon.

    If that's not the issue, the other thing that would be great to know is if your login works in Safari or Chrome. That would help us understand if this is a Firefox specific issue. In my testing I had success with Firefox 36.0.4.

    Oh, and knowing which operating system you're on might help as well.

    We're still in the "find the cause" phase so please bear with us as we ask many questions :)

  • outtacontextouttacontext Junior Member

    Great. Thanks for the update. Okay, here are my answers to your question: the login is not working in Safari either. In both cases I'm using extension 4.3. I am using OS 10.9.5. I don't use Chrome.

  • Hi @Isaiah, @outtacontext, @ASquash & @Prime,

    After a bit of brainstorming we're confident we've discovered the exact cause of this bug. The root of the issue lies in the differences between outlook.com, live.com, microsoft.com and so on. All of these belong to Microsoft and over the years they've been handled differently. For the average user like yourselves and I (basically non-devs) we don't and shouldn't need to think too much about what happens if we visit say www.outlook.com but there's a lot happening in the background. So over time Microsoft changes how they use these domains and when they make a big enough change it breaks it for everybody - so we adapt.

    In this particular case we didn't adapt in quite the right way and it caused an unexpected, and certainly unintended behaviour, dependent on the version of 1Password for Mac and extension that you're running. That's why @hawkmoth and @Andrew_AG struggled to replicate the reports and as a result I'm pretty confident that you're all either running 1Password 4 for Mac or as we discovered during the brainstorming, one of the earlier versions of 1Password 5.

    If you're running say 1Password 5.0.2 and experiencing this then the quickest and easiest resolution is to update to 1Password 5.1 for Mac. It's a free update to anybody running 1Password 5 and we haven't been able to replicate the issue in the latest version, that being v5.1. If you can replicate this using 1Password 5.1 with the v4.3 1Password Browser extension we would really appreciate knowing.

    My best guess is a few, possibly the majority of you are still running 1Password 4 for Mac, I know @ASquash is based on his post. For those of you using 1Password 4 we have a couple of temporary solutions until we can get this fix out.

    1. Reverting to the v4.2.5 1Password Browser extension (for now) is one solution but it would mean turning off automatic updates in your browser or browsers. Given turning off automatic updates would mean you're not informed when the updated extension is released this isn't great.
    2. The alternative and likely better temporary fix is altering your website fields for just these logins to match the following image.

    The websites in a nice copy and paste form are:

    1. https://login.live.com
    2. live.com

    If you were to edit an outlook Login item and set two website fields to those values I hope this will resolve the issue for you while using the v4.3 1Password Browser extension. This alteration won't affect your security and it won't stop the Login item working at a later point. Technically once we've issued the fix you could remove the second website if you wish but this can be something you alter and the leave if you prefer.

    Having determined what the cause of this bug is, I can report the fix will be pushed out in what will be version 4.3.1 of the extension. I don't have an ETA I'm afraid for the release but we do understand the impact this has had and how it can cause confusion for everybody.

  • Hi @outtacontext,

    I just wanted to add a bit of an apology here. Sometimes when I come across a problem like this I can get sucked into the discovery process; trying this and that, different combinations etc. - tunnel vision essentially. My previous post was almost more a report of what I'd been trying and my discovery that it was what we call a regression (where it used to work and then we broke it). So I got wrapped up in replicating the issue, jumping between machines to make sure what I was reporting was accurate in terms of my findings and then I hit post.

    As you can see, I have mentioned the use of v4.2.5 in my post above but it's partly because I like to be as complete as I can. The only reason it is numbered 1 is I don't know how to neatly add an image to a bullet point making the suggestion of altering the website fields harder to place as the first suggestion. My goal, and I know I don't always succeed, is to make sure you know as much about 1Password as you need/want and cover all the possibilities available.

    Hopefully the last couple of posts from us have helped but if you have any questions or issues please do post :smile:

  • outtacontextouttacontext Junior Member

    That's okay. I didn't take any offense. I am using 1password 4 (since I haven't updated to Yosemite yet). I did try your second alternative and it works just fine. Thanks very much. Let us know when there is a new extension.

  • The "alternative and likely better temporary fix" offered by @littlebobbytables works with Firefox, which is all I really care about. It's also lots tidier than my planned next step, and the goat is happier, too

  • dtearedteare Agile Founder

    Team Member

    Great! Thanks for the updates, @outtacontext and @ASquash!

    Lil' Bobby and I had a fun call today digging into this issue. Thanks a bunch for reporting such an interesting problem :)

  • I see the adapting part, but I think we think a way something should be, and it works. When I had my gmail account, I would type "gmail.com" and that would take me to accounts.google.whatevertheyuse.com and it worked. So now I use outlook and type outlook.com and it takes me to live.com. I just never noticed this until I got 1Password.

    Another example I tried. I typed 1Password.com and it took me to https://agilebits.com
    Some people might not even noticed the URL change (re-direct) and just do this out of habit.

    I think the best thing to do is copy the URL from the address bar and paiste it to 1Password.

  • brentybrenty

    Team Member

    @prime: Even better: if you manually save your login on the actual login page, it should have the 'correct' URL, since it has already finished any redirects and 'landed'. That way 1Password can take you right back there from zero next time. :)

    I know the login portals (and even entire websites) can change or shift dramatically over time -- and Outlook/Live/Microsoft/Passport/Hotmail/(YouGetTheIdea) are a 'prime' example of this. Microsoft hasn't had quite as many CEOs in that timeframe, but I digress... ;)

  • Using 1P 4.4.2 on iMac with OS X 10.9.5 All logins work (and always have) except Outlook auto fill quit sometime in last few days. Any one else with this problem? Solutions?

  • BenBen AWS Team

    Team Member

    Hi @carpetboy,

    I've merged your post with a discussion on what I believe to be the same issue. Please see above. Thanks!

  • dtearedteare Agile Founder

    Team Member

    Just a quick note to mention that the version 4.3.1 of the browser extension fixed this issue. The update should install automatically over the next 24 hours or so. Alternatively, you can trigger the update to happen sooner by following the instructions here:

    Updating to the latest 1Password extension

    Please let us know how it turns out :)

  • Well version 4.3.1 works for me.

    Running 1Password 4.4.3 and filling in an Outlook login with https://login.live.com as the single website field works. Hopefully it will work as well for everybody else :smile:

  • outtacontextouttacontext Junior Member

    Thanks, dteare!

  • dtearedteare Agile Founder

    Team Member

    You're very welcome! :)

This discussion has been closed.