1Password on Mastodon

5.3 Auto Fill stopped working with Desktop Broker

johnozjohnoz
Community Member
edited April 2015 in 1Password in the Browser

1Password 5.3 no longer auto fills in 1Browser on an iPad mini 2xiPhone 5 and an iPad 2 all running IOS 8.2. It didn't happen yesterday before we updated or now on 1xiPad that has been reverted to the previous 1Password version. Website is desktopbroker.com.au BTW all working fine on Mac OSX 10.10.2 with 1Passowrd 5.1

Comments

  • littlebobbytableslittlebobbytables
    1Password Alumni

    Hi @johnoz,

    First of all, I'd like to say thank you for all of that information. It allowed me to understand exactly what you're experiencing.

    So I have some bad news and some good news. The bad news is I can replicate your findings. I tried a variety of attempts to fill a DesktopBroker Login inside 1Browser and I couldn't get it to work. I tried:

    1. A basic Login item, one created inside the main 1Password window on a Mac with each field manually entered.
    2. A Login item created by 1Password 5.3 for iOS. We can now save new Login items from the iOS extension and while the steps are different it's like saving a Login from the 1Password Browser Extension where it looks at a page to determine what fields it needs to know.
    3. A login item created in 1Password 5.3 BETA for Mac following our Saving a Login Manually guide.

    All failed to fill in 1Browser, either automatically after tapping on the URL to initiate open and fill or even after the page was loaded and tapping on the key to fill. So we have some work here to do and all I can do is apologise that this has broken for you in 1Password 5.3 for iOS.

    Now at the start I did say there was some good news. Hopefully you see it as good news. While for unknown reasons it won't fill in 1Browser, the Login items I created do work from inside iOS Safari. Why? well that will be up to the developers to figure out but it works for me. If I tap and hold on the URL in 1Password I get three options popping up, the third being Open in Safari. If I select this option I'm switched over to Safari with the page loaded and if I select the very same Login item following our Use the extension in Safari section as detailed on our Extension page it fills in. Now it does involve more steps, I can't deny that but it will allow you to to continue working with the Login item in a semi-automated manner. How do you feel about this particular workaround while we try to understand why 1Browser isn't working?

  • johnozjohnoz
    Community Member

    Thank you for testing and confirming my experience with iOS 1P 5.3. I have at least one other financial site that wont auto fill (same issue) -- I haven't checked them all. I also released auto fill in iOS 1P 5.3 works with Safari and am using it that way on one device, and can live with that in the short term because I have reverted all other devices bar this one back to the previous IP version. For your further understanding (grin) using Safari with iOS 1P 5.3 this way is VERY clunky for me. I use it for multi site access, swapping between sites, etc. 1Browser seems to work well swapping back and forth and having to re sign into various websites regularly, etc. Anyway, you seem to have a growing issue with auto fill in this version. I hope you fix it because it would be a deal breaker for me to have to work this way for too long. Thanks, great product until now :)

  • dtearedteare Agile Founder

    Team Member

    Thanks for your understanding @johnoz. It was my code that had the problem so I feel pretty bad about it. Thankfully a marathon coding session yesterday got all these bugs fixed. :)

  • johnozjohnoz
    Community Member
    edited April 2015

    Just thought I'd let you guys know that I've just used 1PW 5.4 on 2 iOS 8.3 iPads and auto fill worked on my 2 problem sites using 1Browser. Thanks, 1PW harmony reinstated :)

  • littlebobbytableslittlebobbytables
    1Password Alumni

    That's great to hear @johnoz :smile: We're improving the new filling logic or brain every day so if you come across a site that doesn't work please do let us know!

This discussion has been closed.