Can't enable iCloud sync on Mac

Options
foca
foca
Community Member

When I go to the Sync preferences page, I see this:

  • I have iCloud enabled, and iCloud drive checked.
  • I tried installing the newest beta in case it was a bug in the stable version. It still happens.
  • I tried disabling iCloud on my phone and turning it on to see if that had any effect. It didn't.
  • I have both devices (Mac and phone) logged into the same Apple ID.
  • I tried quitting the agent and rebooting the computer, but still, nothing.
  • I don't have the WiFi server enabled, if that's any help.

Right now running:

1Password 5
Version 5.3.BETA-30 (530030)
Agile Beta

I installed dropbox in the phone again just so I can sync passwords until this is fixed, but it's really frustrating :(

Comments

  • Vee_AG
    Vee_AG
    1Password Alumni
    edited April 2015
    Options

    Hi @foca,

    Thanks for getting in touch with us, and for including the helpful screenshots.

    The thing is, Apple only allows us to integrate iCloud Sync functionality in apps sold through the Mac App Store. So the version you have, which was downloaded from our website, unfortunately cannot sync via iCloud. We're sorry for any frustration this has caused you. You may find more info on our FAQ page on this subject.

    There's currently no way for us to transfer webstore licenses to the Mac App Store, but if you've bought a 1Password 5 for Mac license from our webstore in the past 30 days and you'd like to switch to the MAS version, we totally understand, and we can refund your webstore purchase if you wish. If that's what you want to do, please email a copy of your 1Password 5 receipt to support+webstoreicloud@agilebits.com, and include a link to this discussion thread so that you don't need to repeat yourself to our email support team.

    I hope this helps! Let us know if you have any more questions. Thanks. :)

This discussion has been closed.