Safari Extension problem

Options
SarahJBuckley
SarahJBuckley
Community Member

I am having a problem with 1password 5 that I purchased a month or so ago, I used the trial version too and really like it Thanks. However, when I close Safari, I lose the extension, usually I have to re-add it in from the Safari extension menu, but now it is completely gone, not in the Safari extension menu at all. How do I get it to stay there? (Ver 8.0.3)

Comments

  • Jasper
    Options

    Hi @SarahJBuckley,

    I'm sorry to hear about the trouble. First of all, please try a simple reboot of your system:

    • Restart your Mac.
    • Re-install the 1Password Browser Extension.
    • Launch Safari and enable it if necessary.
    • Quit and relaunch Safari.

    If the extension isn't there, check the permissions for Safari's Extensions folder next:

    • Open a Finder Window.
    • Use the Go > Go to Folder... menu item.
    • In the text field that appears, copy/paste this in (including the ~) : ~/Library/Safari
    • Click Go.
    • Finder will navigate to that folder (it's normally hidden, that's why we use that trick to get to it).
    • Find and select the Extensions folder inside of ~/Library/Safari.
    • Use the File > Get Info menu item.
    • A panel will show up with a bunch of information about the folder. The last item it should have is called Sharing & Permissions. Make sure it's expanded.
    • Make sure that the row that corresponds to your user has Read & Write permissions. If it doesn't, you may need to unlock the panel via the lock icon in the lower right to make the changes.

      • Here is an example:

    • If you made a change to the permissions, restart Safari and see if that fixed it.

    If that wasn't it, also check to make sure that Safari has permission to save its extension list in your keychain:

    • Launch Keychain Access. (Enter the first few letters of its name into a Spotlight search and select it in the results.)
    • Make sure "All Items" is selected in the Category sidebar on the left.
    • Use the search box in the toolbar of the Keychain Access window to search for an item named Safari Extensions List.
    • Double click that item. A window will be displayed with additional information. Select the Access Control tab.
    • In the Access Control tab, check if Safari shows up in the list of applications that are always allowed access.

      • If it isn't there, add it via the "+" button (you'll have to locate the Safari app in a Finder dialog that appears).
      • If it is there, remove it using the "-" button, then re-add it using the "+" button (you'll have to locate the Safari app in a Finder dialog that appears).
      • Example:

    • Restart Safari, re-install the extension, and see if that fixed it.

    If none of these suggestions help, please let us know.

This discussion has been closed.