Passwords revealed at random [alt key was being used as mouse modifier]

Options
carl.p
carl.p
Community Member
edited April 2015 in Mac

Hi,

I've been trying to replicate the exact steps before reporting this issue, so after having failed at that I'm hoping someone else could confirm if this is in fact a bug.

I have the following enabled in settings: Security > Conceal passwords
My OS X is running V10.10.3

The problem:
After unlocking 1Password and selecting random Folders/Tags all seems fine, then when I select a random Item (on the right) but not the fist one, the password is shown... even though I have "conceal passwords" enabled.

Right after that, when I select a different Folder/Tag it shows the password of the first Item... even without me having selected the item (but this behavior seems to be random)

Really hope there's some hidden setting/fix for this :'(

Comments

  • Megan
    Megan
    1Password Alumni
    Options

    Hi @carl.p,

    Thanks for bringing this to our attention, I'm sorry that 1Password is misbehaving for you. Unfortunately, I've been testing here, and I'm unable to reproduce this behaviour. Could you let us know which version of 1Password you are currently running (just to be sure we're testing with the same set up as you.)

    I do appreciate you trying to get steps that are reproducible, it will make it a lot easier for us to fix the problem if we can see it here as well.

  • carl.p
    carl.p
    Community Member
    Options

    At the moment I'm running:
    1Password 5
    Version 5.3 (530032)

  • littlebobbytables
    littlebobbytables
    1Password Alumni
    Options

    Hi @carl.p,

    Please do keep us updated if you manage to narrow down any sequence that seems to replicate this. For me 1Password behaves as expected and I too have Conceal passwords option enabled. To reveal a password I either have to hold down the (alt) key or go select the reveal option in the small menu connected to any password field. What you describe is definitely undesirable but reproducibility is usually key to isolating the bug in the code.

  • carl.p
    carl.p
    Community Member
    Options

    Ok, I finally found the problem.

    I've been using EasyDrag (http://nikolozi.com/apps/easydrag/) for years now to bind my right ⌥ (alt) key as my mouse click.. which is essential for being able to drag etc. (especially when working with PS, AI, etc.) ...and because I'm not a fan of the loud pounding sound the trackpad makes.

    Previously I never had this issue, but for some reason after I did the upgrade (finally!) to Yosemite I started having this problem in 1Password... never realizing that I'm using my right ⌥ (alt) for all the clicking.

    I'm 100% convinced that this is mainly an issue with the way key binding is done with EasyDrag... but I would really love to see a setting where I can change or completely disable this keyboard shortcut or at the very least force it to use/trigger exclusively on the left ⌥ (alt) key 8-)

  • littlebobbytables
    littlebobbytables
    1Password Alumni
    Options

    Well I'm glad we were able to at least discover the root cause of this @carl.p :smile:

    I'll add a request to see if we can allow either the disabling of this keyboard shortcut or make it configurable.

    Now it might not be to your taste at all but I rarely click the trackpad either, if I am it's usually a sign that something is driving me daft. For me it's a combination of Tap to click in System Preferences > Trackpad (Point & Click tab) being enabled and also the Enable dragging option which is in System Preferences > Accessibility > Mouse & Trackpad and then in the Trackpad Options.... The with and without drag lock may be of interest too. With those two options enabled a double tap (no click) on the trackpad will allow me to drag files around just as if I had clicked the trackpad and was holding it down with one finger whilst dragging with the other. I find my system a lot more elegant than the defaults but it might not fit in with your style although we both seem to agree that the standard way could be improved on :wink:

    Anyway, your request has been made.

    ref: OPM-1506

This discussion has been closed.