Can not download update file.

Community Member

Please check cdn file.

I received version 5.3.1 update notify.
And then update failed.

check under terminal got result below:

➜ ~ wget
--2015-04-29 18:09:38--
Connecting to||:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2015-04-29 18:09:38 ERROR 404: Not Found.


  • Stephen_C
    Community Member

    See if you're able to download it directly from this page. I don't guarantee it will work for you but it's worth a try.


  • Hi @yibozheng,

    We're having issues with one of our CDN providers. Here's a screenshot showing the 200 response I get from that same URL:

    The updater has a "Source" menu item where you can change where the download comes from and you'll likely have better luck with one of the other sources. This is obviously not a real long term solution and users shouldn't be expected to have to do this. We're looking into what's going on with the CDN and how we can rectify the issue.

    Apologies to everyone affected by this.


  • ChuckinNihon
    Community Member

    Dear rickfillon,

    Changing the source of the update download solved the problem. I'm now running 5.3. The source option listed 3 sites, the last of which was AgileBits. I chose that one, naturally, and the update progressed as all previous 1Password updates have. Since I've never had a problem with updates in the past, I'd had no reason to investigate the menu options in the Updater before.

    I guess the only question now is why the update download from the AgileBits manual site delivered faulty ZIP files?


  • Drew_AG
    1Password Alumni

    Hi @ChuckinNihon,

    Great, thanks for letting us know that worked for you! :)

    I've never needed to change the download source in the Updater before either, it's not something you would normally need to do. There was a problem downloading the update specifically via CacheFly. I don't know what the exact issue was, but we contacted them about it and their engineers were able to track down the bug and fix it, so it should work correctly now for anyone else who still needs to install the update.

    If you run into any other issues, please let us know!

This discussion has been closed.