1Password on Mastodon

Filling in the wrong fields

Hi, I was having trouble with the login form on www.airnewzealand.co.nz - so I deleted the saved password and attempted to "record" me filling in the form again. It prompted me to save the login as expected, but once again - is filling in the travel dates part of the page, and not the credentials.

I think I can remember it working on the odd occasion which is weird. Anyway - at the moment the only way to login correctly is to manually copy and paste the password, which can get a bit annoying as I use this site quite frequently.

Would love some help!

[](https://us.v-cdn.net/5020219/uploads/editor/19/uy1n3mx34tp0.png "

1Password 5
Version 5.3.2 (532001)
Agile Web Store

1Password Version: Version 5.3.2 (532001)
Extension Version: 4.3.1
OS Version: 10.10.3
Sync Type: Dropbox


  • hawkmothhawkmoth
    Community Member

    Have you tried saving a login manually? That often helps when things don't work quite right when you save it automatically as you've described. It's certainly worth a try. It often gets things working correctly. Instructions are on this page.

  • littlebobbytableslittlebobbytables
    1Password Alumni
    edited June 2015

    Hi @rohanadarkar,

    In your saved Login item, do you see two website fields, one with http://www.airnewzealand.co.nz and the second starting with https://auth.airnewzealand.co.nz? If you do I believe the workaround for this site shouldn't be too bad.

    If you edit the Login item and delete the first website field, the one containing http://www.airnewzealand.co.nz you will find that 1Password mini doesn't even offer the Login item as an option to fill the page any more. Instead though, if you use open and fill either from 1Password mini or the main window it will open a new tab directed at https://auth.airnewzealand.co.nz and that I believe will work. In the main 1Password window open and fill can be initiated by clicking on the URL in the Login item and in 1Password mini, searching for you Login item and selecting it will also cause open and fill as 1Password mini knows the current tab's URL doesn't match.

    If you have an iOS device this will also allow the Login item to work there as I noticed the small login window on the webpage is an IFrame which we currently have trouble handing on iOS.

    Does the above work for you and does it seem like a reasonable workaround?

  • rohanadarkarrohanadarkar
    Community Member

    Hi there,

    I did remove the first website field and then tried two things:

    1) Entering the password as before - I knew this wouldn't work, but thought - heck why not try it?
    2) Opening the website using "Open and fill"

    The first option didn't work - it still tried to fill in the main window.
    The second option looked promising. It opened just the iframe in a new window, filled in the form and submitted it. The problem is that it just rendered a blank page. It didn't actually log me in. Bummer.

    I tried manually saving the login as well and that fills out the wrong form fields as well.

    Any other suggestions?


  • littlebobbytableslittlebobbytables
    1Password Alumni

    That's a pity @rohanadarkar, I had hoped you'd be redirected back to the main page but now be logged in :(

    The only other aspect I've noted is a difference in behaviour only visible it seems if you disable submitting for this Login item. Let me explain.

    1. Create a brand new Login item following the How to manually save a Login guide as you've done before.
    2. Edit this new Login item and change the submit option from Submit when enabled to Never submit.
    3. Go to http://www.airnewzealand.co.nz/home and bring up the sign in window. Attempt to fill using this new item. The sign in window will disappear and it will still fill in your username in the from field for booking a flight - not very useful.
    4. Bring up the sign in window again and attempt to fill once more. With your username in the from field, it now properly fills in your username and password in the correct fields. I would hope clicking on Go would then work.

    Assuming this works it's pretty inelegant but it may at least allow you to log in while we work on this. Please do let me know if this makes any difference.

  • rohanadarkarrohanadarkar
    Community Member

    Hi there - woohoo! That works for now :) Thanks for the workaround. I hadn't noticed the "Never submit" option before and I think it would be quite handy for a couple of other sites too.

    Anyway - appreciate you guys looking into this for me and I hope there is an elegant solution that you can come up with! :)

    All the best!

  • littlebobbytableslittlebobbytables
    1Password Alumni

    I'm glad we found something that worked @rohanadarkar, now we just need to make it work better :wink:

    Thank you for letting us know that workaround at least does allow the use of 1Password filling and hopefully we'll figure out what's going on.

    Now sadly it means we don't have a way to log into that website on an iOS device given the IFrame and the fact that the IFrame's page doesn't log you in. I hope that won't be an issue for your intended usage.

  • rohanadarkarrohanadarkar
    Community Member

    No - fortunately they have a robust App on iOS/Android :) Thanks again @littlebobbytables

  • littlebobbytableslittlebobbytables
    1Password Alumni

    :+1: :smile:

  • rohanadarkarrohanadarkar
    Community Member

    Hey @littlebobbytables - just a quick update. I noticed on one of the Air NZ pages there was a link to a discrete login page that logs you in without any issues. I've added this page to be the one that loads by default now and no more iframe issues.

    Obviously it would be nice to fix the homepage login, but this is a fool proof workaround in the interim.

    Here is the URL to the dedicated login page: http://www.airnewzealand.co.nz/vloyalty/action/mybalances
    which I found on this page: http://www.airnewzealand.co.nz/oneup

    Hopefully this helps someone else too!

  • littlebobbytableslittlebobbytables
    1Password Alumni

    Thank you for reporting your discovery @rohanadarkar, I've made a note of it in Synapse, our filling error report tool.

    Should anybody try to fill in that page then currently they'll discover exactly what you did - that it doesn't work. Now in the Settings menu of 1Password mini there is a Report Website Issue (see image below). Now if somebody reports that website we suggest the URL you've found as a workaround for now (rather than as a fix) :smile: That's some nice detective work on your part so thank you!

This discussion has been closed.