Return of the dreaded "Failed to fetch some record zones"



  • Wonderful...! Worked for me @AGKyle. Thanks.

  • AGKyleAGKyle AgileSupport 1Password Alumni

    @jthj Unfortunately this isn't a bug on our side, so it's not something we can fix in the application. There are people investigating though so hopefully we'll see that the cause is found and either we can prevent it or Apple can prevent it from happening in the future.

    I am sorry for the trouble though. We definitely don't like seeing this happen.

  • iCloud syncing seems to be back this morning (PST). How about you guys?

  • Works for me now. Successfully synced my iPhone just now.

  • Still not working,

    Signed out of iCloud, deleted iCloud data from within the app, restarted iPad and still same issue.

  • AGKyleAGKyle AgileSupport 1Password Alumni

    @larrythelasertech Sorry to hear that.

    I'd like to ask you to create a Diagnostics Report from your iOS device:

    Attach the Diagnostics Report to an email message addressed to [email protected].

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report and ensure that it is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks very much!

  • I have been talking with someone since this started here is the first case # Re: [#KIY-13766-592] have not received a response back from this person.

    This is the case number I received after sending in my diagnostic records for the second time: Re: [#VIZ-47888-493]

  • BenBen AWS Team

    Team Member

    Thanks Larry. Looks like we had two separate cases going as you wrote in from two different email addresses. I've merged the two (under KIY-13766-592). We'll be back to you as soon as we can after we've reviewed the latest reports.

  • Ok thanks, looking forward for a resolution.

  • asvorenasvoren Junior Member

    Yes! All good now. Thanks for the effort.

  • brentybrenty

    Team Member

    Thanks for the confirmation! It's working here as well now. Cheers! :)

  • larrythelasertech:

    The following is a method to have 1P sync to iCloud again, after the latter fails.

    If you do not see the two words in red font "Disable Sync" when attempting to an iCloud sync service, the "Failed to Fetch Some Record Zones" error message will appear. There is no exit; you are trapped in this no sync error loop. If this is the case, a fresh install of the app is required. Delete the corrupt or non-responsive 1P from the device's iCloud Documents & Data.

    Assuming you have many 1P items, first you need to do is go to the app's Advanced option to create a backup. When connect your iOS device with a USB cable to iTunes for app file sharing under 1P, save the "Backups" folder to your local drive. If you don't, once the iOS device is disconnected from iTunes, the Backups Folder is deleted as well.

    Delete the corrupted 1P app from the iOS device

    When you completed your new 1P reinstall, use the same Master password and hint for the app configuration and select iCloud sync. You should now see the two words "Disable Sync" in the reinstall.

    In the newly reinstalled app, open Security Note, and create a note with a simple title such as "test." Now go and create another Backup.

    Connect the device with your desktop iTunes, under the 1P app you will see this new Backups folder (i.e. the one created just with a test Security Note).

    Hit the computer's Delete key to delete this Backups folder.

    Drag and drop the Backups folder (created earlier from the non-iCloud sync app before its removal) into the 1P share file space in iTunes. Make sure the name of the folder is called "Backups". Also make sure your device is USB cabled to iTunes.

    Now in the iOS newly reinstalled 1P, go to the Advanced option and do a "Restore from Backup". All your 1P items are now restored with the same contents and master password. iCloud sync should now be working again.

    Next time, when iCloud sync fails again, do not "Disable Sync" in 1P. If you have more than one iOS device, use any of the Share Login functions for updates.

  • brentybrenty

    Team Member

    Delete the corrupt or non-responsive 1P from the device's iCloud Documents & Data.

    @Lymond: Noooooooooooo! :scream:

    To be clear, the problem larrythelasertech has been experiencing is separate from the one this discussion pertains to. Confusingly, however, the error message is the same since 1Password doesn't know why it can't fetch iCloud data, only that it can't. Deleting 1Password's data from iCloud itself is what causes the problem in the first place (at least apart from issues with iCloud itself — same error, different cause), so we definitely don't recommend deleting 1Password's data from iCloud in iOS Settings (or OS X System Preferences, for that matter) as a matter of course, as this would result in 1Password "Fail[ing] to fetch record zones" even after iCloud comes back.

    If, however, someone has already deleted 1Password's data from iCloud (again, Don't) the easiest way to get back up and running is to follow these steps:

    1. Backup your data using 1Password for iOS and iTunes
    2. Delete 1Password for iOS
    3. Reinstall it
    4. Launch it and choose New User to create a vault
    5. Enter the same Master Password as before
    6. Sync this new vault to iCloud
    7. Restore the backup
    8. Re-sync and merge the data
    9. Let it finish then re-sync any other devices

    Cheers! :)

This discussion has been closed.