1Password on Mastodon

Error signing into one bank w/iPhone and no other devices ? Deleted and reinstalled App

Community Member

Issue only with one bank and only on iPhone . Use Drop Box. No issue on iMac, MBP, iPad . All are newish and fully updated. Deleted and reinstalled App on phone; restarted phone; used Wifi and VZ cell . Bank requires two pages....first w/ account #, second for photo icon and PW. Currently when I access 1Password using App and inside it's web access , click on DuPont Bank , it opens the first account page with my account #, but a new Pink box banner covering the top of page : This page contains the following errors: error on line 228 at column 20: Opening and ending tag mismatch : img line O and a Below is a rendering of the page up to the first error " . I'm wondering if there is some file or folder that needs to be deleted ?? Since it works on the iPad and all devices ....it can't be the Drop Box file ? It can't be the bank link....because the same link in Drop Box is used for all....and the iPad is the same iOS app version. What am I missing ??

1Password Version: 5.5
Extension Version: ?? Only for MBP & iMac ?
OS Version: iOS 8.4.1
Sync Type: Drop Box
Referrer: forum-search:Error signing onto one bank on iPhone


  • MuleladyMulelady
    Community Member

    This is my issue: I just read about a snag in 1Browser several months ago on this site where it suggested I copy/paste into the Safari App ....it worked ! Weird....why is this still an issue ....and NOT on my iPad Mini ? How can I fix this on my iPhone where I need it the most ? I already deleted the App ....what other option will repair this ?

  • Drew_AGDrew_AG
    1Password Alumni

    Hi @Mulelady,

    I'm sorry you're having trouble with your Login for that site on your iPhone! If the same thing works on your iPad then it should certainly work on your iPhone as well, and I'm not sure why there's a difference, but I'm sure we can figure out what's going on.

    First, I'd like to get some more details about your setup and how you reproduce this problem:

    • What exact version of 1Password is installed on your iPhone? And what exact version is on your iPad?
    • If you don't mind, what is the exact URL in your Login item for that bank?
    • Did you create that Login item on one of your iOS devices, or on one of your Macs?
    • Is this happening in 1Browser (1Password's built-in browser) or in Safari? (It sounds like you're doing this in 1Browser, but I wanted to be sure.)
    • If this happens in 1Browser, do you also have a problem with that site in Safari?
    • What are the exact steps you take to reproduce this issue once you open 1Password? (The more details, the better.)
    • If you open 1Browser and manually type the URL into the address bar, does it open that site correctly or give an error?
    • If you open 1Password and go to Settings > 1Browser, what is the setting for the User Agent? (Please check this on both iOS devices.)

    Thanks in advance!

  • MuleladyMulelady
    Community Member

    Version is 5.5 on iPhone ( exact same on iPad Mini that does work ?? ) .
    I would imagine it was created on my MBP as it is easier to create there...and I didn't have the iPhone till last year ? I've saved & used passwords to my Drop Box file and assume all devices are accessing/using the exact same file ?
    This is only happening in 1Browser . This afternoon I was checking to see if there was an answer and discovered the different forum for signing in and noticed the old April comment from 1Password about an issue like this. I hadn't ever used Safari /iOS after learning about 1Browser ( seemed more secure and easier ), so didn't know about the Extension option. I tried it once this afternoon ( on iPhone )....not sure how correct....some copy and paste....but it did work ! Since it works fine on the iOS iPad Mini , I don't see why it can't work on the phone ?? I also deleted and reinstalled the App. when initially had this problem.
    For the record, this particular bank has two pages.....the first one ( above ) enters the account #....auto moves to second page with chosen animal icon and PW input where I must copy and paste ...press enter again to finally go to account page. In this current dilemma , the pink error banner appears over the first input account page . On the Mini....it continues to open DuPont bank as desired.
    I just typed the https line above into the browser and it said " Server Error 404 file or directory not found The resource you are looking for might have been removed , had it's name changed, or is temporarily unavailable. " Next I tried the same process ( typed the above link into 1Browser on iPad Mini ) and it DID open the primary DuPont bank page where the account # goes....and did NOT Error ?!
    iPhone 1Browser User Agent is " 1 Browser "
    iPad Mini 1Browser User Agent is " 1 Browser "
    I notice there is a Clear Web Data bar.....should I touch that ?? I was afraid to change the User Agent because I didn't know if that might make a bigger mess ....don't know the difference on one choice over the other ??
    I notice the MBP has a tab for " clear clipboard "....should I touch that ? Is that the same as " Clear Web Data " on iOS ?
    One more tid bit.....this DuPont issue isn't just with MY access.....I also manage my husbands account....has same issue. For heck of it, I got on the first pink banner error page and clicked Enter and it produces another pop up " Failed to Load Page The operation couldn't be completed. ( NSURLErrorDomain error -999.) "
    Should I change the User Agent on iPhone....reboot .....??....change back to 1Browser since that's way better than copy/paste to Safari ?
    I'm going Madd.....thank you for trying to help me .......

  • BenBen

    Team Member

    Hi @Mulelady,

    Sorry we don't have an immediate answer for this, but hopefully with some troubleshooting we can find a workable solution.

    This page contains the following errors: error on line 228 at column 20: Opening and ending tag mismatch : img line O and a Below is a rendering of the page up to the first error

    This one is an error on their website. They have an issue in their code. Nothing we can do to fix it. You may be able to work around it by switching 1Browser's user agent to Safari, as I didn't note the problem appearing in Safari. They use different code depending on which browser and device you are using. It happens on my iPhone but not my iPad, and in 1Browser but not Safari, as well. It doesn't appear this affects the site's functionality?

    " Failed to Load Page The operation couldn't be completed. ( NSURLErrorDomain error -999.) "

    This one is more concerning, as it sounds like the page doesn't load at all in this case?

    A few further questions:

    1) If you add a Secure Note test item in 1Password on your iPhone, does it appear on your iPad? [may have to relaunch 1Password to cause a sync]
    2) Is it possible one of the devices is on WiFi and one is on 4G / cellular data?
    3) Does everything work as intended when using Safari on the iPhone to login to this site? If so, that may be the solution. If you haven't already enabled the Safari extension on your iPhone you can read more about that here: https://support.1password.com/guides/ios/enable-extension.html (no copy & pasting required).

    Thanks for your continued patience with this issue. Hopefully we'll be able to find a way for you to conveniently access this site from your iPhone.


  • MuleladyMulelady
    Community Member

    Ben: I created Test Note on iPhone ( and waiting for syncing as you suggested ) , the note appeared on iPad . Next I activated the Safari Extension option on the iPhone ....and I must be doing something wrong. I start with VZ LTE as I assume I'd be wanting the security when I can't use 1Browser . When I click Safari 1Password, it won't open the DuPont links....only a short list of charge card options, two identity forms and says I have to create a Login ? I didn't want to make another one to confuse things more ! Next I changed to using Wifi ....exact same dilemma....can't get to the DuPont login info ?
    I did enable the extension IN Safari....but is the current problem that I must also change my iPhone " User Agent " from 1 Browser to Safari ???? Then ....every time I wish to visit the bank ( assuming this works ) I will have to keep changing my agent setting in 1Password ? ! I was confused/surprised when you said the bank code is to blame....yet the same code can work on my iPad and NOT my iPhone ??? Is that true ? I would think they were identical ? If true...I know it is a waste of time for me to approach the bank about it.....they don't even know what 1Password IS !!!!!!! Been there.....this is wearing me out .

  • MuleladyMulelady
    Community Member

    Ben...are you saying that you feel my iPhone sign-in issue to DuPont is caused by DuPont...rather than my devices, my software or hardware issue ? If yes...should I be ( trying!) to inform the bank that THEY have an issue ? They are also involved with Apple Pay...which I hope to use when I trade up in November.....might I expect to have issues then too ? Am I correct that I am safer using 1Browser and/or Cellular access for banking in public ....rather than Wifi and/or Safari ??

  • Hi @Mulelady,

    One thing a web page can do is query the device making the request and obtain a little information about it. They can use this information to alter the page that is being returned. You don't realise it but this has been happening for years. Certain web browsers understand different standards or there are known quirks that you wish to avoid with a particular browser. This has been extended to account for different sizes of viewing devices - it's how a web site knows to return the mobile version of a site rather than the full sized one that you would view on a desktop or laptop. The preferred approach these days is to use Cascading Style Sheets to simply rearrange the same information but many sites still simply serve up a completely different page for phones and another for everything else. That's why it's possible to see an error on an iPhone and not on an iPad. I'm not saying that's definitely the case here, merely that's why it is possible a particular page is broken yet it seems to work elsewhere.

    Now our iOS Safari Extension works a bit differently from the extension on OS X or Windows. In the iOS extension we don't yet have the ability to view your entire vault and select an item to perform open and fill, the extension just allows you to fill the currently open page. Part of the reason is iOS Extensions should be as small as possible as iOS can remove it from active memory if it decides it wants to. That's why we thought very carefully about adding the ability to add an item from the extension as a really bad UI experience would be watching the extension being purged from memory while you were trying to add an item.

    If I want to open a URL stored in a Login item on my iOS device this is what I do.

    1. Launch 1Password for iOS.
    2. Find the item and bring up the item's details.
    3. Tap and hold on the website field. This will bring up three options *Copy**, Open & Open in Safari.
    4. Select the Open in Safari option and 1Password for iOS will pass the URL to Safari.
    5. I then use the iOS 1Password Safari Extension to fill the page.

    If you visit a particular page often enough you would probably want to bookmark the login page from within Safari to streamline the steps.

    Now the Clear Web Data option in Settings > 1Browser simply clears the 1Browser cache. If a page isn't loading properly there might be a corrupted copy in cache being used. No harm can come from seeing if it helps.

    The Settings > Security > Clear Clipboard setting instructs 1Password to clear the iOS keyboard after a certain period of time if you copied a field from an item in your vault. The idea is if you copied a password from an item to paste elsewhere in another app you don't want that password left in the clipboard until the next time you copy something (which is the normal behaviour). This allows the clipboard to be purged after a pre-defined delay. I have mine set to 90 seconds for example.

    Hopefully that was informative but if you have any follow up questions or feel something remains unanswered please do let us know :smile:

This discussion has been closed.