[Bug] Closing preview results in black screen

edited September 2015 in iOS Beta

Reference [#RMB-45647-652].


I ran into a bug in the latest TestFlight beta (600016) on my iPhone 6 running iOS 9.1 PB1 which should be reproducible.
For multiple items I have jpegs or pdfs attached to those items.
1. When I click on one of those attachments it is opened (let's call it preview like on the Mac).
2. When I want to close preview I can either click on done in the top bar or swipe it down.
A. Clicking the done button works like it should be. Preview is closed and I return to the item.
B. However, when I swipe down preview I get a black screen.
3. I haven't found a way to get out of that black screen within the app so I was forced to force quit the app.

I also sent a diagnostic report via mail in case you might need it.

1Password Version: 600016
Extension Version: -
OS Version: iOS 9 PB1
Sync Type: Dropbox


  • GreigAllenGreigAllen

    Team Member
    edited September 2015

    Thanks @eh801 for raising this issue with us. I've replied to your email, but thought I would let you know here too.

    Unfortunately this is a known issue with 1Password 6 for iOS. Our developers are aware of the issue and will hopefully have a fix out in a future beta version.

    Sorry for any inconvenience caused.

    ref: OPI-3040

  • Thanks for you quick reply! Glad to hear it's a known issue.

  • MikeTMikeT Agile Samurai

    Team Member

    On behalf of Greig, you're welcome.

  • I had a similar issue in 1Password for IOS. I could open and preview any JPG attachment but the PDF attachments didn't open at all. I got a message "My pdf ### kb" where ### showing the size of the PDF. After i clicked on the screen it turn to black and i only could close the app by removing it out of memory.

    Because I did not view my PDF attachments very often could not link this issue to an upgrade or installation of any kind. So i kept silence about this one.

    It happened only on my iPad Mini 2 Retina, all other versions on iPhone, Mac, Windows and iPad 2 worked fine.
    I have had also some syncing problems with iTunes so I decided to wait for IOS 8 and later IOS 9 in the hope this upgrade resolved this issue. Unfortunately this problem did not disappear.

    After all I decided to install the iPad Mini from scratch and reinstall Dropbox and 1Password at first to eliminate influence from other Apps, beta trials etc.

    After this action all my 1Password versions on all my equipment works fine and i could preview my PDF attachments.

  • sjksjk oversoul 1Password Alumni

    Hi @WGBeekhuis,

    Glad to hear you've got attachments opening in 1Password on your iPad Mini 2 now! Wish it hadn't taken a "nuke and repave" effort to make that happen. Thanks for letting us know about this and I apologize for any inconvenience it's caused you.

This discussion has been closed.