Safari extensions don't install (but no error message)

I've installed the last couple of releases of 1Password and after the most recent one, my Safari extension is gone, so I downloaded the extension (opened up 1Password 6 and chose install browser extensions form the menu). After the download, I double click the extension (4.5.3) file.
I get a message: are you sure you want to install the extension "1Password"?
I am, so I click Trust. The Trust dialogue box disappears but then nothing happens. No extension appears in the extensions window, no 1Password button in the browser bar, no activity/progress box - absolutely nothing.

How do I get the latest version of the extensions to install?

1Password Version: 1Password6 6.0.1
Extension Version: 4.5.3
OS Version: OSX 10.11.2
Sync Type: Dropbox


  • JacobJacob

    Team Member

    Hey @hedgert! Sorry for the trouble. We have an idea of what this may be. Could you try these steps to resolve it?

    1. Launch System Preferences and open the Keyboard pane.
    2. Switch to the Shortcuts tab.
    3. Toggle All Controls to selected.
    4. Re-attempt to install the extension and use the Tab key on the keyboard to highlight Trust.
    5. Press the Space bar key to press the Trust button once selected.

    Let us know if that gets things up and running again. I suspect it will, but I suspect many things. :sunglasses:

  • Thanks for the reply - I didn't know it was there - I didn't get a notification - which is weird!
    But alas the above didn't help.
    I've toggled all controls, but having done that, pressing the Tab key has no effect in terms of which button and area is highlighted. No amount of fiddling around with the keyboard changes anything, the only option is to click Trust with the mouse, and when I do that nothing happens. The extensions box just sits there there's no other activity and stubbornly no Safari extensions.
    It's a real pain without them - what else can I do?

  • Drew_AGDrew_AG 1Password Alumni

    Hi @hedgert,

    I'm sorry to hear that didn't help! From what we know so far, the problem seems to be that Safari isn't working right when clicking the Trust button with a mouse or other input device. So the key to the workaround is selecting that button with the Tab and Space keys. I don't know why that isn't working as expected for you, but I'm sure we can figure this out.

    Can you please confirm that when you went to System Preferences > Keyboard > Shortcuts, you enabled the option at the bottom for "All controls"? And if you go back to those settings, is that option still selected? When viewing those settings, you should also be able to press the Tab key several times to see different parts of that window become highlighted. Do you see that happen?

    If it's still not working, are you using a MacBook? And if so, are you using an external keyboard with that? If you are, try disconnecting the external keyboard and use the MacBook's built-in keyboard to try to choose the 'Trust' button.

    Does any of that help?

  • Hi Drew_AG,
    I can confirm that I followed the instructions about All Controls in keyboard settings, and when I go back into that panel the option is still checked.
    And yes, with that settings panel open, the Tab key does navigate me around from option to option.
    And after that going back to double click the extension, when the Extensions trust panel came up, this time the Cancel button was highlighted and when I hit Tab the focus moved to the Trust button and then I could select it with the space bar. Having hit space, the extension is now installed and all is well.
    I had rebooted my Mac (after a power cut) since we last chatted, not sure if that was in some way necessary after the settings change.

  • Drew_AGDrew_AG 1Password Alumni

    That's great news @hedgert, thanks for following up to let us know how it all worked out! It's strange that it didn't work before, but I'm glad it worked this time and that the 1Password extension is now installed.

    Hopefully it's all smooth sailing from now on, but if you need more help or have other questions, we'll be here for you! :)

This discussion has been closed.