"Please Unlock 1Password..." message too intrusive

I have 1Password Mac and 1Password iOS Pro set to sync over WiFi. Lately, i've noticed that almost every time I launch 1Password on my iPhone, it gives me the message “Please unlock 1Password on your Mac for Wi-Fi syncing to continue. 1Password encountered a problem.” I understand this to occur if my mac is open and it's trying to sync and my vault is locked.

What I don't expect should happen is that I would get this message when my mac isn't even awake. I can be on a whole other floor of my house, with my MBP quietly taking a nap, lid closed, and 1Password iOS is telling me I have to unlock on my mac. To make it worse, this message will repeat about every 30-60 seconds. Like, it doesn't take the hint or it doesn't recognize that 1Password Mac isn't "live" at the moment.

I had seen where someone Tweeted at you with the same issue back in February, and that's about when it all started. Before then, I don't recall receiving that message unless my mac was awake, and I opened 1Password on my iPhone but my mac's vault was locked. This should be the expected behavior, right?


1Password Version: 6.1
Extension Version: 4.5.5.90
OS Version: 10.11.4
Sync Type: Mac & iOS WiFi Sync; Mac-only also to DropBox

«13

Comments

  • I have 1Password for Teams and I have 1Password installed on my Mac (6.0.2), iPad Air (6.2.2), iPhone (6.2.2), iPad Pro (6.2.2).

    Recently, every time I open 1Password on an iOS device I get the following error message:
    "Please unlock primary 1Password vault on your Mac for Wi-Fi syncing to continue. 1Password encountered a problem."

    Suggestions?

    Thanks,
    Robert


    1Password Version: Not Provided
    Extension Version: Not Provided
    OS Version: Not Provided
    Sync Type: Not Provided
    Referrer: kb-search:Please unlock primary 1password vault on your Mac for Wi-Fi syncing to continue

  • @R9E have you set up your devices to sync by wi-fi? If so, when you unlock 1P on your Mac the sync should take place. If you don't want to sync at that time you can simply dismiss the message.

    Stephen

  • @Stephen, if I unlock the Mac it does indeed sync correctly. But the next time I open the same iOS device I get the error message again. Historically, once the Wi-Fi syncing was set up and correctly working, I did not get this error message every time.

  • BenBen AWS Team

    Team Member

    @R9E,

    Sorry for the trouble! In 1Password 6 we've made some improvements to the way locking works between 1Password mini and the main app, to make it both more reliable and more stable. Previously, 1Password for Mac could leave the Wi-Fi Sync server running at all times to automatically sync data. But now when the vault is locked this will no longer be possble. Much like Wi-Fi Sync in 1Password for Windows, 1Password for Mac will need to be unlocked first before Wi-Fi Sync can commence.

    Thanks!

    Ben

  • Ben,

    Thanks for the clarification.

    I think there needs to be a way to suppress the error message on iOS devices (e.g. "Don't show me this again" checkbox). At this point, every time I open 1Password on iOS I get that error message which really detracts from an otherwise great experience. To make matters worse, for some reason, I typically get the error message twice.

    Thanks,
    Robert

  • AGKyleAGKyle AgileSupport 1Password Alumni

    Hi @R9E

    I would agree. We haven't yet figured out how we'll be handling this, if at all, but a bug report has been filed.

    How exactly do you see this working in an ideal world for you? Any feedback you can provide for how you'd like to see it work can be added to the bug report.

    Thanks!

    ref: OPI-3314

  • I've encountered the same annoyance. I would suggest a checkbox, like R9E said, along with an indication somewhere on the home screen of how long it's been since 1Password has synced, so the user knows if it has been a while.

    I also don't think it needs to say "1Password encountered a problem.". It's a pretty normal situation; there's no need to treat it as an error.

  • BenBen AWS Team

    Team Member

    Thanks for the feedback, @PetWolverine. :)

    Ben

  • I'd like to add my voice to this. 1Password 5 on OS X and two iOS devices (iPhone and iPad) worked just fine. Upgrading ti 1Password 6 on OS X and now I get this strange error message that had me thinking I needed to do configuration changes or uninstall and reinstall. Confusion and frustration abounded.

  • BenBen AWS Team

    Team Member

    Sorry for any confusion and frustration, @michael. :(

    We did make some important changes that necessitate having 1Password for Mac unlocked before Wi-Fi sync can occur, and that is the reason you are seeing this message. Previously a sync could occur even if the Mac application appeared to be locked. That is no longer possible. If you'd like your devices to be able to sync more automagically we'd recommend 1Password for Families, 1Password for Teams, Dropbox, or iCloud.

    I hope that helps!

    Ben

  • I am having an issue syncing 1Password to my iphone 6. I have been able to for some time but it just stopped working. I deleted and reinstalled the ap on my phone. I see that when it looks to sync it comes up with the MacBook i am looking to sync to but it has the wrong IP. I dont see a way to change this. I upgraded my Macbook the the latest 1password beta. i still am not able to sync

    any ideas ?

  • BenBen AWS Team

    Team Member

    Hi @roadkill00

    Restarting the Mac should, in theory, refresh that information. Please let us know how it turns out. If that does not resolve the problem, have you considered an alternate sync method? I provided links to the options here. If you'd really like to stick with WiFi and it still doesn't work after rebooting the Mac please let us know.

    Ben

  • tried somethng different set the IP of the Mac to this IP displayed on the phone when looking to sync.

    now i recieve a error domain=NSPOSIXEErrorDO
    main code=9 " bad file descriptor"

  • BenBen AWS Team

    Team Member

    @roadkill00

    I'd like to ask you to create some Diagnostics Reports, one from each of your devices:

    Attach the Diagnostics Report(s) to an email message addressed to [email protected].

    Please do not post your Diagnostics Report(s) in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report(s) in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report(s) and ensure that this issue is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks very much!

    Ben

  • Hi AgileBits Team,
    Let me come back to this message "Please unlock primary 1Password vault on your Mac for Wi-Fi syncing to continue. 1Password encountered a problem."
    Today you have published a new IOS version and this issue is still there.
    I do not expect such a message at all, when I understand the previous posts correctly.
    Please fix it in next update.

  • BenBen AWS Team

    Team Member

    Hi @PeterOFre

    This message is definitely intended. Please see this post.

    Ben

  • Hi Ben, sorry, but I do not see any advantage in that message. If you read the other comments then I am not alone with that opinion.
    I am a 1Password user for many years and using only WLAN sync. And 1Password was working fine without this alert for a very long time.
    :-)
    I am an almost retired electronic engineer and I have developed many programs in my life here in Germany. I know what I am talking about. To stop this round the clock sync server is a good idea, but please re-phrase that message in a way that user understand it correctly. I guess you want to inform users that an automated sync is not possible without logging in on your Mac. You could combine it with the info that no sync has happen for x hours, days, years and that is is a good idea to do it now.
    Best regards
    Peter

  • BenBen AWS Team

    Team Member
    edited March 2016

    I see. Thanks for the feedback Peter. I thought you were saying we should do away with the warning entirely, which would leave folks unaware that their data is not syncing (unless they were to notice by themselves, which is rarely the way things go down). The first sentence of the message is the critical part. You need to unlock 1Password for Mac in order to sync with it. Perhaps we can remove or replace the second sentence.

    Ben

  • Yes, Ben.
    You could write "If you want to sync via Wi-Fi now, please unlock primary 1Password vault on your Mac."
    Btw, I have never expected an automated sync via Wi-Fi, it was always clear that I have to unlock the Mac AND open the sync menu.
    And you should really have an option to surpress this message or display it if the sync time is several days/weeks in the past.
    I guess you do not want to be like MS-Windows in the old days with all that reminders. And meanwhile you see all these ugly reminders on the Mac as well.
    I mean the Mac reminder for updates without the information what the Mac would like to update.
    :-)
    Peter

  • brentybrenty

    Team Member

    I guess you do not want to be like MS-Windows in the old days with all that reminders. And meanwhile you see all these ugly reminders on the Mac as well.

    @PeterOFre: Good point! I'm not sure what the best solution is here, but we certainly don't want that. Thanks for the feedback! :lol:

  • I would really like to see a way to get rid of this annoying reminder.
    If I'm working at home and not using my iMac, every time tap on 1Password on my iPhone this annoying reminder pops up. When my iPhone locks after a minute, it pops up again when I unlock it. The consequences will be that I'll stop syncing at all. Not I good idea.
    So please put in a configuration on iOS to stop that reminder. An easy one could be to stop it at all. A better one would be to remember once a day or a period that could be setup.
    And please change the message as PeterOFre proposed. There is no problem. It is normal that 1Password is locked when I'm not sitting in front of my Mac.

  • BenBen AWS Team

    Team Member

    Thanks, @vb_de. We are looking at how we can best reduce the annoyingness of this message, but still get the point across (syncing will not occur while the Mac is locked).

    Ben

  • Yes, I know that.
    So let me tell you two scenarios. Maybe that gives you a better look to my point of view.

    I'm sitting with my PC at home (home office) to do some administration task for our customer. Every time I look up a login or password the message pops up. Only because I'm working at home.

    A friend asks me for my wlan key while we are at my home. I look it up in 1Password an guess what message pops up ;-)

    I really don't need this message every time.
    Maybe you could change it from popup to banner?

    Volker

  • brentybrenty

    Team Member

    @vb_de: Ah, a notification. Well, personally I find those a bit annoying too, but we won't let that get in the way of considering that as another possibility. Thanks for the suggestion! :)

  • BenBen AWS Team

    Team Member

    Hi @eFlat7,

    I've merged your thread with another on the same topic. Please see above. :)

    Ben

  • I agree that the modal is very annoying. A toast would be sufficient and much less disruptive.

  • BenBen AWS Team

    Team Member

    Thanks for the feedback, @jvinding.

    Ben

  • I was not aware until know that sync between IOS app and mac (WIFI) is done automatically, when I wanted to sync I opened 1password on mac and pressed sync on IOS app. I also think that this message is annoying and missleading, I also thought there is an error in sync and I already reinstalled app with not solving the issue (now I understand why). My suggestion would be to remove the pop up window, and have a Text displayed under Settings->Sync e.g. In case of WIFI be aware that there is no automatic sync if 1Password is locked.

  • BenBen AWS Team

    Team Member

    Thanks for letting us know your thoughts on this, @mhaerb.

    Ben

  • I have 1Password Mac and 1Password iOS Pro 6.3.1 set to sync over WiFi. For the last several weeks, after an upgrade (I don't remember from which version), I very often get the the message “Please unlock 1Password on your Mac for Wi-Fi syncing to continue. 1Password encountered a problem.” when I launch 1Password on my iPhone or iPad. This happens even if my Mac is turned off, however not all the time, only sometimes. I find this quite annoying, especially since the message keeps popping up after dismissing it.

    I understand that my vaults are not sync'd when 1Password is not open on the Mac, and do not need a(n annoying) reminder for that. However, if a warning is deemed necessary, I would prefer a warning in Settings->Sync as mhaerb proposed combined with the option to set a (user-defined) periodic reminder if the vaults were not sync'ed in that time frame as proposed by vb_de.

    Please fix this with the next update, because otherwise the app is really great (and was perfect for me before this update).

This discussion has been closed.