No filling in Firefox

This discussion was created from comments split from: Firefox 47.0 missing 1password 4.5.6 extension button.

Comments

  • I think my problem is similar. I have Firefox 47 and 1Password 4.6.0.604. I have to manually copy paste the user names and passwords for the saved sites I want to visit. It used to autofill, but not any longer :-(
    Many thanks
    Andrew

  • brentybrenty

    Team Member

    @andyinmoreton: I'm sorry or the trouble! Just to be clear, 1Password does not "autofill"; that's a browser feature of questionable security merit (given that it allows anyone who can access your browser to login to your accounts).

    However, while 1Password won't take action without you telling it to, you can use the toolbar button or keyboard shortcut (Ctrl \) to have the 1Password extensions log you in to websites in your browser. Just make sure you're using the current version of both 1Password and the extension.

    If you're still having trouble, be sure to let me know the exact steps you're taking and what is or is not happening as you expect. And include the URL as well so I can test it myself to give you specific instructions. Thanks in advance! :)

  • Hi Brenty
    Thanks for getting back to me. Its probably my poor tech jargon that's confusing the issue.
    When I first began using 1Password, in my logins list I could click on the url of a site and it would take me to the site and log me in by automatically filling in the user name and password, which was great.
    For the last few months, when I click on any url in my logins list it takes me to the login page, but I need to manually fill in the user name and copy paste the password from 1Password, which is clunkier.
    I have downloaded the latest Firefox extension and am running the latest version of 1Password. Ctrl \, doens't generate a response.
    Many thanks for your help. Much appreciated
    Andrew

  • brentybrenty

    Team Member

    Thanks for getting back to me. Its probably my poor tech jargon that's confusing the issue.

    @andyinmoreton: Ah, don't blame yourself! Tech jargon can definitely be confusing! I'm really sorry you're having these problems. I hope you don't mind, but I've split you off into a separate discussion so we can focus on your particular issue.

    For the last few months, when I click on any url in my logins list it takes me to the login page, but I need to manually fill in the user name and copy paste the password from 1Password, which is clunkier. I have downloaded the latest Firefox extension and am running the latest version of 1Password. Ctrl \, doens't generate a response.

    Thank you so much for clarifying that. It sounds like you're not getting any kind of response from 1Password in Firefox at all: it isn't filling when you open a login from 1Password, and it doesn't fill when you press Ctrl \ either! :(

    I'm not able to reproduce this behaviour myself, so I suspect there's some difference between you setup and mine. Can you tell me which version of Windows you're using? And do you have any "security" software or other extensions installed that might interfere with 1Password? For example, some antivirus programs will prevent 1Password from functioning — or even installing properly. You might try disabling them temporarily to see if it helps. Please let me know what you find. I look forward to hearing back from you!

  • Hi Brenty
    I have recently upgraded from Windows 7 to Windows 10, but the issue pre-dated the upgrade and remains the same in Windows 10. I use AVG security software, which I temporarily disabled but this made no difference.
    Any more thoughts?
    Many thanks
    Andrew

  • brentybrenty

    Team Member

    @andyinmoreton: Thanks for following up! Just to clarify, do you see the 1Password extension installed in Firefox? Did AVG by any chance install anything in Firefox itself? That might explain why disabling the app didn't help. Please try this:

    1. Press Ctrl Shift Esc to open Task Manager
    2. You should see "1Password (32-bit)" showing up under "Background Processes"
    3. Please let me know in either case
    4. Open the main 1Password app
    5. Go to Help > Restart 1Password Helper
    6. Try using 1Password in your browser by clicking the icon
    7. Try using 1Password in your browser by pressing Ctrl \
    8. Try using the main 1Password app to open a login in the browser

    Please let me know your results. We will get to the bottom of this! :)

    1. 1Password (32-bit) does show up under background processes in task manager.
    2. I did the help>restart 1Password Helper
    3. I open 1Password by clicking the icon pinned to the bottom bar.
    4. 1Password is not 'in my browser'. It opens in a separate window. Is this why Ctrl \ does not work?
    5. Many thanks
    6. Andrew
  • brentybrenty

    Team Member

    1Password is not 'in my browser'. It opens in a separate window. Is this why Ctrl \ does not work?

    @andyinmoreton: It sounds like that's the issue! Please go install the extension from our site:

    1Password browser extensions

    Now, we may be out of the woods yet. You should be able to simply click the "Install" button and follow the prompts in Firefox to add it. If you run into any issues, it may be that AVG is preventing it from being installed in the first place. There are a few ways around that: disable AVG temporarily to install the extension, or download the Firefox extension using another browser and drag the file to Firefox to install it. Then you should be able to use the 1Password extension in Firefox. Please let me know how it turns out! :)

  • Hi Brenty
    I have tried disabling AVG and downloading from Chrome and dragging it into Firefox. Every time it says it has installed correctly, but does not appear in the Firefox browser. Any other thoughts?
    many thanks
    Andrew

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Hi, @andyinmoreton. One thing to try is a new Firefox profile with just 1Password installed to see if you have the problem there as well.

  • The Additional Tools and Features doesn't have the 1Password icon. Does this make any sense?
    Many thanks
    Andrew

  • brentybrenty

    Team Member

    @andyinmoreton: Ack! That doesn't make any sense whatsoever. Very frustrating! :dizzy:

    Did you try a brand new Firefox profile like jxpx777 suggested? It really sounds like the one you've been using may be corrupt. Installing any extension — 1Password or otherwise — should result in it showing up in Firefox settings and the button being available for the toolbar. Please let me know what you find!

  • All sorted now. Great support
    Many thanks
    Andrew

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Glad you got it sorted, @andyinmoreton! Let us know if you have any other questions or issues. We're always here to help. :)

This discussion has been closed.