Multi-line login

I am trying to save the login information for my library's website. The log in page contains 3 blanks, Username, Password and Phone Number. I only need to complete the Username and Password to get into the site, NOT the phone number. The phone number field is to remain blank.

The information is saved in 1Password. But, when I use 1Password to log in, it fills in the Username field and my password in the Phone Number field and leaves the Password field blank.

I can't figure out how to get 1Password to put my password in the Password field and NOT in the Phone Number field.


1Password Version: 6.3.1
Extension Version: 4.5.6
OS Version: 10.11.5
Sync Type: DropBox
Referrer: forum-search:Multiple passwords on website


  • Hi @jdentwistle,

    If you save a Login item from inside the browser does it make any difference?

    If you have an existing Login item you'll probably find the How to save a Login manually in your browser steps useful for creating a new one. I tried it out just now and it correctly filled the right fields because it had prior knowledge of what the page should look like and what fields you had entered data into.

    The reason it gets confused is your library is using a password field for the phone number and refers to the middle field in both the name and ID attributes as relating to the last name rather than as a field for a password. It's confusing 1Password and we're failing to correctly identify it. All of this should hopefully be bypassed though if you save inside the browser. Do you find the same as I do?

  • No. It did not work. When I followed the steps outlined in "How to save a Login manually in your browser" 1Password saved only my username. The password field did not even register. I deleted the login info in 1Password several times before trying the steps and it never worked for me.

  • PilarPilar

    Team Member

    Hi @jdentwistle,

    I'm sorry to hear that you're still having trouble, I tried saving the login manually and 1Password is working nicely on my end. I would like to confirm the steps that you've taken to save the login manually and please try one more time or see if something has been done differently. Please follow the next steps:

    1. Open exactly this link:
    2. Type username and type password. Leave phone completely empty.
    3. Go to 1Password mini, click on the gear and then on "Save new login".
    4. Leave it as "Create new" and click on "Save login".

    To test it, please refresh the webpage, go to the brand new entry and click on the login that you just generated. If you're still finding issues, can you please tell us in which step things go wrong?

    I hope to hear back from you to see if it all works or if we should take the troubleshooting one step further! :chuffed:

  • Hello jdentwistle,

    There's something I didn't clarify earlier and I'm wondering, did you visually inspect the new Login item and because you didn't see a visible password you assumed it had failed or did you try to fill using the new Login item and find it failed when it filled?

    As I mentioned before, 1Password is doing a bad job of identifying the correct password field but in my initial test it did save the password correctly and it was stored in the web form details section. We can work on manually adjusting the Login item to show the password below the username but we'll want to do that after we've confirmed it's working for you as it does for me.

    Obviously this doesn't apply if you're saying it didn't fill properly but I would hope filling works as I found it did when I tested. We'll know better when we hear back from you :smile:

  • So, here's what i just did.

    1. I deleted the 1Password form created yesterday so my library account is no longer anywhere in 1Password.
    2. I went to the library login page. Entered my username and password.
    3. I did NOT press return, but went to the 1Password icon in the menu bar of Safari. I selected the gear icon.
    4. I clicked on Save New Password. I accepted the default name for the site.
    5. I was logged into the library website.
    6. I logged out of the site.
    7. I went back to the library login page.
    8. Pressed command-\ to invoke 1Password.
    9. 1Password filled in only my username. The Password field was left completely blank.

    Then I went to 1Password and selected the library form. Here's what I did and what I saw.
    1. I clicked on Edit then the show web form details button.
    2. The "barcode" field has my username filled in.
    3. The lastName field has my password filled in.
    4. The phone field has nothing (there are some dots, but when i click on the dots, there's nothing there.
    5. rememberMe is checked
    6. display is set to Always
    7. submit is set to Submit when enabled.

    That's it.
    I put a screenshot of the 1Password form in my Dropbox. Access it at

  • brentybrenty

    Team Member

    @jdentwistle: Thanks for following up! I think I see what's happening here. It appears that 1Password is trying to fill, but the form itself isn't quite finished loading right only the "username" is filled. If you press ⌘ \ afterward, 1Password will be able to fill the password as well. And of course if you don't want it to fill the phone number, save your login without filling that. We'll see if we can improve this in a future version, but this workaround should help in the mean time. Thanks for bringing this up! :)

    ref: OPX-1202

  • Greetings @jdentwistle,

    I would be curious to know if brenty's explanation makes sense of the differences we're seeing. When I looked into what he's written I found that the page hasn't finished building itself (for lack of a better description) when the browser sends the finished loading event. This is what we use for open and fill as it's the only event that browsers offer, at least to the best of my knowledge anyway. Once the browser says the page is loaded we query the page and send the results to 1Password just like we do if you use the keyboard shortcut **⌘**. As the page isn't fully formed though it's missing several fields and we evaluate it differently as a result. If I fill after the page is fully loaded I continue to see the results I've obtained from my original testing. I believe there isn't a page has finished rendering so options here are likely to be quite limited.

This discussion has been closed.