TreasuryDirect.gov - Foiled Again!

My 1P browser extension has been working well on the treasurydirect.gov web site—up until today (or very recently.) The site is still using the on-screen virtual keyboard, and 1P used to fill in both the username and password fields on their respective pages, but now the password field sits blank. Any thoughts on how to get 1P working again on that password field? Thanks.


1Password Version: 6.3.3
Extension Version: 4.5.9
OS Version: 10.12
Sync Type: Dropbox
Referrer: forum-search:TreasuryDirect

Comments

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Hi, @bruce_in_shorewood. Thanks for your post. Sorry for the trouble. Could you let us know more about where to get to the sign in page that's giving you problems? I clicked around the various applications and various sign in buttons on treasurydirect.gov, but I wasn't able to find any page that matched your description of having an on-screen keyboard.

    Also, could you let us know a little more about the problem you're having?

    • When you open your browser, do you see the 1Password button in the toolbar?
    • What happens if you click the toolbar button?
    • If you visit the sign in page on a site for which you have a Login saved and click the button, does that Login show in the list that pops up?
    • If you see the Login, what happens if you select it?

    Thanks!

    --
    Jamie Phelps
    Code Wrangler @ AgileBits

  • Sure:

    Start here: https://www.treasurydirect.gov
    Click orange LOGIN button for the default TreasuryDirect application.
    On the orange question "Does your account number begin with a letter?" (mine does) click on "letter".
    Now you're on the Account Number page. Click 1P icon in browser toolbar (yes, it is there, and clicking it fills in my account number on this page.)(I usually use command-\ to activate the 1P extension, FWIW.)
    Click blue Submit box.
    Now the Password page comes up. This is the problem page. I am attaching a cropped screen cap. Doing a command-\ used to work in filling in the password field here. It no longer does. I have to go into 1P, reveal my password to see it, and tap the password out on the virtual keyboard. It doesn't even allow me to copy/paste into the field. Looking at the page's code, I see that the virtual keyboard is a javascript feature.
    I have sent TreasuryDirect feedback on this.
    This happens in both Safari and Chrome. (I'm on a Mac.)
    1P works great on every other web site I visit. But then, none of them use a "virtual keyboard"!
    Thanks, Jamie!

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Thanks for that, @bruce_in_shorewood. Sounds like I need a username in order to get to this page, so that makes things a bit more tricky.

    It's not clear from the screenshot which browser you're using (Looks like maybe Firefox if I had to guess?) but if you right click on the password field, do you have the option to Inspect Element or something similar? If you do, select it and it should show you the information about the field. You can simply take a screenshot of the highlighted code or copy the code itself if you're comfortable doing that.

    My guess is that the field is flagged as either readonly or disabled and that's why we're not filling it, but seeing the code will tell us more.

  • edited October 2016

    Here's the code for the password field. I think I got it all. It's attached in a screen grab.

    Just tried something, though: once I got to the Password page, I went into Safari's security settings and unchecked "Enable JavaScript" to turn it off. Then I reloaded the page. The virtual keyboard went away and I noticed that I had a blinking cursor in the password field. I tried to have 1P fill it in—no go. But I was able to copy the password from 1P and paste it into the field. So that's something. Still not great, but something.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Sadly, that confirms what I suspected. The readonly attribute (in the document.write line, which they seem to not have copied into the <noscript> portion below) is what is preventing 1Password from filling for you here. We recently changed this, and I have seen a couple more similar reports, so I think we may need to revisit this decision. Thanks for the report!

  • Thanks. And so I understand what you're saying, this is actually due to a change by AgileBits to 1P, and not due to a change by the Treasury to their site? Interesting. Yes, I'd love to see you revisit that, too!

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hello @bruce_in_shorewood,

    It is a change on our part and this site with a few others were an unintended side-effect of it. The reason we added it was we had also had reports of where not respecting read-only or disabled field status could cause problems and we didn't realise how many sites used read-only fields on their login pages. We're looking at ways to side-step this issue with Login items whilst keeping the benefits that caused the original change to the code. Hopefully we'll be testing something soon :smile:

  • littlebobbytableslittlebobbytables 1Password Alumni

    :+1:

  • Just checked my Treasury Direct account and Firefox did not fill in the password like it did before either. v6.3.3

    This is a terrible site as you can not paste your password in and the keypad entry does not differentiate between caps and small letters.

  • littlebobbytableslittlebobbytables 1Password Alumni

    We do intend to correct this @doctormo and hopefully it won't be too long now.

  • I just wanted to second this. I was so happy when 1Password worked on TreasuryDirect. Now I have to manually type it into their little keyboard and I'm sad again.

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @samjlord,

    Would you be willing to test our beta extension? It may be able to make you happy again and if it doesn't we would like to learn of this.

  • sure, I'll try it, @littlebobbytables. i tried installing the version 6.5.BETA-35, but that didn't fix the problem.

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @samjlord,

    In this particular instance the beta of the actual application wouldn't help, this one is inside the extension. It's not something you could deduce without knowing the actual code well so I certainly would never expect anybody to know without contacting us :smile: Please do let us know how you get along.

  • OK, how do I get the beta extension, @littlebobbytables ?

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @samjlord,

    1. Uninstall the stable extension.
    2. Restart your browser (this ensures no weird caching issues).
    3. Install the beta extension using this link, 1Password Browser Extensions
    4. Re-authorise the extension with 1Password as it's a fresh copy of the extension. This should happen automatically as soon as the extension finishes installing.

    That should be all it takes :smile:

  • Yeah, that worked. Thanks, @littlebobbytables

  • brentybrenty

    Team Member

    Excellent! Thanks for the update. On behalf of lil bobby, you are most welcome! I'm glad to hear that all is well. It sounds like you should be all set, but don't hesitate to reach out if we can be of further assistance. Cheers! :)

This discussion has been closed.