I can't figure out how to move my data to a family account

It finally dawned on me that I was supposed to scan the code in the Emergency Kit! Or was I? When I did that it told me I was already signed up and I should add another device or another user. But that's not what I want to do!
I want to move my existing 1Password data. Right now there are only 3 items in my account. That's quite a few less than I have on my computer.
I need a step by step guide. A clear one - not one that says "scan the code". I really thought the code was on my computer in 1Password. Spent a half hour looking for it. How else would the new program know where to find my data if it weren't on the computer?
I'm sorry, I've tried to find answers in the knowledgeable base but can't wade through all the weird outlier problems and Windows issues. I did see advice to read the manual but have no idea where to find it.
Mac OS 10.12.3


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:I can't figure out how to move my data to a family account

Comments

  • rickfillionrickfillion Junior Member

    Team Member

    Hi @k8user,

    I'm really sorry that this has been as painful as it sounds.

    I just want to make sure I'm not making an incorrect assumption here... you've got 1Password on your Mac and it has a bunch of items already that you'd like to move over to the Families account. Is that right? If so, let's carry on and if not let me know.

    Using the Mac app, you should be able to go to Preferences > Accounts. There you'll see that no accounts are listed. Click on the "+" button to add your Families account. It'll give you the option to scan the code... this is the QR code that's on your Emergency kit and also available on the "Get The Apps" page of the website. Once you've scanned the code it should just leave you with the Master Password to put in.

    Once you've signed in, it should add the account to the Mac. If you only have a Primary vault on your Mac, the Mac app should automatically prompt you at this point to move your items over to the Families account. If this happens, you should say yes and the next question it asks you is if you'd like to remove the old (now unnecessary) Primary vault. You should say yes to this as well.

    If you don't get prompted for the automated migration we can mimic what it does quite easily:

    • Using the Vault Picker in the upper left hand corner of the window, select the Primary vault
    • Select 'All Items' in the sidebar, and then select the first item in the list.
    • Scroll down to the bottom of the list and shift-click the last item. This should select all items in the vault
    • Use the Item > Share > Family Account Name > Personal > Copy menu item

    If you have any vaults except for Primary, you'll want to login to the website and create new vaults to mimic the other vaults you had and do the same procedure. Most people don't have this.

    Once you're done you'll want to delete all of the non-Families vaults you had, and once you're down to just the Primary vault and your Families account, you can go to Preferences > Advanced, and uncheck the checkbox at the bottom that says "Allow creation of vaults outside of 1Password accounts." This will guide you through the process of removing the Primary vault.

    At this point you should only have your Families vaults (Personal, Shared, and any others you've created) on your Mac. To unlock the Mac app you'll be using your Families account password.

    We also have a support article that goes through these steps if you'd like to see them in action:

    https://support.1password.com/migrate-1password-account/

    Let me know if you have any more questions.

    Rick

  • Thank you for what looks like a really careful and thorough step-by-step.

    Your assumptions are correct. Also I have been able to move items from my iPhone and iPad to my family account but since, in spite of numerous attempts to sync over the years, none of the sets of data were complete so I need the data from the Mac, too.

    Unfortunately things fell apart at step 1. When I go to Preferences/Accounts there IS an account - the new family account. So I went down to your "If you don't get prompted..." paragraph and copied my data.

    The next problem was Item/Share/Family Account Name/Personal. There is no "Personal" so I clicked on "Private/Copy. This seems to have worked.

    Now I can't delete the Private vault on my Mac. The Delete Vault Item is dimmed.

    Thank you again for your help.

  • FrankFrank

    Team Member

    Hi @k8user - Thank you for the update and additional details :-) Sorry for the confusion on the vault name. We recently made some changes on our end renaming the Personal vault to Private. If you migrated all your existing 1Password data over to your Private vault (the one connected to your Families account), you can delete your original Primary (local) vault.

    First let's everything up -

    Open & unlock 1Password on your Mac > Click File in the menu bar then select 'backup' from the drop down menu. Click 'backup now' to create a backup of your Primary vault.

    To delete your Primary vault, please follow the steps below -

    Click 1Password in the menu bar > Select "Switch to Vault" and choose Primary from the list > Click 1Password in the menu bar and select "Delete Vault" from the drop down list. You will have to enter your master password before you can delete the vault.

    I hope this helped and let us know if you have any additional questions :-)

  • Thank you for your help and encouragement.
    I did the backup.
    "Delete Vault" is still greyed out.

  • FrankFrank

    Team Member

    Hi @k8user - Hmmm... Do you have any secondary vaults besides your Primary vault? I apologize, I should have mentioned this previously, you will have to delete any secondary (local) vaults before you can delete your Primary vault. Once you delete the other vaults, you should be able to remove your Primary vault. Keep me posted if this helped or if you have any additional questions :+1:

  • The only other non-Family Vault is "Shared"(no items in it) which I can't recall setting up but deleting that one allowed me to delete the "Primary".
    Thanks!

  • FrankFrank

    Team Member

    Hi @k8user - Fantastic news! Thank you for the update :-) I'm happy to hear that worked for you. If you have any further questions don't hesitate to reach out to us, we're always happy to help out :+1:

This discussion has been closed.