Not syncing between iPhone and desktop

Options
PatriciaW
PatriciaW
Community Member

I'm using Dropbox to sync and am getting no errors but the database is not syncing. I've added unique entries on both but they do not show up on the other platforms. What do I need to ensure that it does?

Comments

  • PatriciaW
    PatriciaW
    Community Member
    Options

    I realized that I had changed the master password on my iMac but not on my iPhone. I changed it on the iPhone but it did not help. How can I get them to sync. Dropbox shows that 1Password files is updated when I do that but it appears that the iMac version is not reading it. And when I update an entry on the iMac version it does not change the date on the files on Dropbox. I did not change the Dropbox password. When I look at the Sync preferences on the iMac it has changed the sync date. Is it possible that there are 2 different entries in Dropbox and if so how do I merge them?

  • Drew_AG
    Drew_AG
    1Password Alumni
    Options

    Hi @PatriciaW,

    I'm sorry to hear you're having some trouble syncing via Dropbox! You didn't mention what version of 1Password you're using on your Mac and iPhone, but I'll assume it's version 6 (if not, please let us know the exact version on each one).

    Let's start by checking the sync settings on your Mac and iPhone to see if we can find a problem there:

    On your Mac:

    • Open 1Password and go to 1Password > Preferences in the menu bar.
    • Click the Sync tab.
    • Make sure it shows your Primary vault is set to sync with Dropbox.
    • If it shows a different sync option or says None, set up sync with Dropbox by following the steps here: Sync with Dropbox (Mac)
    • If Dropbox is already enabled in the sync preferences, check the file name and file path for the sync file in Dropbox.

    On your iPhone:

    • Open 1Password and go to Settings > Sync > Primary.
    • Make sure it shows the Sync Service is Dropbox.
    • If it shows a different sync service or says Start Syncing, set up sync with Dropbox by following the steps here: Sync with Dropbox (iOS)
    • If Dropbox is already enabled in the sync settings, tap "Sync Service" and check the file name and file path for the sync file in Dropbox (underneath Current Sync Method / Dropbox).

    If the problem is that one is syncing with a different sync file than the other, you'll need to disable the sync, then set it up again and choose the correct sync file.

    Let us know how it goes and what you find, thanks!

  • PatriciaW
    PatriciaW
    Community Member
    Options

    I had already done this although it is very hard to see the file name on the Mac because of the way it folds. It is definitely set for Dropbox/Apps/1Password/1Password.agilekeychain and there is only one such folder on my Dropbox disk. iPhone syncing is set for Dropbox and the file is /Apps/1Password/1Password.agilekeychain (same file)

  • PatriciaW
    PatriciaW
    Community Member
    Options

    I should add that the most recent date on the data/default folder is 4 hours ago which corresponds to the last change to the desktop 1Password whereas the iPhone version sync'd while I was checking this (minutes ago.)

  • PatriciaW
    PatriciaW
    Community Member
    Options


    I see 2 entries here ... the time of the one starting DF3 corresponds with the changes I made to my iPhone, whereas the other one is for my iMac changes

  • Drew_AG
    Drew_AG
    1Password Alumni
    Options

    Thanks @PatriciaW! It's possible there's a problem with the sync file in Dropbox, so you can try resetting that to see if it helps. First, you should backup your data as a precaution. On your Mac, open 1Password and go to File > Backup. On your iPhone, you can follow the steps here: 1Password backups

    When you're ready, go ahead and follow these steps to reset Dropbox sync:

    On your Mac:

    • Open 1Password and go to 1Password > Preferences > Sync
    • Change the sync setting from Dropbox to None.
    • Click the box to Delete data from Dropbox, then click Disable Sync.
    • Open your Dropbox folder on the Mac and make sure the .agilekeychain has been deleted.
    • In 1Password, go back to Preferences > Sync and change it from None to Dropbox.
    • Click the Choose button and select your main Dropbox folder (then click Open).
    • Click Create New to create a new sync file in Dropbox.
    • Allow Dropbox to fully sync.

    Your iPhone should stop syncing when it realizes the old sync file was removed from Dropbox, and will give you an error message about that (which is expected). You can follow these steps to re-enable Dropbox sync:

    On your iPhone:

    • Open 1Password and go to Settings > Sync > Start Syncing.
    • Choose Sync with Dropbox.
    • When you see your Dropbox account name, tap on the name (do not tap on the 'i' icon).
    • When asked to choose a vault, choose the new sync file you created on your Mac.
    • Choose to merge the vaults and enter your master password if prompted.

    Please let us know how it all goes, and if you have questions about any of that.

  • PatriciaW
    PatriciaW
    Community Member
    Options

    Definitely a problem ... I followed the instructions up to disable sync but the agilekeychain is still there with the same values as in the screenshot I sent yesterday. I even went ahead and restarted syncing to Dropbox but it didn't change anything. I did the same on my iPhone and after I re-enabled sync it started uploading files to Dropbox (i can see them) BUT there is a red error message below the Sync Service entry saying "Failed to upload file to Dropbox". It looks like it thinks I have different Dropbox accounts.

  • PatriciaW
    PatriciaW
    Community Member
    Options

    A bit more checking ... it seems that my desktop is saving to .opvault and my iphone to .agilekeychain

  • Drew_AG
    Drew_AG
    1Password Alumni
    Options

    Hi @PatriciaW,

    When you disable sync with Dropbox, the sync file won't be deleted from your Dropbox folder unless you select the "Delete data from Dropbox" option, as I described in the steps I sent you:

    • Change the sync setting from Dropbox to None.
    • Click the box to Delete data from Dropbox, then click Disable Sync.
    • Open your Dropbox folder on the Mac and make sure the .agilekeychain has been deleted.

    But that's not a problem: you can simply find the .agilekeychain file in your Dropbox folder and drag it to the Trash. Your iPhone will give you an error when it realizes that sync file is missing, and you just need to re-enable sync on your iPhone and choose the new .opvault sync file (it's a newer sync format).

    Let us know how it goes, thanks! :)

  • PatriciaW
    PatriciaW
    Community Member
    Options

    Will the two files get merged?

  • PatriciaW
    PatriciaW
    Community Member
    Options

    I went ahead and now the two databases match. Did I miss some instructions when the new format got introduced?

  • Drew_AG
    Drew_AG
    1Password Alumni
    Options

    That's great news @PatriciaW! I'm glad it seems to be syncing correctly now.

    The OPVault sync format has actually been around for a number of years now, but it wasn't always supported by the 1Password app on all platforms, so it didn't become the default format until a little over a year ago. The Agile Keychain format still works well for syncing your data though, so it's not necessary to switch. The general differences are:

    • Agile Keychain is an older format, and is more compatible with older versions of 1Password.
    • OPVault is a newer format, and is a bit more efficient.

    Hopefully you're all set now, but if you need more help, just let us know. :)

This discussion has been closed.